Mixing RAM PC3-10600 & PC3-8500 ?



I have a used e-Machine that I got for free from a cousin. It came with just a 1 GB Kingston RAM stick(PC3-10600). I recently tried to upgrade with a used 3 GB RAM (PC3-8500) combined with the original giving me 3 GB. Initial tests with MemTest86 (Hirens CD) seemed to suggest this would work. I even saw some improved performance with a few games I was trying.

However, I thought Debian was running odd. Since I was interested in Gaming, and Valve officially supports Ubuntu, I decided to try it and then Xubuntu. On both Ubuntu and Xubuntu, I've had Firefox and Chromium crash. Chromium gives me the "Aww Snap" screen saying something failed. After searching Google, I found a forum post saying a person confirmed bad RAM was causing their browser crashes.

I left the computer running all day with some browser tabs open while I was running errands and left only the original 1 GB RAM stick in. So far, I've seen no indication of crashing. I've also done a shorter test using only the 2 GB stick and it seemed to resolve the problem.

I am not a major hardware guy, so tweaking this desktop hardware is a good learning experience for me. I just thought I'd get a second opinion here on whether I'm on track with this.

Try linuxmint I think it is a smoother running OS it is true that ram could be the problem... however bad ram would more likely to cause a system crash than just one program..
For the sake of it try to switch the banks around, check to see if your ram speed is matched, pull one ram stick out at a time to see if you can get a different results.
insanity is doing the same thing over and over again and expecting a different result.
And one last thing... try this search for linux-command-check-memory-usage
Thanks I appreciate the feedback. I'll try some more tests and maybe try another OS. I'm wondering if the problem is purely hardware related due to the new 2 GB stick.

I tried booting Linux Mint with the used 2 GB Ram stick in. It ran but it was glitchy. Next, I installed MemTest86+ and powered off the machine.

I removed my original working RAM stick and left in the one I suspected was bad. Linux Mint tried to boot, but I think it was showing memory addressing errors. I tried booting again, but this time in the GRUB menu I picked MemTest 86+. I left that running a while to scan and test while doing other things.

After 7 tests, it was showing a lot of error flags. I think this RAM was in a condition that it could sort of work, but created instability, even with Live Linux distros running.

Members online