Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

Mint terminal will not recognize password.

Discussion in 'Command Line' started by Greentea, Apr 2, 2018.

  1. Greentea

    Greentea New Member

    Joined:
    Mar 25, 2018
    Messages:
    6
    Likes Received:
    4
    Terminal will recognize text, but not my password. I know, it is not made visible. I know my password. No, caps lock is not on.


    (log in to hide this advertisement)
    Am I overlooking something?

    Any help appreciated. Thanks.
     
    wizardfromoz likes this.
  2. JasKinasis

    JasKinasis Well-Known Member

    Joined:
    Apr 25, 2017
    Messages:
    183
    Likes Received:
    296
    What program/application is asking you for your password? Are you doing something via sudo? or is this some other program?

    Do you get any error messages?

    If this is related to the use of sudo - Is your user a member of the sudo group?
    You can find out by using the following command:
    Code:
    groups
    
    Which will list all of the groups your user is associated with.

    If your user IS in the sudo group - then sudo should work and the only sane explanation is that you have entered your password incorrectly. The only other thing to try might be to change the password for your account, then log out and log back in again.

    If your user isn't in the sudo group (i.e. "sudo" is not included in the output from the groups command) - then you will have to log in as another user with root access and then add your user account to the sudo group.
    e.g.
    Code:
    sudo usermod -a -G sudo username
    
    Where username is the user to be added to the sudo group.
    I'm not a Mint user, but there's probably also a GUI based user-management application that will allow you to add superuser privileges to your account - assuming that is what you are trying to do.

    But before we go too far down the user-management rabbit-hole - I think the first thing to do is get clarification from you about which application is rejecting your password and whether or not your user is a member of the "sudo" group.
     
    #2 JasKinasis, Apr 2, 2018
    Last edited: Apr 4, 2018
    wizardfromoz likes this.
  3. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    953
    Likes Received:
    885
    Not that comes to my mind. Having no explanation doesn't preclude a solution though: reset your password (even to the same thing, if you want). It's a fairly easy process in Mint... take a look here. I use Mint also, and I tested the first method which worked fine for me.

    Cheers
     
    wizardfromoz likes this.
  4. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    698
    Likes Received:
    729
    @Greentea - hi Mate :p

    Just let us know if that worked for you or not? If not, there are other possibilities ;)

    Wizard
     
    atanere likes this.

Share This Page