mint power problem

phw17

New Member
Credits
28
on mint 19, on acer laptop, shutdown is not clean. eventually installed v20....same problem. help please.
 


arochester

Moderator
Staff member
Gold Supporter
Credits
2,109
What do you mean by "shutdown is not clean"? What happens? What do you see? Are you shutting down from the menu and choosing "Shutdown"?
 

phw17

New Member
Credits
28
I use 'Shutdown' from the main menu. The screen ends up blank except for the usual linux mint logo. The machine is then 'hung', no other options possible until I use the force restart via the power on/off key, holding it down for 4 secs. These symptoms are the same for v19 and v20. I have also noted problems when, several months ago, I selected 'Suspend'. After that I stopped using suspend at all. Hope you can help. Overall I'm very pleased with mint, its just this one irritating problem that I'd like to get fixed. Thanks for your help.
 

sam444

Member
Credits
318
How old is the HDD ?

It's possible the HDD might be failing, I'm no expert but the first thing I'd do is swap the problem HDD and see if the problem still exists.
 

phw17

New Member
Credits
28
I bought the laptop new 6 years ago. So your suggestion sounds interesting. Its started me off on a whole new line of thinking. Thanks so much for that. I tested the disk with no obvious problems, but that's not conclusive. Buying a new HDD is possible but, of course another installation of mint. A bit unsure. Maybe there are other explanations? Hope so.
 

Condobloke

Well-Known Member
Credits
5,108
Make sure the EUFI/ Bios is in Legacy mode and not active with Fast boot

Do yu have a nVidia graphics card ?

Have you updated the nVidia drivers yet by default Linux does not have nVidia drivers it uses nouveau drivers which work ok on older nVidia cards but not so great on newer ones

To add the Proprietary GPU Drivers PPA in Linux Mint and update the software sources in the terminal, use the following commands:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt update

Close terminal then open the Driver Manager and install latest nVidia drivers - then reboot.

Source, from HERE
 


Members online


Latest posts

Top