Mint Cinnamon 19.2 32bit Slow Bootup after Installed

JohnN3AOF

New Member
Joined
Jun 3, 2017
Messages
7
Reaction score
0
Credits
68
Hi, I installed Mint Cinnamon 19.2 on a Dell Inspiron 1520 32bit laptop. It has 3G memory and 1.5GHZ CPU.
It takes about 7 minutes to get booted up. Note: First installed on a 120GB HD. I tried a 240GB SSD, but it did not make any improvement on the bootup speed.

Anyone have a suggestion?

Thank You in advance, John

UPDATE, PROBLEM SOLVED:

Thanks to the responder(s) for suggesting I install the Mint 20.3 64 bit. I did and BY GOLLY! the boot up
time is FAST!!!

FYI: "System Information" (Windows XP) on this Dell Inspiron 1520 indicates this is a "X86 system" (may not
be exact words).

Also, THANKS to everyone, JohnN3AOF



Reply
Report Edit Delete
 
Last edited:


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,508
Reaction score
2,338
Credits
26,112
Welcome to the forums

Try something a bit lighter, MX19-32bit, peppermint 10-respin-32bit [I have used both of thease on old 32 bit laptops] or Linux lite.
But my question is why a 32-bit Linux, I am sure insperon 1520s had Intel Core 2 duo 64-bit processors the same as my 1540

Addendum it is the same age and basic spec as my 1540, EXCEPT the processor is the lowest in the range, so whatever you install it will never set the world on fire speed wise.
 
Last edited:

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,444
Reaction score
1,257
Credits
10,367
Hello @JohnN3AOF,
Welcome to the Forum.

As much as I like Mint I would agree with @brickwizard you would be better off with MX. Mint 19.2 is no longer receiving active support. Just security updates. So you may be better off with a lighter Distro. 3 Gigs of ram is not a lot for Cinnamon desktop either.
 

Old Tom Bombadil

Active Member
Joined
Jul 29, 2020
Messages
153
Reaction score
225
Credits
1,409
It takes about 7 minutes to get booted up.
Of course that's not normal, even with a low-spec system. You could have some hardware failing, or perhaps a serious misconfiguration of the operating system or BIOS settings. Some things you might try:

1. A simple thing first: Be sure you do not have any external devices plugged into the laptop while booting. No external drives, no external monitors, no cameras, not even a USB keyboard or mouse. Just your AC power adaptor only.

2. Open a terminal and enter systemd-analyze blame. That may point out some clear culprit. What is taking up all that time?

3. Run "memtest" from your GRUB prompt. This takes forever, so be sure to connect to AC power and start it in the evening, letting it run overnight. It may identify RAM problems. If it does (or even if it doesn't) you could try to remove and reinsert the RAM chips. Doing this helps to clean the contacts for a better electrical connection. If RAM is supicious, you can also try to remove one stick at a time and just boot/run with the other one, then switch them and try again.

4. Reset BIOS to all default values and install a 64-bit Linux instead. Mint XFCE would be easier on your RAM than Cinnamon, but you could try other distros too, as recommended by others above. If you have a UEFI BIOS, you may need to change some settings to non-default values, depending on which Linux you want to try.

Ubuntu, Linux Mint, Linux Lite, Fedora, Zorin, and others, will likely work with all default BIOS settings, even Secure Boot enabled. But it's a good idea to use the proper partition table on your HDD or SSD to match your BIOS. That is, if you will use UEFI settings in BIOS, you should set the partition table on your drive to GPT. If your BIOS is not UEFI capable, or if you will use Legacy BIOS (also called CSM) settings, you should set the drive partiton table to MBR (called "msdos" by Gparted). If this doesn't make sense, then it could be part of the problem... a misconfiguration, as I've mentioned already.

While 3GB of RAM is not a lot, it should work to run a great many Linux distros comfortably enough. This should not be your slowdown unless RAM is failing, or unless you have a mismatched pair of sticks.

Good luck!
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,157
Reaction score
6,993
Credits
66,234
Well, we could at least look into the problem before just yelling out names of other distros. LOL

What's the output from:

Code:
systemd-analyze blame
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,444
Reaction score
1,257
Credits
10,367
Also what is the output of
Code:
inxi -FXXZ
 

Old Tom Bombadil

Active Member
Joined
Jul 29, 2020
Messages
153
Reaction score
225
Credits
1,409
Well, we could at least look into the problem before just yelling out names of other distros. LOL

What's the output from:

Code:
systemd-analyze blame
That's why I mentioned systemd-analyze blame early (at #2) and not at the end.

But icode tags don't stand out as well as code tags. Oh well. LOL
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,157
Reaction score
6,993
Credits
66,234
That's why I mentioned systemd-analyze blame early (at #2) and not at the end.

But icode tags don't stand out as well as code tags. Oh well. LOL

Though it looks like it, your post wasn't there when I pressed submit on mine. There was some overlap. So, I never read your post. I still haven't read it - but I did skim it. So, I got that going for me.

I tend to open the entire page worth of posts in a new tab and then work through 'em. So, that happens from time to time. Sometimes the system will tell me that a new post has been posted but that's not consistent.
 
OP
J

JohnN3AOF

New Member
Joined
Jun 3, 2017
Messages
7
Reaction score
0
Credits
68
Well, we could at least look into the problem before just yelling out names of other distros. LOL

What's the output from:

Code:
systemd-analyze blame

Well, we could at least look into the problem before just yelling out names of other distros. LOL

What's the output from:

Code:
systemd-analyze blame
At terminal, I typed "systemd-analyze blame". Pages with lines of "actions" displayed with duration for each. The longest duration was 32.* seconds. There may have been about 4 actions that took that long. Most actions took milliseconds. Some took 1-9 seconds (I think).

I also have another laptop (64 bit, 2.6 GHZ) with Mint Cinnamon 20.4. That boots up very fast. I did
not time how fast.

I am confused about "
Code:
" prefix and suffix to "systemd...."  command?
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
8,157
Reaction score
6,993
Credits
66,234
Depending on what was taking that long, you can mask or disable them entirely.

Disable stops it from running during boot and mask disables it entirely.

As you didn't show us said services, we can't really offer any suggestions.
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,508
Reaction score
2,338
Credits
26,112
Let's cut to the chase, give us the full spec of the offending computer, by running in a terminal sudo inxi -Fnmxz and pasting the results back here, [you could also run it on the other machine and do a side by side comparison]
you may have to install inxi [apt-get install inxi]
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,508
Reaction score
2,338
Credits
26,112
As I said in post #2 your laptop has the same basic components as mine except I have 4mb ram and a top end processor for that time a [2.3gh twin core] which will boot mint + cinnamon in 1m50s
yours should have the Intel Core 2 Duo T5250 2 x 1.5 GHz [64 bit] processor
 
OP
J

JohnN3AOF

New Member
Joined
Jun 3, 2017
Messages
7
Reaction score
0
Credits
68
That's why I mentioned systemd-analyze blame early (at #2) and not at the end.

But icode tags don't stand out as well as code tags. Oh well. LOL
Hi, I received an error when I tried to reply regarding using "systemd-analyze blame" in Terminal. I hope this Reply "works". Note: This is a Dell Inspiron 1520 32BIT laptop that had Windows XP (did NOT take long to boot).
Pages of "actions" were listed. The time for each action amounted to 32 seconds for about 4 actions. Some
actions around 1 to as much as 9 seconds. Most actions took milliseconds. There is NOTHING wrong with
this laptop's hardware.
Maybe there is some things I can DISABLE (not necessary) during boot up?
Thank You in advance, JohnN3AOF
 

Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
5,617
Reaction score
4,696
Credits
34,228
Disable stops it from running during boot and mask disables it entirely.

As you didn't show us said services, we can't really offer any suggestions.
 
OP
J

JohnN3AOF

New Member
Joined
Jun 3, 2017
Messages
7
Reaction score
0
Credits
68
Let's cut to the chase, give us the full spec of the offending computer, by running in a terminal sudo inxi -Fnmxz and pasting the results back here, [you could also run it on the other machine and do a side by side comparison]
you may have to install inxi [apt-get install inxi]
In Terminal, I tried "apt-get install inxi" (without quotes). Results: "Could not open lock file.....(13: Permission denied)".

What about an app I saw in Software Manager called "Check Install"? Could this be helpful?

Thanks in advance, JohnN3AOF
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,508
Reaction score
2,338
Credits
26,112
Try open mint menu, open software manager, put inxi in the search box and enter, that should bring up the older version in mint 19 and install
I think you have a corrupt installation of mint.
Humour me … download mint 20.3 Xfce 64 bit burn to either a good clean USB or a new DVDr and try to run it live, if my suspicions are correct it should work
edit… if you're new to Linux use this article as a checklist https://linux-tips.us/how-do-i-install-linux-a-general-guide/
 
Last edited:

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,444
Reaction score
1,257
Credits
10,367
If software manager or synaptic is open then you won't be able to install it in the terminal. make sure all package managers are close and re try the command
 
OP
J

JohnN3AOF

New Member
Joined
Jun 3, 2017
Messages
7
Reaction score
0
Credits
68
In Terminal, I tried "apt-get install inxi" (without quotes). Results: "Could not open lock file.....(13: Permission denied)".

What about an app I saw in Software Manager called "Check Install"? Could this be helpful?

Thanks in advance, JohnN3AOF
UPDATE, PROBLEM SOLVED:

Thanks to the responder(s) for suggesting I install the Mint 20.3 64 bit. I did and BY GOLLY! the boot up
time is FAST!!!


Also, THANKS to everyone, JohnN3AOF
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
3,508
Reaction score
2,338
Credits
26,112
If you had confirmed the laptop spec we could have got there quicker, What made you think it was a 32 bit machine?
You could make it faster by upping the ram to 4mb [If it has the motherboard that I suspect then I have a feeling it may be possible to take it to 8mb, but more investigation is necessary]

edit .. if your now happy , please go back to your first post and edit the title to include "Solved"
 
$200 Digital Ocean Credit
Get a free VM to test out Linux!


Staff online

Members online


Top