midi keyboard doesn't work in LMMS

srgslogin

New Member
Joined
Dec 24, 2017
Messages
6
Reaction score
1
Credits
0
Midi keyboard doesn't work in LMMS in Debian Linux. It appears in LMMS as Input, but performs no sound when a key is pressing. I tried using QJackCtl, "a2jmidid -e" and most available options.

LMMS settings:
sound driver = Jack
midi driver = ALSA seq

QJackCtl settinhs:
driver = ALSA
midi driver = seq
ALSA seq support enabled

2017-12-29_19-24-58.png


2017-12-29_19-24-27.png


Output of a2jmidid -e:
JACK MIDI <-> ALSA sequencer MIDI bridge, version 8 (7383d268c4bfe85df9f10df6351677659211d1ca) built on Thu Jan 1 05:00:00 1970
Copyright 2006,2007 Dmitry S. Baikov
Copyright 2007,2008,2009,2011,2012 Nedko Arnaudov

Bridge starting...
Using JACK server 'default'
Hardware ports will be exported.
Cannot lock down 82274202 byte memory area (Cannot allocate memory)
Cannot use real-time scheduling (RR/5)(1: Operation not permitted)
JackClient::AcquireSelfRealTime error
Bridge started
Press ctrl-c to stop the bridge
port created: Midi Through [14] (capture): Midi Through Port-0
port created: Midi Through [14] (playback): Midi Through Port-0
port created: GarageKey mini [20] (capture): GarageKey mini MIDI 1
port created: GarageKey mini [20] (playback): GarageKey mini MIDI 1
port created: LMMS [131] (playback): TripleOscillator
ERROR: a2j_port_create: jack_port_register() failed for 'LMMS [131] (playback): TripleOscillator'
ERROR: a2j_port_create: jack_port_register() failed for 'LMMS [131] (playback): TripleOscillator'
ERROR: a2j_port_create: jack_port_register() failed for 'LMMS [131] (playback): TripleOscillator'
 


Just passing through, have a quick question or two and I'll be back when I can.

@srgslogin

Have you add yourself to Group Audio in Debian? If not

Code:
sudo usermod -a -G audio yourusername

In my case, that would be

Code:
sudo usermod -a -G audio chris

and then try your steps again.

You would have to logout at the least, or else reboot, first.

Cheers

Chris Turner
wizardfromoz
 
Have you add yourself to Group Audio in Debian?

I am in this group. I don't know what happened but the midi kbd works now (even without jack server running). Maybe installing of Jamin added me in Audio group automatically or "apt-get install -f" made some changes.
 
@srgslogin

Shame on LMMS (Linux DAW), for instructions only for Windows.

Yes, I found that rather curious. For the benefit of The Viewers, LMMS stands for Linux MultiMedia Studio ... so you would think they would have a focus on explaining things for Linux Users? :confused:

I don't know what happened but the midi kbd works now (even without jack server running). Maybe installing of Jamin added me in Audio group automatically or "apt-get install -f" made some changes.

That may be so. I regret that (currently) I know very little about this subject, and do not have a keyboard to practise with, but that may change.

@srgslogin , I noticed when first I read your thread, and Googled up a few reference topics in a hope to assist, that you have this thread open http://lmms.io/forum/viewtopic.php?f=7&t=26694 , but that you had not had any further help from them since 21st December or so.

I understand, that you would wish to seek help elsewhere, and you are welcome here :D, but do understand that if you seek help at multiple forums, it can get confusing if we, and they, do not know what is being said elsewhere ... so bring that information with you?

I note also, that their Member musikbear said

That one is yet a new piece in the puzzle of linux-addons+lmms...
I will be very pleased, if you will come back and explain a solution for using this, in case you get it solved -It will go strait to Wiki :)

So if you think your problem is solved now, you might let them know.

In closing, I have an article here https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/ that may be of use to you once you have your Debian the way you like it :)

Cheers and enjoy your Linux.;)

Wizard
 
@srgslogin
it can get confusing if we, and they, do not know what is being said elsewhere
Wizard

There is no any useful advice from that forum (http://lmms.io/forum), so nothing to copy to here. And i wrote to them finally, that problem is solved, but i don't know how (just the same text i wrote here and below).

And recently (before midi-kbd started working) i also installed Windows7 on this notebook, and noticed, that usb3.0 port doesn't work. I installed usb3.0 driver for Windows, and now it works on Win7. Than i ran Linux and plugged the usb cable of midi-kbd in usb3.0. The midi-kbd works in LMMS now, in all the usb ports (3.0 and 2.0).
 
That sounds promising, sir.

Enjoy your music :)

Wizard
 


Latest posts

Top