messed up with bootloader

tremon

New Member
i think i've just messed up something. I explain the situation:
During the last few weeks i've been using Linux Mint in dual boot with windows 10. I decided to remove Mint as it had some terrible screen tearing problems, and switch it to ubuntu. I thought that formating the partition were linux Mint was from windows would make it (i'm pretty new to linux), and the SO was removed, but not the grub bootloader i used on minsk. This grub bootloader didn't show anything after removing Linux Mint, so i decided to proceed with the installation of ubuntu, thinking it would replace the old bootloader with a new one. I installed it and it didn't replace it, but created a new one that only shows ubuntu as aviable, so in order to boot into windows i have to select it manually from the bios.
Is there anything I can do to solve this problem? How can I remove the old bootloader?
thank you for your answers!
 


captain-sensible

Active Member
i dont use ubuntu but from what your saying ; i would say that your install went well on the basis that , after your install at least you can boot up the last installed OS.it can be a lot worse than that believe me.
and windows is still there so all you have to do in essence is add the entry of Windows to the boot menu.

you might try:

# update-grub

to see if it finds windows.

The questions others here are going to ask are probably
1) is your machine using secure boot
2) is secure boot turned off in bios and your using legacy
3) can you see a partition called efi ( use gparted to see)
 

Alexzee

Active Member
Hi & Welcome to Linux.org.

Updating grub is the best thing you can do.

With Ubuntu up and running run this command in your terminal:
sudo update-grub
And wait for it to finish. Close the terminal.

Reboot and you should have the option to choose which operating system you want. Use the up and down arrow keys to highlight either Windows or Ubuntu and press Enter.

Cheers,
Alex
 



Members online

No members online now.

Latest posts


Top