MESA: error: ZINK: failed to choose pdevglx: failed to create drisw screenfailed to load driver: zink

So you are not missing any amdgpu firmware

GQRX - do you use the AppImage or did you make it from source code or did you install it from the Kali Repos?

for this error - MESA: error: ZINK: failed to choose pdev
try installing libqt5quickcontrols2-5 and qtquickcontrols2-5-dev then Reboot - this should be available through the Synaptic Package Manager

I think your problem does not have anything to do with amdgpu graphics but missing qt5 dependencies, which is causing the errors
i have install the with sudo apt install libqt5quickcontrols2-5 qtquickcontrols2-5-dev
and rebbot
and i got this error
 

Attachments

  • 000.PNG
    000.PNG
    399.4 KB · Views: 95
  • 888.PNG
    888.PNG
    239.3 KB · Views: 94
  • 9999.PNG
    9999.PNG
    245.6 KB · Views: 89


i have install the with sudo apt install libqt5quickcontrols2-5 qtquickcontrols2-5-dev
and rebbot
and i got this error
i can,t receive
the frequency can,t load even
if i changed it that is the problem

the avahi-daemon is working fine now
 
when i run gqrx it work fine and i receive
 

Attachments

  • ssssssss.PNG
    ssssssss.PNG
    414 KB · Views: 69
  • www.PNG
    www.PNG
    176.3 KB · Views: 65
i have install the with sudo apt install libqt5quickcontrols2-5 qtquickcontrols2-5-dev
and rebbot
and i got this error
well we are making progress - Run this in the terminal and post back the results
glxinfo | grep "OpenGL renderer"
also try
grgsm_livemon --args=rtl
and see if the errors persist
 
Last edited:
i got this
 

Attachments

  • qqqq.PNG
    qqqq.PNG
    192.3 KB · Views: 81
  • ttt.PNG
    ttt.PNG
    307.5 KB · Views: 75
OpenGL renderer string llvmpipe - is an issue it means you are using your CPU as your graphics and not your GPU
do you have an NVIDIA card? What is the output of
I also found this bug report on Ubuntu about the Mesa error Zink failed - https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/2066353
seems to be associated with kernel 6.8 which that is the latest kernel that Kali is using as well I believe, maybe try an earlier kernel like 6.6
 
Last edited:
OpenGL renderer string llvmpipe - is an issue it means you are using your CPU as your graphics and not your GPU
do you have an NVIDIA card? What is the output of

I also found this bug report on Ubuntu about the Mesa error Zink failed - https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/2066353
seems to be associated with kernel 6.8 which that is the latest kernel that Kali is using as well I believe, maybe try an earlier kernel like 6.6
i don,t have NVIDIA card
 

Attachments

  • xxx.PNG
    xxx.PNG
    359.2 KB · Views: 44
OpenGL renderer string llvmpipe - is an issue it means you are using your CPU as your graphics and not your GPU
do you have an NVIDIA card? What is the output of

I also found this bug report on Ubuntu about the Mesa error Zink failed - https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/2066353
seems to be associated with kernel 6.8 which that is the latest kernel that Kali is using as well I believe, maybe try an earlier kernel like 6.6
I also found this bug report on Ubuntu about the Mesa error Zink failed - https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/2066353

yes seen thanks
 
I see you are in a VMware - make sure 3D acceleration is turned on - other then that I do not use VMware and can be of no further help

I see you are in a VMware - make sure 3D acceleration is turned on - other then that I do not use VMware and can be of no further help



please but where can i get help on this vmware
 
The only other thing I can think of is to change your kernel from 6.8 to 6.6 and see if that works - which you can get through the Synaptic Package Manager - if you do not have it - sudo apt install synaptic - just type in 6.6 in the search block it should find the image install it and then boot to that kernel - you can leave the 6.8 kernel there along side the 6.6 kernel - you do not need to remove it
 
i enable 3D acceleration the error stop
but i got this
 

Attachments

  • 22222.PNG
    22222.PNG
    216.1 KB · Views: 98
i enable 3D acceleration the error stop
but i got this
Looks like you need to upgrade the Osmocom driver - you can get it here - https://github.com/osmocom/rtl-sdr - but you will have to build it - also see this wiki - https://osmocom.org/projects/rtl-sdr/wiki - the Wiki tells you how to build it and what prerequisites you need

You can check the Synaptic Package Manager and see gr-osmodsr it may be newer and might work - it is in Debian repos v0.2.4-1 also from what I see on your photo you have v0.2.0 - I do not know if it is in Kali repos or not - the latest version is 2.0.2 according to - https://github.com/osmocom/rtl-sdr/tags

Now I have run out of ideas
 
Last edited:

Members online


Latest posts

Top