Manjaro 20 Boots To A Black Screen After Update {Solved}

Alexzee

Well-Known Member
Credits
4,287
Manjaro 20 Gnome has been running great for a month on my AMD 64-bit desktop until an update 2 days ago.

Now it boots to a black screen.

I found a temporary solution and have to hold down Ctrl + Alt + F2 to get to a tty2.
Than I log in and type startx.
That brings up the gui.

Before the update Manjaro would boot right to the desktop gui.

How do I fix this?

Alex
 
Last edited:


f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
Check if your GDM is still enabled:
[manjaro ~]# systemctl list-unit-files | grep gdm
gdm.service enabled disabled

If both are disabled do:
systemctl enable gdm

Then reboot and your graphical interface should start automatically again. Otherwise you can add the following to your user .bash_profile -->
if systemctl -q is-active graphical.target && [[ ! $DISPLAY && $XDG_VTNR -eq 1 ]]; then
exec startx
fi
 

Alexzee

Well-Known Member
Credits
4,287
Check if your GDM is still enabled:
[manjaro ~]# systemctl list-unit-files | grep gdm
gdm.service enabled disabled

If both are disabled do:
systemctl enable gdm

Then reboot and your graphical interface should start automatically again. Otherwise you can add the following to your user .bash_profile -->
if systemctl -q is-active graphical.target && [[ ! $DISPLAY && $XDG_VTNR -eq 1 ]]; then
exec startx
fi
I tried running the cmd you posted and made sure gdm was enabled and rebooted.

Manjaro still boots to a black screen.
 

Alexzee

Well-Known Member
Credits
4,287
I tried uncommenting a line in the /etc/gdm/custom.conf hoping that it would help.
Still no joy.

GDM.png

Got any other ideas?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
What output do you get when you run:
Code:
systemctl start gdm
systemctl status gdm
 

Alexzee

Well-Known Member
Credits
4,287
What output do you get when you run:
Code:
systemctl start gdm
systemctl status gdm
When I run the first command the authentication window opens and I have to put in my password.
Running the second command returns this:

systemctl start gdm
[-systemproductname ~]$ systemctl status gdm
● gdm.service - GNOME Display Manager
Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor prese>
Active: active (running) since Sat 2020-10-03 16:25:39 EDT; 54min ago
Main PID: 754 (gdm)
Tasks: 3 (limit: 19081)
Memory: 4.8M
CGroup: /system.slice/gdm.service
└─754 /usr/bin/gdm

GdmSession: Disposing session
Oct 03 16:25:42 cora-systemproductname gdm[754]: GdmSession: Closing session
Oct 03 16:25:42 cora-systemproductname gdm[754]: GdmSession: Stopping all conversations
Oct 03 16:25:42 cora-systemproductname gdm[754]: GdmDisplay: Finalizing display: /org/gnome/DisplayManager/Displays/94610264556000
Oct 03 16:26:06 cora-systemproductname gdm[754]: GdmLocalDisplayFactory: received VT change event
Oct 03 16:26:06 cora-systemproductname gdm[754]: GdmLocalDisplayFactory: VT changed from 1 to 2
Oct 03 16:26:06 cora-systemproductname gdm[754]: GdmLocalDisplayFactory: active VT is not initial VT, so ignoring
Oct 03 16:26:29 cora-systemproductname gdm[754]: GdmCommon: Found session 3 for PID 1382, using
Oct 03 16:26:29 cora-systemproductname gdm[754]: GdmManager: trying to register new session on display (nil)
Oct 03 16:26:29 cora-systemproductname gdm[754]: GdmManager: No display, not registering
~
 

Alexzee

Well-Known Member
Credits
4,287
Could this be an Xorg problem?
 

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
Could this be an Xorg problem?
Can you try to start it with: sudo systemctl start gdm
Then what does the output of journalctl -u gdm say and can you share your most recent Xorg.log?

As a work around you could probably try what I mentioned before since you don't actually need a desktop manager when running only one DE. Add this to your .bash_profile:
if systemctl -q is-active graphical.target && [[ ! $DISPLAY && $XDG_VTNR -eq 1 ]]; then
exec startx
fi


Then reboot, when you login it should then automatically start your Gnome session.
 

Alexzee

Well-Known Member
Credits
4,287
Can you try to start it with: sudo systemctl start gdm
Then what does the output of journalctl -u gdm say and can you share your most recent Xorg.log?

As a work around you could probably try what I mentioned before since you don't actually need a desktop manager when running only one DE. Add this to your .bash_profile:
if systemctl -q is-active graphical.target && [[ ! $DISPLAY && $XDG_VTNR -eq 1 ]]; then
exec startx
fi


Then reboot, when you login it should then automatically start your Gnome session.
Running sudo systemctl start gdm didn't produce anything.

Running journalctl -u gdm gave me a lot of output but I couldn't copy it. The output returned:
gkr-pam: unable to locate daemon control file.

Adding the command that you gave me to the .bash_profile also didn't help.
When I rebooted after editing the .bash_profile I still had a black screen.

Where is the Xorg.log?
 

Alexzee

Well-Known Member
Credits
4,287
Had trouble finding it--

ls ~/.local/share/xorg
Xorg.0.log Xorg.0.log.old Xorg.1.log Xorg.1.log.old

I copied my Xorg.log. and made a file, it's attached:-
 

Attachments

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
I don't see anything strange in the Xorg.log.

You could try installing a different desktop manager to see if the problem doesn't exist with that one.
1. Disable gdm: sudo systemctl disable gdm
2. Install lightdm: sudo pacman -S lightdm lightdm-gtk-greeter
3. Enable lightdm: sudo systemctl enable lightdm
4. Reboot: See if you do get a graphical login screen this time.

If this works, then we have to figure out what packages were updated during your update by checking the pacman.log and try to filter out the ones that could have broken gdm. If it doesn't work it probably has to do with a pam authentication package that was updated or pam configuration. Also seems you are not the only one with this problem.

Also there is a recently closed gitlab issue for this, and the packages mentioned there that are affected are:
gdm, gnome-session, gnome-shell and gnome-keyring.
 

karlsayle

New Member
Credits
8
Hi all,

I have a very similar setup (Laptop with dual GPU Intel/AMD) which updated on Friday evening and when booting today, would not display GDM. I was able to login using the same Ctrl+Alt+F2, startx method.

Thanks to @f33dm3bits advice, disabling GDM then installing and enabling lightdm, allowed me to login 'normally'.

Will have to keep an eye out for any further releases/fixes relating to GDM.
 

Alexzee

Well-Known Member
Credits
4,287
I don't see anything strange in the Xorg.log.

You could try installing a different desktop manager to see if the problem doesn't exist with that one.
1. Disable gdm: sudo systemctl disable gdm
2. Install lightdm: sudo pacman -S lightdm lightdm-gtk-greeter
3. Enable lightdm: sudo systemctl enable lightdm
4. Reboot: See if you do get a graphical login screen this time.

If this works, then we have to figure out what packages were updated during your update by checking the pacman.log and try to filter out the ones that could have broken gdm. If it doesn't work it probably has to do with a pam authentication package that was updated or pam configuration. Also seems you are not the only one with this problem.

Also there is a recently closed gitlab issue for this, and the packages mentioned there that are affected are:
gdm, gnome-session, gnome-shell and gnome-keyring.
Running those cmd's and installing lightdm worked! Thank You!
After rebooting I was able to login.

Where is the pacman.log?
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
That is located here: /var/log/pacman.log

Also check which gdm pam files you have, I came across a Manjaro post where a person comes across the same error and someone from the Manjaro team mentions it but it's from a month ago. Can you show it by running this command: ls -l /etc/pam.d/gdm-*
 
Last edited:

Alexzee

Well-Known Member
Credits
4,287
That is located here: /var/log/pacman.log

Also check which gdm pam files you have, I came across a Manjaro post where a person comes across the same error and someone from the Manjaro team mentions it but it's from a month ago. Can you show it by running this command: ls -l /etc/pam.d/gdm-*
ls -l /etc/pam.d/gdm-*
-rw-r--r-- 1 root root 572 Aug 12 17:24 /etc/pam.d/gdm-autologin
-rw-r--r-- 1 root root 1057 Aug 12 17:24 /etc/pam.d/gdm-fingerprint
-rw-r--r-- 1 root root 804 Aug 12 17:24 /etc/pam.d/gdm-launch-environment
-rw-r--r-- 1 root root 449 Aug 12 17:24 /etc/pam.d/gdm-password
-rw-r--r-- 1 root root 1085 Aug 12 17:24 /etc/pam.d/gdm-smartcard

The pacman.log is 43 pages long.

Is there something specific I should look for by name?

Thanks for staying with me. You have been a big help!-:)
 

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
Can you also check if there are any pacnew files in /etc/pam.d


Search for lines with "upgraded" in it with the date you updated your system to the new manjaro release(I think it was this one?) of Manjaro. It should look something like this:
Code:
[2020-09-18T07:43:14+0200] [ALPM] upgraded vim-runtime (8.2.1684-1 -> 8.2.1704-1)
[2020-09-18T07:43:14+0200] [ALPM] upgraded vim (8.2.1684-1 -> 8.2.1704-1)
 

Alexzee

Well-Known Member
Credits
4,287
Code from the pacman.log:

BTW, there are hundreds of entries on 10-1-2020 for [ALPM] upgraded that start on page 36 and continue until the end of page 43.

[2020-10-01T11:13:29-0400] [ALPM] upgraded gnome-layout-switcher (0.8.9-1 -> 0.8.10-1)
[2020-10-01T11:13:29-0400] [ALPM] upgraded gnome-shell-extension-appindicator (33-1 -> 34-1)
[2020-10-01T11:13:29-0400] [ALPM] upgraded gnome-shell-extension-desktop-icons-ng (0.12.0-1 -> 0.13.0-1)
[2020-10-01T11:13:29-0400] [ALPM] upgraded gnome-shell-extension-gsconnect (41-1 -> 42-1)
[2020-10-01T11:13:29-0400] [ALPM] upgraded gnome-shell-extension-nightthemeswitcher (36.r2.g53b530d-1 -> 37.r0.g10c329c-1)
[2020-10-01T11:13:29-0400] [ALPM] upgraded gpm (1.20.7.r27.g1fd1941-2 ->

etc pam.d.png

The only new files that I saw were the lightdm-auto login and the lightdm-greeter.
 

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
That must have been a big update then if you have 7 pages of upgrade packages for 1-10-2020. If I were you I would just wait for the next update of these packages: gdm, gnome-session, gnome-shell and gnome-keyring. After that you can just try switching back to gdm, which is basically the same as the commands I mentioned before but this time disable lightdm en enable gdm. Unless you don't care about which display manager you use, also I would follow the manjaro forums too you may never know if you come across something useful there. Since nothing seems wrong with your pam configuration otherwise lightdm would have probably given trouble too. Not much else I can help you with.
 

Alexzee

Well-Known Member
Credits
4,287
That must have been a big update then if you have 7 pages of upgrade packages for 1-10-2020. If I were you I would just wait for the next update of these packages: gdm, gnome-session, gnome-shell and gnome-keyring. After that you can just try switching back to gdm, which is basically the same as the commands I mentioned before but this time disable lightdm en enable gdm. Unless you don't care about which display manager you use, also I would follow the manjaro forums too you may never know if you come across something useful there. Since nothing seems wrong with your pam configuration otherwise lightdm would have probably given trouble too. Not much else I can help you with.
Yeah, it was a big update.

For now I think I'll just keep the lightdm display mgr as I'm happy with it.

Thanks for the help and support f33dm3bits. :)

Cheers,

Alex
 

f33dm3bits

Gold Member
Gold Supporter
Credits
6,171
Yeah, it was a big update.

For now I think I'll just keep the lightdm display mgr as I'm happy with it.

Thanks for the help and support f33dm3bits. :)

Cheers,

Alex
Glad to have helped you with a workaround! :)
 


Members online


Top