Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd, 2017 please sign up again. Thanks!

make my Linux Portable....

Discussion in 'General Linux' started by Condobloke, May 24, 2018.

  1. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,297
    Likes Received:
    1,297
    Yeah, but they read all your mail. :eek::eek::D:D (I use Gmail too. There's no escaping the mighty "G".)



    I was in a thread not too far back about installing Debian on a USB with persistence, and those instructions got into creating a persistent partition larger than 4GB. I followed them along and made it work, but maybe Wizard will find an easier method. I didn't even know it was possible until just lately.
     
  2. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,297
    Likes Received:
    1,297
    Here's a link to my last post on the persistent Debian... it gives a link to the original instructions that I used, and then some comments I made about the instructions. I ended up with an 8GB persistent partition on the flash drive, so it worked. :D
    https://www.linux.org/threads/debian-live-usb.17921/#post-54228
     
  3. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    I am quite certain it can be done in "MultiSystem".....which is what Wiz used back in post #...just realized there are no post numbers !....the post on page 1 where he has a screenshot of Sylvia with persistence....there he left this :
    Code:
    sudo apt-add-repository 'deb http://liveusb.info/multisystem/depot all main'
    wget -q -O - http://liveusb.info/multisystem/depot/multisystem.asc | sudo apt-key add -
    sudo apt-get update
    sudo apt-get -y install multisystem
    I think I may have found a way (well, someone else may have found it), to increase the size of the Persistence to fill the stick and I am going to check into that and come back here later.

    I installed multisystem using that.....and I must say it is a very polished piece of software.

    I will leave Wiz to figure out the intricacies of increasing persistence beyond 4 gb (i dont want to steal his thunder :rolleyes:;)
     
    atanere likes this.
  4. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,297
    Likes Received:
    1,297
    You aren't seeing post numbers??? I think you're referring to post #7 of this thread.

    (In the lower right corner, just above the Reply button.)
     
  5. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    weirdness sometimes happens......i just went bakc to page 1....and sure enough post numbers are ON.......I reopened the topic in a fresh tab by clicking on the email link....no post numbers....oh well....tomorrow is another day !
     
  6. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,297
    Likes Received:
    1,297
    Yeah, I see some odd things happen sometimes too, but I haven't missed the post numbers.... yet. Now I probably will. :D

    Ah well, g'nite Brian... even though it's mid-day down under. I'm off to bed. :(
     
  7. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    Sorry I missed Stan :(

    (Wizard appears in a puff of smoke, sets his beard and moustache on fire ... so smoking really IS bad for your health)

    Actually it is quite simple, which is not to say that the method I advocate is the best or smartest way.

    Basically, when we say "Linux go get my Persistence and load it up", it says "Yes sir, no sir, 3 bags full" and goes off in search of casper-rw.

    When you burn a Linux .iso with one of the Linux or Windows or cross-platform utilities that allow you to add persistence (Unetbootin for cross-platform, Multisystem for within Linux, are just 2 examples), it adds a file to the rest of the burned material, called casper-rw.

    With many burning solutions requiring a USB stick formatted in FAT 32, the limit of size on casper-rw is 4GB, a limitation imposed by FAT32, not by Linux.

    Our "gofer" Linux does not care if the Persistence is a file or a partition, it just goes for something named ""casper-rw". So thinking outside the box, if we take a stick already loaded with Persistence, delete that Persistence file, reclaim the space freed up, go into GParted and resize the FAT32 partition down to the minimum recommended by GParted, then create a new EXT4 partition filling the balance of the stick's capacity, label it casper-rw, and reboot, Bobs Your Uncle and we have a stick with heaps of Persistence.

    And yes, Brian, it does work with your already persistence-enabled Multisystem stick, I did it today :p (didn't know if it would, hadnt tried it before on Multisystem).

    Gotta run, but I'll be back with more, clearer, instructions, screenshots and videos.

    Cheers and Avagudweegend

    Wiz
     
    atanere likes this.
  8. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    and......end up with something looking like
    ....

    [​IMG]

    ....and...i was able as a result to load the profile etc from my original thunderbird to the profile folder on thunderbird on the multisystem....and it all loaded up ok....albeit as slow as a wet week.....

    It survives reboots (when it will actually reboot....which is never so far), hard shut downs.....5 to date....

    When I start via F11 to select the 'boot from' device etc......i still encounter "two" multisystems......one with persistence and one without. I start the one with persistence and at least it boots easily and consistently.
    When I have time I will start it...open thunderbird....and allow t;bird to download all it needs from the gmail servers. It is a considerable amount. last I looked it was downloading number 22 of 555 sent emails.......and there are approx 9 folders with more than that in them.....
    I talk to a lot of people....what can I say !:)

    At this point my only complaint is speed. It is abominably slow...although that may have more to do with T'bird setting itself up/d'loading from servers etc etc.....so I will wait and see.
     
    atanere likes this.
  9. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    (No wonder I love this guy... if I say to a young person "as slow as a wet week" they look at me like I've got two heads, lol)

    That screenshot looks about right, Bro' :)

    I am currently in "Method 2", which is slower than a wet week, I'll wrap up here shortly and get back to sane speeds with more.

    You're in "Method 1", which we could describe as being "Mega Persistence using Multisystem".

    Method 2 is a full install on a stick, you can put everything you like on it to the stick's capacity, and run a Timeshift snapshot from within it. I have just finished transferring 40GB or so of .iso's from my Downloads folder on to it and will see if things hold.

    I'll take a couple of screenshots before I exit, and be back anon.

    Cheers

    Wiz
     
    atanere likes this.
  10. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    Well, my "anon" was not so soon, was it? Regrets. :oops:

    You can move the one with Persistence to be at the top of your Menu

    [​IMG]

    SCREENSHOT 1 - ABOUT TO TAKE THE UP ELEVATOR

    The above is from my 32GB stick that has a number of Distros on it. I put 'Sylvia' MATE on on 5 December last, then put on OpenSUSE 12 January. I then decided I wanted Persistence on the LM, so did so on 28 January (3rd entry, highlighted).

    I later decide that I want the Persistence-enabled one on top, so I highlight it and click the eyeball.


    [​IMG]

    SCREENSHOT 2 - ELEVATOR RIDE OVER, YOU ARE ON THE TOP FLOOR

    There are radio buttons on the right, some may look greyed out but they are not.

    Click the one with the Up arrow and you will be prompted to enter your password and on completion of the exercise, your entry has moved up one. I had to perform the operation twice in my case, you would only need one.

    Multisystem's individual Grub Menu is updated, and when you next boot from it, your Persistence version will be on top and the 30-second countdown will apply to it. As you can see from the Smart Tip, you can also double-click a menu item and edit it to perhaps something more meaningful to you, for example "Persistent LM18.3 Cinn" might work better for visibility without having to scroll right (Multisystem does not allow for resizing the pane).

    Also note that to the right of the Up arrow (two columns) is a Grub Settings button.

    [​IMG]

    SCREENSHOT 3 - I SEE YOUR TRUE COLOURS

    I have highlighted one of the entries, and you can change background and foreground colours and text appearance to suit. The default white text on that splash screen is difficult to read, and it includes the timer countdown.

    I have not played with the splash screen yet, nor the config files.

    Found the right stick now, and here you can see what a colour change can provide. The timer countdown line would be the same colour but I had moved to highlight an entry so it stopped the countdown.

    [​IMG]

    SCREENSHOT 4 - NEW GRUB MENU COLOURS (TEXT)

    Next Post I will deal with Method 2 options.

    Cheers

    Wizard
     
    atanere and CptCharis like this.
  11. CptCharis

    CptCharis Active Member

    Joined:
    Feb 27, 2018
    Messages:
    171
    Likes Received:
    175
    atanere likes this.
  12. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    Not quite as simple as that, my friend :D

    But yes, the principles are basically similar to those I was going to cover in Method 2 ;)

    What I write following this begs the question of Brian:

    Brian, you have said that the Windows 10 lappie has come back into your possession, and that will be on UEFI.

    Is the desktop or other that you have been working on, and creating USB sticks, UEFI as well?

    There is a significant difference between the environment of the writer of the TecMint article and those of any number of Users, perhaps including the OP, Brian:

    At Step 3, point 7, he has the following (could only capture part of it, and the screenshot is not very clear, likewise with the original article)



    [​IMG]

    SCREENSHOT 1 - WRONG FOR UEFI

    He changes his Device for boot loader installation from it's default (dev/sda) to his stick (dev/sdc) and that is fine for BIOS-MBR.

    However under UEFI-MBR or UEFI-GPT, the following will happen:

    Linux Mint will go in search of an ESP (EFI System Partition), a FAT32 partition of perhaps 512MB or as little as 2 - 3 hundred MB, on your existing setup. It will assign that entry to /etc/fstab on your stick.

    Example of an fstab under such conditions:

    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    # / was on /dev/sdb1 during installation
    UUID=9dd6a7c7-e522-42cb-a14f-0be9c489e960 / ext4 errors=remount-ro 0 1
    # /boot/efi was on /dev/sda1 during installation
    UUID=E9DC-B605 /boot/efi vfat umask=0077 0 1

    I have highlighted the lines which reflect the circumstances.

    The writer was using /dev/sdc whereas I was using /dev/sdb.

    If Brian were to follow the writer's article step by step, with the stick being written on a UEFI computer, and then taken to a UEFI computer, the following would likely happen:

    • Windows 10 has its own small UEFI ESP, with a unique UUID
    • The laptop would not be able to find the UUID described in /etc/fstab on the stick.
    • It would progress a certain way through the bootup procedure, you would see a splash screen with the Mint Logo and 5 dots turning green to white and back, then ... KAPOW, you would be dumped at a tty session (black and white) where it said something like "Welcome to emergency mode..."
    1. The situation CAN be fixed from there, by using nano text editor to modify the /etc/fstab on the stick OR
    2. The Tecmint writer's procedure will work under most conditions if you first change your Setup from UEFI to CSM (Compatibility Support Module aka Grub Legacy), boot into your computer and write the stick from there, and then use it on a computer that has the same facility OR
    3. At the point where the TecMint writer has Step 3 point 7. you choose actively to install the ESP onto the stick itself, either by choosing /dev/sdc1 or /dev/sdb1 as identified for your stick to install it to OR in preparation stage, carve off a small FAT32 partition on your stick of about 512MB and designate it as eg /dev/sdb2 or /dev/sdc2
    Under that point 3 scenario, your stick will be taking its own ESP with it.

    I cannot tell how that last one will operate under a Windows only computer, as I don't have one.

    Other than that, that is a good article Capta, I have bookmarked it and thanks for sharing :D

    Brian, if you can just confirm on UEFI or otherwise of the from and to computers, I can advise further?

    Cheers

    Wizard
     
    atanere and CptCharis like this.
  13. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    On my Linux pc.....NOT uefi ( EFI variables are not supported on this system.)

    On the Laptop, Windows 10 IS uefi

    Sorry....not much time last few days......major kerfuffle regarding quarantine time for Belle in Singapore
     
    wizardfromoz likes this.
  14. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    Totally understandable, and Ta for the input :)

    If you wish to follow the full install on a stick approach, then you could likely follow the instructions given in the TecMint article Capta offered us. If the Win 10 lappie is all that is going to make use of it, you could go 64-bit instead of 32-bit. Only thing I cannot be sure of is whether you would need to switch the lappie to CSM mode in order to use the stick.

    Cheers

    Wiz
     
    atanere likes this.
  15. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    1,297
    Likes Received:
    1,297
    Hey Brian, how did the portable Linux experience turn out for you? (Or has your trip not happened yet?)

    I was unaware of MultiSystem before this thread, and I've been playing with it a little the last couple of days. After creating and deleting one USB stick, I'm on attempt #2 now... but I get some mixed results with it (probably just my inexperience). In my current edition, I made a 10 GB partition for casper-rw (associated with Mint Cinnamon), and then later I installed Knoppix 8.2 and MultiSystem prompted me to create it with persistence.... so I did, and it worked (but I'm not sure where the casper-rw file is stored).

    I could be mistaken, and maybe Knoppix is sharing the 10 GB partition, but MultiSystem seemed to set up its own 2 GB persistence for Knoppix. Both Knoppix and Mint have persistence working, however it was accomplished. But while Knoppix saves some things (a text file on the desktop, and it remembers my wifi password).... it does not save the screen resolution that I prefer.

    On the downside, Mint no longer boots on a Windows 10 UEFI laptop. But quite strangely, Linux Lite DOES boot on this UEFI laptop (with Secure Boot enabled!) even though Lite does not support UEFI booting. In this case, it seems that MultiSystem is booting Ubuntu to get through the UEFI hurdles, but then it actually starts Lite.

    I think I'll be deleting this edition of MultiSystem and starting again to see what other strange things I can do with this new toy. I'm not even sure what I've done differently between installations. I have also put the small Slax distro on both times... the first time it would work with BIOS but not UEFI, and now this time its not available to boot in either BIOS or UEFI (but it shows up in MultiSystem).

    I hope you had an easier time and found the solution(s) you were looking for! I seem to be stumbling in the dark! :eek::D

    Cheers
     
    wizardfromoz likes this.
  16. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    @atanere Just a Holding Post in terms of Stan's Post above (do you know when you mistype Stan you can get Satan?) -

    I could look into those issues further with you, or else since I first (in this thread) addressed Multisystem on May 29 Oz time, @Jarret B has since released an article for a Fix Stick here https://www.linux.org/threads/creating-a-fix-stick.18151/ ... which featured Multisystem, and he may have valuable input?

    @Condobloke

    Mate, I think I have a wizbang viable solution for you that will allow you to travel from the Philippines to Oz and unpack without (hardly) a ripple.

    I've used Multisystem and Timeshift for it, on a 64GB stick, run it on MBR, CSM, UEFI between two computers and on the stick.

    Just need to know the following:

    1. USB stick USB 2.0 or 3.0 and likewise ports' configuration, ie is the lowest common denominator/bottleneck USB 2.0 speeds?
    2. I've factored in 3 partitions including one for 10GB Windows data if needed
    3. No dedicated Swap, but we can factor in a Swap on the stick itself if you want
    I can wrap this up within 24 - 48 hours once you give me the green light

    Cheers

    Wizard
     
    atanere and Condobloke like this.
  17. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    the pc it will run on is usb 2.0...therefore...
    windows ata not necessary
    not fussed re swap......I should be able to get away without it for the duration of the trip.......the trip looks like including singapore for at least a few weeks
     
    wizardfromoz and atanere like this.
  18. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    I'm putting together the "paperwork" for a blow-by-blow on what to do, but will hold off on the finished product for a couple of days.

    We joined the SKI Club (Spend the Kids' Inheritance) and purchased a couple of Dell laptops in an EOFY deal that saved us around AUD$1,800 and they are in transit. Ship with Windows 10 and I want to see that the stick works OK.

    GParted shot below indicates how I have the stick partitioned:

    [​IMG]

    Don't be confused with the MX-17 cf Linux Mint 18.3 'Sylvia' Cinnamon.

    Using Elaine's old Compaq Presario with 512MB RAM as the MBR-based test unit, hence limited to low resource, 32-bit options.

    So

    1. Are you still on 18.3 or upgraded to 19?
    2. Is Windows 10 the only OS on the laptop?
    Cheers

    Wizard
     
    atanere likes this.
  19. Condobloke

    Condobloke Active Member

    Joined:
    Apr 30, 2017
    Messages:
    189
    Likes Received:
    238
    1. still on 18.3

    2. only windows 10
     
    atanere and wizardfromoz like this.
  20. wizardfromoz

    wizardfromoz Well-Known Member

    Joined:
    Apr 30, 2017
    Messages:
    1,010
    Likes Received:
    1,128
    Ta, I'll proceed on that basis :p

    Wiz likely out for the evening
     

Share This Page