Make command on RPi Zero W (Raspbian)

danmanx

New Member
Joined
Apr 9, 2020
Messages
1
Reaction score
0
Credits
0
Hi Forum! Bear with me. Trying to install this on a Pi Zero with [Retropie] Raspbian installed.


I SSH'd into my pi and git clone'd the file to my Pi. Now, according to the instructions, I am trying to use the make command to make/install on it. I followed the instructions, but i am doing the make command line wrong and I can't find a single source for it properly. I'm trying to use UNIX-SDL for it and i believe it's [unix-sdl] installed already. However, I can't tell.

So, #1 I need to check my dependencies, and #2 how on earth do I run this makefile?

Thanks in Advance
 


arochester

Moderator
Staff member
Gold Supporter
Joined
Apr 25, 2017
Messages
1,624
Reaction score
1,293
Credits
3,032
i am doing the make command line wrong and I can't find a single source for it properly.

How do you know you are using the command incorrectly? What exactly does it say?
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,450
Reaction score
2,056
Credits
10,088
When you want help with problems like this, it really helps if you include any error messages that are displayed.

Without knowing what errors you’re seeing, I’m going to have to run through several likely possibilities. So I’d recommend you check the following:

1. Do you have make installed?
If not, you’ll need to install the build-essential package. That will install make and a bunch of other build tools.

2. Do you have the libpng and SDL2 dev packages installed?
From looking at the linker settings in the makefile, it requires libpng and SDL2 - so you’ll need to download and install the dev packages for those too (assuming you’re building the unix-sdl target.).
To find the appropriate packages:
Code:
apt search —names-only dev | grep sdl
apt search —names-only dev | grep libpng
That should yield the names for the appropriate dev packages for you to install.


3. Don’t use spaces when assigning values to variables in make.
e.g. if you do this:
Code:
make PLATFORM = unix-sdl
make will fail

Instead, you need to do it exactly as shown in the instructions, with no spaces:
Code:
make PLATFORM=unix-sdl
Then the variable will be set and the command should work.

If none of those help, please post again with more information and any error messages that you are seeing.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top