Loud pop and then noise when using headphones

alexban011

New Member
Joined
May 15, 2022
Messages
6
Reaction score
2
Credits
60
I've had this problem occur on every single distro that I tried. I have a realtek sound card in my asus g551vw, but am using the drivers from intel (kernel) since the ones from realtek are ancient (2018) and use an even older kernel (there is a warning to only use kernel 3.18 or LOWER ?? is that a joke ffs?)

In the following link someone had the exact same problem but I don't know how to use that fix though. Does anyone have any idea how to fix the problem?

Btw I'm using Pipewire and do not have PulseAudio installed.

I have also attached a recording (.mp3) of the issue. It is silent until I start a video/something that plays audio, then a loud pop and white noise until a couple seconds after I stop the video. A couple months ago I tried the "fix" that completly disables the power save and all that did is to make the noise constant, which was worse.

I should also mention that the pop and noise are independent from the volume. (volume = 0, still happens at the same exact loudness)

uname -a =
Linux archlinux 5.17.7-arch1-1 #1 SMP PREEMPT Thu, 12 May 2022 18:55:54 +0000 x86_64 GNU/Linux

lscpi -vvv =
00:1f.3 Audio device: Intel Corporation 100 Series/C230 Series Chipset Family HD Audio Controller (rev 31)
Subsystem: ASUSTeK Computer Inc. Device 1d3d
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 32
Interrupt: pin A routed to IRQ 132
Region 0: Memory at df328000 (64-bit, non-prefetchable) [size=16K]
Region 4: Memory at df300000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

Edit: I forgot to mention I'm using KDE Plasma, but I think thats irrelevant as it happened on every distro I tried, but not on windows
 

Attachments

  • export.zip
    86.6 KB · Views: 37
Last edited:


Condobloke

Well-Known Member
Joined
Apr 30, 2017
Messages
4,514
Reaction score
3,941
Credits
25,363
G'day alexban, Welcome to Linux.org

Which distro are you running?

Warning to use an old kernel?....where does that warning come from?

During install, most distributions will ask if you wish to install non-free/proprietary drivers, tick the box for yes and enter. Non-free does not mean it will cost money to use. It just means that it’s supplied by the manufacturer and not FOSS (Free Open-Source Software). You can choose to not install proprietary drivers, but that will make your life more difficult

DID YOU TICK THE BOX ?
 
OP
alexban011

alexban011

New Member
Joined
May 15, 2022
Messages
6
Reaction score
2
Credits
60
Looks like there are also drivers for linux which don't have that warning but you can't download them. Realtek is a joke

Hi, I'm using archlinux 5.17.7. The warning comes from the official download page from Realtek. They say in some broken english that the driver is now upstreamed in the kernel, but my laptop uses the intel ones


I don't recall asking me to install any propietary drivers other than the nvidia ones

The guy in the link in the original post said the issue is that his sound card cannot handle the low latency so he increased it. Any idea how I might be able to do that ?
 
Last edited:
D

Deleted member 140690

Guest
You could see if the same files are on our system,
this only sets the priority to realtime, I used to set this way back
but it does not seem to be required these days, usually better off
finding eveything that can be disabled that interupts the processor,
like usb sleep system alerts messages, update checks and such,
I find these things cause way more issues and will continue to so
no matter realtime or not.

Have you this file, in the example below the priority is being set to high, and its given unlimited memory, this may cause more problems than it will solve unless you have lots of memory, again, unwanted
interruts are way more trouble than not setting up the below.

The below may help in a round about way and is worth a try.

Code:
cat /etc/security/limits.d/99-realtime-privileges.conf

@realtime - rtprio 98

@realtime - memlock unlimited
 
D

Deleted member 140690

Guest
Is there no interface where you can change your system to use the linux drivers instead of the intel ones.
Someone who knows will come along,
I once blacklisted a deiver, so that forced another one to be used,
but that was yonks ago and have no clue now.
Maybe look up blacklisting kernal driver
 
OP
alexban011

alexban011

New Member
Joined
May 15, 2022
Messages
6
Reaction score
2
Credits
60
Code:
cat /etc/security/limits.d/99-realtime-privileges.conf

@realtime - rtprio 98

@realtime - memlock unlimited
No, I do not have that file
But I do have a /etc/security/limits.conf file.
Edit: I tried it in limits.conf but it doesn't work
 
Last edited:
OP
alexban011

alexban011

New Member
Joined
May 15, 2022
Messages
6
Reaction score
2
Credits
60
if I blacklist snd_hda_intel it doesn't load any other driver and I get no sound, the sound controls are also disabled (no option in the menu)
 
Last edited:
OP
alexban011

alexban011

New Member
Joined
May 15, 2022
Messages
6
Reaction score
2
Credits
60
I think pipewire/jack is not getting real-time priority. (because I get the following error message in android studio, and on the link someone mentioned this)
[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
 

Lord Boltar

Well-Known Member
Joined
Nov 24, 2020
Messages
1,665
Reaction score
1,113
Credits
12,440
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top