lost wifi

C

charolenne

Guest
Mint on thumb drive...windows will not boot am finding my way around mint..EXCEPT I HAVE LOST WIFI CONNECTION. ?. Cannot use tutorials..no wifi... help.
 


A

arochester

Guest
Did you have wifi and then it has gone? Or did you not have it with Linux?

Open a Terminal. Input:
lspci
and/or
lsusb

What is the output? Can you connect with cable? Can you copy and paste here?
 
C

charolenne

Guest
Thank you will try..I believe I had it until windows totally died..
 
I

ihermit

Guest
Let's start with the simplest first. Please excuse me for asking such a question, but do you have a wireless NIC on this computer? You can check that like such from a terminal as root:

Code:
lspci | grep -i "wireless"
on my desktop the output looks a such:
05:01.0 Network controller: Ralink corp. RT3060 Wireless 802.11n 1T/1R

I have a Ralink RT3060 Wireless NIC

If this is a usb modem try:
Code:
lsusb | grep -i "wireless"
If we can pass test 1 than we have a wireless card so let's go to test 2. Is wireless enabled? A simple check in the System Tray and click on the wireless icon and make certain that the check box "Enable Wireless" is selected. Also, on some laptops you can enable/disable wireless from the keyboard. It's normally a key combination like <fn><f2>. Press and hold the 'fn' key while pressing the 'f2' key. Just look for the key with a little wireless tower on it. But there should be a backlite on some kind to show that wireless is indeed enabled on the laptop.

If we pass test 2 than we have a NIC, it's enabled so let's see if it's working even the least bit. As root type:
Code:
iwconfig wlan0
If you get something like this
Code:
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
Your good! So let's see if we can scan some access points:
Code:
iwlist wlan0 scan
On my computer some of the output would be as such
Code:
wlan0     Scan completed :
          Cell 01 - Address: BLAH BLAH
                    Channel:11
                    Frequency:2.462 GHz (Channel 11)
                    Quality=70/70  Signal level=-30 dBm  
                    Encryption key:on
                    ESSID:"BLAHBLAH"
If we can get this far we know Wireless is working and if we still can't connect it's a problem in our Network Manager. Try scanning for access points with your Network Manager. Is anything showing up? If not the problem is the network manager you're using doesn't support the type of wifi access point you're trying to connect to. Yes I have ran into that problem. KNetwork Manager with a pre 3.x Kernel always gives me problems with mobile hotspots like T-Mobile and Cricket. If this is the case try using the network manager 'wicd'. That might work ???

If you're getting scan results with your Network Manager and still not connecting make sure you typed the password correct and also, make sure the encryption type in your Network Manager is set to the same type as the access point. i.e wep or wpa2

Now if we failed Test 2 and got no ouTput from either iwconfig or iwlist we probable have a driver issue so let's go back to test 1 and type as root in your terminal:
Code:
lspci | grep -i wireless
My output was
05:01.0 Network controller: Ralink corp. RT3060 Wireless 802.11n 1T/1R
Select and copy the first part. In my output it's the "05:01.0" part.

Now type:
Code:
lspci -vv -s [I]<your Number code>[/I] | grep driver[CODE]

i.e mine would be like:
[CODE]lspci -vv -s 05:01.0 | grep -i driver

My output is as such:
Kernel driver in use: rt2800pci

The driver I'm using is rt2800pci

If you fail to get any output than we have a driver issue. Post the output of the lspci | grep -i wireless command and maybe we can help you find the driver you're going to need.

Sometimes wireless with Linux is tricky. Sometimes wireless with Linux is easy. But wireless with Linux is always possible. The trick is don't give up.

Hope this helped.
 
M

Mohanasmith

Guest
I tried to connect my laptop with my cellphone via wifi tethering but it is showing some troubles..i don't know what's the issue.can anyone help me around with this.
 
A

arochester

Guest
@Mohanasmith

Please don't hijack somebody else's thread by sticking your problem on the end. Please start a new thread of your own.

Note that you have told us nothing about your laptop, your distro and your cellphone and provider...
 
C

charolenne

Guest
Am completely new to mint..have been spoiled lazy widows user...my laptop is a acer inspire one...winxp told to upload ubuntu. ....did that..windows crashed..unbuntu didn't boot...took it to a tech..reloaded win xp and he put mint on a thumb drive..4 times I used 5he computer ein xp and connected to 5he wireless router. ? Then nothing..windows would not boot..can boot mint with thumb drive but cannot connect to internet..cannot ask intelligent questions because I sm completely new to the language..
 
R

ryanvade

Guest
cannot ask intelligent questions because I sm completely new to the language..
You seem to know what you are talking about. ;)

Your laptop "Should" have Atheros wireless. If so the kernel should have the correct drivers. So, some options might be the Acer one Patches. Double checking that the correct drivers are in use. Etc. Here is a document that should help:
http://www.linurs.org/pdf/Aspire one.pdf
 
A

ArchMint

Guest
Just wondering, how are you posting this if you have no internet?
 

Members online


Latest posts

Top