linux wont run

Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
hi, im a windows 10 user but i wanted to give linux another chance so i installed it on another partition (linux mint).... in bios i have it set to legacy mode but when i boot the pc it goes to a blinking cursor..... what gives ?
 


kc1di

Well-Known Member
Joined
May 14, 2021
Messages
462
Reaction score
426
Credits
3,261
Please give us some more information to go on. What type of Machine, ram Graphics card ETC.
Which version of Mint?
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
nevermind i kinda fixed it.... to boot to windows i go to bios and switch to uefi... to boot to linux i switch to legacy..... kinda tiresome


pc ps a lenovo m91p... intel i7, no graphics card..... 12gb of ram... linux mint uma i think
 

endruschat100

Member
Joined
Jul 24, 2021
Messages
63
Reaction score
1
Credits
454
Hi,did you use a USB Stick with Install Mint?
In any cases/devices you have to enable and disable boot secure in BIOS?
But this can bei different.
 

Fanboi

Well-Known Member
Joined
Apr 16, 2021
Messages
358
Reaction score
270
Credits
4,288
No reason you'd use legacy these days. Most, if not all, distros are UEFI (well, mainstream ones). That includes mint. If you set the BIOS to UEFI boot, just install Mint (latest version) as per normal. It will install GRUB, too. That'll auto-detect every OS and when you boot, it'll boot straight into GRUB where you can choose to boot Mint or Windows. Nothing complex.
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
if bios is in legacy, it goes straight to linux mint....if bios is in uefi... it goes straight to windows 10
no grub
and yes i installed through USB
 

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
462
Reaction score
426
Credits
3,261
You should use the same for both windows and Linux Mint. UEFI will work in both. But you will have to set bios to UEFI and reinstall Mint You should disable secure boot however as that can cause other problems in Mint. So reset your system to UEFI and reboot Mint from Live media and do a fresh install Making sure you do not erase your windows partitions. And grub will be install in the UEFI and you'll beable to boot to either windows or mint from their. Good luck.
 

captain-sensible

Well-Known Member
Joined
Jun 14, 2019
Messages
2,531
Reaction score
1,672
Credits
15,089
I wonder if you installed Mint with grub legacy MBR mode and not to efi ?

Actually i think we may be able to confirm that , if you install efibootmgr and use command something like efibootmgr -v if Mint was installed to efi , then efibootmgr should show an entry for it.

But the real question @corporal_Canada is : do i stand to attention to you , or you stand to attention to me ? if its me "stand at ease !"
 

Fanboi

Well-Known Member
Joined
Apr 16, 2021
Messages
358
Reaction score
270
Credits
4,288
if bios is in legacy, it goes straight to linux mint....if bios is in uefi... it goes straight to windows 10
no grub
and yes i installed through USB
Don't put it in legacy. Keep it in UEFI, install (reinstall) Mint and use the default settings. That's the sum total of what to do.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,863
Reaction score
2,611
Credits
27,935
Blinking cursor after the system has booted is usually a sign of a problem with the video driver or firmware causing the system not being able to load anything graphical.
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,207
Reaction score
926
Credits
9,049
@corpral_canad
Please tel us the Make Model and full model number of your machine
IF its a home build then the make/model of the motherboard/graphics/sound/ & other main components you used

If you can boot it then please run in a terminal inxi -Fnxz [inxi space -fnxz] copy and paste here...this should tell us all we need to know at this stage

Bwiz
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
@corpral_canad
Please tel us the Make Model and full model number of your machine
IF its a home build then the make/model of the motherboard/graphics/sound/ & other main components you used

If you can boot it then please run in a terminal inxi -Fnxz [inxi space -fnxz] copy and paste here...this should tell us all we need to know at this stage

Bwiz
the pc is essentially a stock lenovo m91p
except for an additional 250gb ssd
additional 250gb hd
an antec 500watt psu that i installed this morning
thats it
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
I wonder if you installed Mint with grub legacy MBR mode and not to efi ?

Actually i think we may be able to confirm that , if you install efibootmgr and use command something like efibootmgr -v if Mint was installed to efi , then efibootmgr should show an entry for it.

But the real question @corporal_Canada is : do i stand to attention to you , or you stand to attention to me ? if its me "stand at ease !"
i installed mint in uefi and (cursor)....
as for saluting... i dont salute muricans sorry
 

brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
1,207
Reaction score
926
Credits
9,049
I have taken a quick look at the original Spc, nothing much is jumping out at me except depending on country and variant you have either
  • ATI Radeon HD5450
  • NVIDIA Quadro FX380 (DVI + DP)
on board graphics if its the HD5450 you may need the legacy drivers in the repository [sorry I don't have the full list of ATI cards & drivers

open a terminal and type in inxi -G [inxi [space]-G and enter , the report will tell us what card and drivers are installed copy and past the results back here

Bwiz
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
just finished installing ubuntu 20.04 i think (in uefi)... and when it had to restart.... it went straight to windows
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
I have taken a quick look at the original Spc, nothing much is jumping out at me except depending on country and variant you have either
  • ATI Radeon HD5450
  • NVIDIA Quadro FX380 (DVI + DP)
on board graphics if its the HD5450 you may need the legacy drivers in the repository [sorry I don't have the full list of ATI cards & drivers

open a terminal and type in inxi -G [inxi [space]-G and enter , the report will tell us what card and drivers are installed copy and past the results back here

Bwiz
no video card im afraid... and i didnt get a chance to put in your command before the ubuntu install ended
 

Fanboi

Well-Known Member
Joined
Apr 16, 2021
Messages
358
Reaction score
270
Credits
4,288
Had a look at that machine's specs. It's quite old. Yep, chances are Ubuntu and derivs are not recognised as "trusted". See for years most mainstream OSes are recognized and trusted, but your machine is running crap firmware. You might get Ubuntu/Mint/etc. support by updating your UEFI BIOS but no guarantees:
Official Lenovo download + instructions. Let us know how it goes.
https://support.lenovo.com/za/en/do...ate-thinkcentre-m81-m91-m91p-thinkstation-e30
 
OP
C
Joined
Jun 8, 2021
Messages
59
Reaction score
12
Credits
362
ive been trying to update the bios since i got this pc so i can install my Radeon, but it isnt like dell (1 exe and boom done) this exe needs a command as shown in the image
Untitled.jpg
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Staff online


Top