Linux mint decided to lock me out of itself all the sudden

C

CrazedNerd

Guest
Speaking from the Fedora partition...

All the sudden it requires a login screen and my password doesn't work. Will try again. This is why security is over-rated and password requirement for root should just be an option on linux systems.
 


OP
C

CrazedNerd

Guest
Speaking from the Fedora partition...

All the sudden it requires a login screen and my password doesn't work. Will try again. This is why security is over-rated and password requirement for root should just be an option on linux systems.
Nope, i typed the password in very slowly and it still didn't work. It's really creepy how i specifically turned off login requirements for this reason and somehow the system just decided to change its mind.
 
OP
C

CrazedNerd

Guest
the only thing that works on the login screen is REISUB, virtual terminals do not.
 
OP
C

CrazedNerd

Guest
i apologize if you weren't trying to be condescending, but grub changes when you have multiple partitions, there's no way of knowing if your recommendation is going to work so we'll see what happens with time. It is a fatal error on a linux system when is screws up it's own administrative password.
 
OP
C

CrazedNerd

Guest
it seems like the same error as this:

 
OP
C

CrazedNerd

Guest
Speaking from the Fedora partition...

All the sudden it requires a login screen and my password doesn't work. Will try again. This is why security is over-rated and password requirement for root should just be an option on linux systems.
probably the best option would be just be to let there be a root and sudo be the same thing...if it's something corporate or organizational, well that's what sysadmins are for. If i can install a linux distro, i should be able to whatever i want to it even if it harms me or the system.
 
OP
C

CrazedNerd

Guest
Solution:

it's funny and a happy coincidence that i realized from the virtual terminal my caps lock key does not work, which means that if you have a password which contains capital letters, then you can't do anything within recovery mode. SO...luckily linux makes it easy to copy and paste your files off of one partition and put it on the OS you are using, my hopes are that they don't change this in the name of security.

I'm opting just for a clean restart using a password with no upper-case letters. I'm really not happy about this since i found such a nice desktop wall-paper for linux mint but the robots have given me no choice. Fedora until i can figure out arch linux...which is something i intend to work on today.
 
OP
C

CrazedNerd

Guest
How did robot effect your OS? I also recommend solus OS
I've already done a complete re-format with Fedora as the only system, just decided go the safe route since i'm a beginner, though not much of one at this point...i'm really adament about having a very thorough understanding of linux, command line, low-level programming, a work in progress.

Sorry for the confusion, i just think of computers as robots, was just getting creative about referring to internal apps inside of linux mint which has now been erased which caused this problem in the first place. Thanks for your help i read your article even though it wasn't relevant since i had multi-boot...and i apologize again for snapping at you since you were just trying to help. What do you like about solus OS?
 
Last edited by a moderator:

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
6,259
Reaction score
4,732
Credits
45,987
it's funny and a happy coincidence that i realized from the virtual terminal my caps lock key does not work, which means that if you have a password which contains capital letters, then you can't do anything within recovery mode.
Why not just use the shift key if your capslock key doesn't work?
 
OP
C

CrazedNerd

Guest
this whole thing was unnecessary, clearly what happened was the screen went into lock mode and then for some reason the caps button doesn't work during some setting...I WILL REMEMBER FROM NOW ON THAT SHIFT IS AN ALTERNATIVE TO CAPS LOCK.
 
OP
D

Deleted member 108694

Guest
Yep I hate the Caps Lock key to me it is the most useless key on the board - because now and then it gets pressed accidentally, creating havoc in your typing. If you wish to disable it, that's quite easy. For all editions of Ubuntu and Ubuntu based OSes, proceed like this:
Make sure that Caps Lock isn't active: the hack you're about to do, makes the Caps Lock key "dead". So if it's active at the time of the hack, it'll remain active!
Launch a terminal window.
Copy/paste the following command line into the terminal:
Code:
setxkbmap -option caps:none
To make it permanent you have to add the command to the startup session
Press Enter.
Done! Now the only way to get capital letters is by keeping the Shift key pressed first.
To Reset Caps lock
Code:
setxkbmap -option
and delete it from the startup session if you added it there
 
OP
C

CrazedNerd

Guest
I just wish I know why linux mint decided it needed to assert the login screen. Oh well, I learned a lot today.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
10,164
Reaction score
8,727
Credits
84,175

Members online


Top