• Rob's side project: I recently started Gun-Forums.com and we currently have a $100 raffle - if you're into guns, join up and enter the raffle to win $100.00. Gun Forums

Linux Mint and Kali Linux taking so long to boot

WhlIlte

New Member
I already had Linux Mint and I installed Kali Linux, everything seemed normal but when i restarted the pc, I realised that both of them were taking 3 minutes to boot while before It were 5 seconds.

Using systemd-analyze time i saw that the userspace was taking 3 minutes, and I "solved" reinstalling the swap partition. But it was still taking so long becouse kernel.
Then i boot the other OS to do the same with the swap partition. But when i returned to the first one, the swap was inactive again, so I can only have it in one OS.

systemd-analyze time (with swap on):
Startup finished in 4.457s (firmware) + 7.134s (loader) + 35.115s (kernel) + 31.179s (userspace) = 1min 17.886s
graphical.target reached after 31.168s in userspace


systemd-analyze time (with swap off):
Startup finished in 4.828s (firmware) + 3.136s (loader) + 35.376s (kernel) + 3min 513ms (userspace) = 3min 43.854s graphical.target reached after 1min 30.659s in userspace

systemd-analyze blame (with swap on):

29.842s plymouth-quit-wait.service
1.087s systemd-logind.service
601ms upower.service
580ms smartmontools.service
524ms systemd-journald.service
356ms networking.service
311ms dev-nvme0n1p7.device
216ms e2scrub_reap.service
199ms boot-efi.mount
178ms udisks2.service
173ms systemd-udev-trigger.service
114ms [email protected]\x2duuid-FF3C\x2d63FC.service
104ms [email protected]\x2duuid-00633ae5\x2de780\x2d4b75\x2daa7d\x2d55f7059bc99a.service
95ms binfmt-support.service
95ms ModemManager.service
87ms NetworkManager.service
79ms [email protected]
76ms accounts-daemon.service
75ms systemd-udevd.service
68ms systemd-journal-flush.service
68ms stunnel4.service
60ms dev-disk-by\x2duuid-81dc674c\x2d8e66\x2d42fe\x2d879c\x2d73cd5b47f49d.swap
52ms [email protected]:intel_backlight.service
48ms pppd-dns.service
47ms rsyslog.service
44ms proc-sys-fs-binfmt_misc.mount
39ms systemd-rfkill.service
34ms gdm.service
29ms colord.service
29ms plymouth-start.service
23ms home.mount
19ms systemd-tmpfiles-setup-dev.service
19ms systemd-tmpfiles-setup.service
17ms plymouth-read-write.service
16ms systemd-remount-fs.service
15ms systemd-random-seed.service
15ms run-rpc_pipefs.mount
12ms [email protected]
11ms systemd-sysusers.service
10ms polkit.service
9ms systemd-update-utmp-runlevel.service
9ms systemd-sysctl.service
9ms wpa_supplicant.service
9ms keyboard-setup.service
9ms systemd-update-utmp.service
8ms systemd-modules-load.service
7ms dev-hugepages.mount
7ms console-setup.service
7ms dev-mqueue.mount
7ms ifupdown-pre.service
7ms systemd-user-sessions.service
6ms nfs-config.service
6ms sys-kernel-debug.mount
5ms kmod-static-nodes.service
4ms rtkit-daemon.service


systemd-analyze blame (with swap off):

296ms dev-nvme0n1p2.device
293ms systemd-logind.service
209ms lightdm.service
209ms plymouth-quit-wait.service
202ms [email protected]
200ms udisks2.service
186ms [email protected]\x2duuid-08B9\x2dE58B.service
172ms systemd-udev-trigger.service
144ms lvm2-monitor.service
136ms upower.service
133ms ubuntu-system-adjustments.service
129ms gpu-manager.service
128ms NetworkManager.service
123ms ModemManager.service
120ms systemd-journal-flush.service
115ms networkd-dispatcher.service
99ms hddtemp.service
94ms apparmor.service
93ms systemd-timesyncd.service
89ms systemd-resolved.service
89ms accounts-daemon.service
87ms grub-common.service
87ms bluetooth.service
86ms thermald.service
79ms keyboard-setup.service
76ms wpa_supplicant.service
74ms avahi-daemon.service
68ms speech-dispatcher.service
64ms lm-sensors.service
54ms alsa-restore.service
53ms systemd-rfkill.service
49ms systemd-journald.service
48ms rsyslog.service
47ms kerneloops.service
38ms networking.service
38ms pppd-dns.service
35ms [email protected]
33ms systemd-modules-load.service
30ms colord.service
20ms systemd-udevd.service
19ms dns-clean.service
18ms kmod-static-nodes.service
17ms dev-mqueue.mount
17ms nvidia-persistenced.service
17ms dev-hugepages.mount
16ms polkit.service
14ms [email protected]\x2duuid-0974a8ae\x2d8cab\x2d49a6\x2dab80\x2d6653c9b7d3b1.service
14ms systemd-tmpfiles-setup.service
14ms ureadahead-stop.service
13ms plymouth-start.service
12ms systemd-sysctl.service
11ms boot-efi.mount
11ms plymouth-read-write.service
10ms systemd-tmpfiles-setup-dev.service
9ms sys-kernel-debug.mount
9ms tor.service


Kali Linux: 2020.1
Linux Mint: 19.3
Kernel: 5.3.0-40
 
Last edited:


WhlIlte

New Member
Reinstall the kernel
Thank you for answering, the problema with the swap is solved, but when I try to reinstall de kernel with: sudo apt-get install --reinstall linux-image-5.3.0-40-generic.
It throws an error:

Code:
Errors were encountered while processing:
linux-image-5.3.0-40-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

WhlIlte

New Member
This:

sudo update-initramfs -u

Should work
This is the output:

Code:
update-initramfs: Generating /boot/initrd.img-5.3.0-40-generic
/usr/sbin/mkinitramfs: 1: /etc/initramfs-tools/conf.d/resume.save: W:: not found
/usr/sbin/mkinitramfs: 2: /etc/initramfs-tools/conf.d/resume.save: W:: not found
/usr/sbin/mkinitramfs: 3: /etc/initramfs-tools/conf.d/resume.save: I:: not found
/usr/sbin/mkinitramfs: 4: /etc/initramfs-tools/conf.d/resume.save: Syntax error: word unexpected (expecting ")")
update-initramfs: failed for /boot/initrd.img-5.3.0-40-generic with 2.
 


Members online


Latest posts

Top