Linux Kernel Update

phanmetal

Member
Joined
Feb 22, 2022
Messages
32
Reaction score
16
Credits
217
Hi friends.

I am using elementaryOS 5.1.7 Hera in long time.
Kernel; Xanmod Kernel 5.15.

I want upgrade to Offical Linux 5.16/5.17 but i cant.
Is there an easy way to update?

I have AMD CPU and official Linux 5.16 has made significant strides for AMD CPU.

Thanks you.
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,776
Reaction score
3,433
Credits
34,774
Don't bump, if you are running the Xanmod Kernel currently and want to switch over to the default kernel that comes with Elementary is that you have to install the kernel package if it's already installed. Can you share the output of the following by running it in the terminal?
Code:
dpkg --list | grep linux
 
OP
P

phanmetal

Member
Joined
Feb 22, 2022
Messages
32
Reaction score
16
Credits
217
Don't bump, if you are running the Xanmod Kernel currently and want to switch over to the default kernel that comes with Elementary is that you have to install the kernel package if it's already installed. Can you share the output of the following by running it in the terminal?
Code:
dpkg --list | grep linux
Code:
ii  binutils-x86-64-linux-gnu                  2.30-21ubuntu1~18.04.7                                                         amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                        1.178ubuntu2.9                                                                 all          Linux specific part of console-setup
ii  libselinux1:amd64                          2.7-2build2                                                                    amd64        SELinux runtime shared libraries
ii  libselinux1:i386                           2.7-2build2                                                                    i386         SELinux runtime shared libraries
ii  libv4l-0:amd64                             1.14.2-1                                                                       amd64        Collection of video4linux support libraries
ii  libv4l-0:i386                              1.14.2-1                                                                       i386         Collection of video4linux support libraries
ii  libv4lconvert0:amd64                       1.14.2-1                                                                       amd64        Video4linux frame format conversion library
ii  libv4lconvert0:i386                        1.14.2-1                                                                       i386         Video4linux frame format conversion library
ii  linux-base                                 4.5ubuntu1.7                                                                   all          Linux image base package
ii  linux-firmware                             1.201                                                                          all          Firmware for Linux kernel drivers
ii  linux-generic-hwe-18.04                    5.4.0.99.112~18.04.86                                                          amd64        Complete Generic Linux kernel and headers
ii  linux-headers-5.15.24-xanmod1              5.15.24-xanmod1-0~git20220216.6c16085                                          amd64        Linux kernel headers for 5.15.24-xanmod1 on amd64
ii  linux-headers-5.4.0-99-generic             5.4.0-99.112~18.04.1                                                           amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-generic-hwe-18.04            5.4.0.99.112~18.04.86                                                          amd64        Generic Linux kernel headers
ii  linux-hwe-5.4-headers-5.4.0-99             5.4.0-99.112~18.04.1                                                           all          Header files related to Linux kernel version 5.4.0
ii  linux-image-5.15.24-xanmod1                5.15.24-xanmod1-0~git20220216.6c16085                                          amd64        Linux kernel, version 5.15.24-xanmod1
rc  linux-image-5.4.0-42-generic               5.4.0-42.46~18.04.1                                                            amd64        Signed kernel image generic
ii  linux-image-5.4.0-99-generic               5.4.0-99.112~18.04.1                                                           amd64        Signed kernel image generic
ii  linux-image-generic-hwe-18.04              5.4.0.99.112~18.04.86                                                          amd64        Generic Linux kernel image
ii  linux-image-unsigned-5.3.0-1045-gke        5.3.0-1045.48                                                                  amd64        Linux kernel image for version 5.3.0 on 64 bit x86 SMP
ii  linux-libc-dev:amd64                       4.15.0-167.175                                                                 amd64        Linux Kernel Headers for development
ii  linux-modules-5.3.0-1045-gke               5.3.0-1045.48                                                                  amd64        Linux kernel extra modules for version 5.3.0 on 64 bit x86 SMP
rc  linux-modules-5.4.0-42-generic             5.4.0-42.46~18.04.1                                                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-99-generic             5.4.0-99.112~18.04.1                                                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.4.0-42-generic       5.4.0-42.46~18.04.1                                                            amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-99-generic       5.4.0-99.112~18.04.1                                                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-sound-base                           1.0.25+dfsg-0ubuntu5                                                           all          base package for ALSA and OSS sound systems
ii  linux-xanmod                               5.15.24-xanmod1-0                                                              amd64        Complete XanMod Linux kernel and headers (STABLE) (5.15)
ii  pptp-linux                                 1.9.0+ds-2                                                                     amd64        Point-to-Point Tunneling Protocol (PPTP) Client
ii  util-linux                                 2.31.1-0.4ubuntu3.7                                                            amd64        miscellaneous system utilities
 

Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,656
Reaction score
1,759
Credits
19,882
Bumping your question will not get you any quicker answers, we are not a professional help site, we are all volunteers with differing specialities spread across the 5 continents and every time zone, so you need to have patience until one of us pick up your question.
It is not recommended that you change to the latest kernel until your distribution releases it to their stream, you can manually install any kernel on Ubuntu based distributions, but be warned it could break your installation..
 
OP
P

phanmetal

Member
Joined
Feb 22, 2022
Messages
32
Reaction score
16
Credits
217
Bumping your question will not get you any quicker answers, we are not a professional help site, we are all volunteers with differing specialities spread across the 5 continents and every time zone, so you need to have patience until one of us
I didn't get professional help/answer. I saw it like a normal forum site and stated my problem like a normal member.

Thank you for answer.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,776
Reaction score
3,433
Credits
34,774
I didn't get professional help/answer. I saw it like a normal forum site and stated my problem like a normal member.

Thank you for answer.
Bumping is frowned upon in most forums, so here as well.
 
OP
P

phanmetal

Member
Joined
Feb 22, 2022
Messages
32
Reaction score
16
Credits
217

Attachments

  • Screenshot from 2022-02-22 19.36.15.png
    Screenshot from 2022-02-22 19.36.15.png
    27.7 KB · Views: 72

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,776
Reaction score
3,433
Credits
34,774
OP
P

phanmetal

Member
Joined
Feb 22, 2022
Messages
32
Reaction score
16
Credits
217
Can you share the output of the following?
Code:
apt search linux-generic

Then why bump if you know that is true.
Where is the bump?




Code:
linux-modules-extra-5.4.0-89-generic/bionic-updates,bionic-security 5.4.0-89.100~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-90-generic/bionic-updates,bionic-security 5.4.0-90.101~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-91-generic/bionic-updates,bionic-security 5.4.0-91.102~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-92-generic/bionic-updates,bionic-security 5.4.0-92.103~18.04.2 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-94-generic/bionic-updates,bionic-security 5.4.0-94.106~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-96-generic/bionic-updates,bionic-security 5.4.0-96.109~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-97-generic/bionic-updates,bionic-security 5.4.0-97.110~18.04.1 amd64

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP



linux-modules-extra-5.4.0-99-generic/bionic-updates,bionic-security,now 5.4.0-99.112~18.04.1 amd64 [installed,automatic]

  Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP

linux-oem/bionic-updates,bionic-security 5.4.0.100.113~18.04.87 amd64

  Complete oem kernel image and headers (dummy transitional package)



linux-tools-oem/bionic-updates,bionic-security 5.4.0.100.113~18.04.87 amd64

  OEM kernel versioned tools (dummy transitional package)
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,776
Reaction score
3,433
Credits
34,774
Where is the bump?
When you replied with "Up" to your topic, it's the same as bumping.

Looks like in ElementaryOS repos you don't have access to kernel 5.16. You could try installing the mainline kernel on your system, since Elementary is based on Ubuntu this should work.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation


Top