<!DOCTYPE html>






	
	
		
	




	









	




	




	





	




	
		
	
	
	
		
	


<html id="XenForo" lang="en-US" dir="LTR" class="Public NoJs uix_javascriptNeedsInit LoggedOut Sidebar  Responsive pageIsLtr hasWelcomeBlock  hasTabLinks  hasSearch   is-sidebarOpen hasRightSidebar is-fullWidth navStyle_0 pageStyle_0 hasFlexbox" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>

<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="theme-color" content="#ffffff">

	<meta charset="utf-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
	
		<meta name="viewport" content="width=device-width, initial-scale=1" />
	
	
		<base href="https://www.linux.org/" />
		<script>
			var _b = document.getElementsByTagName('base')[0], _bH = "https://www.linux.org/";
			if (_b && _b.href != _bH) _b.href = _bH;
		</script>
	

	<title>Linux in Windows 10 | Linux.org</title>

	<noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
	<link rel="stylesheet" href="css.php?css=xenforo,form,public&amp;style=3&amp;dir=LTR&amp;d=1495740434" />

	<link rel="stylesheet" href="css.php?css=BRMI_forum_list_sidebar,EWRporta2_Global,bb_code,likes_summary,login_bar,message,message_user_info,moderator_bar,notices,polls,share_page,thread_view,uix_extendedFooter,uix_welcomeBlock,wf_default&amp;style=3&amp;dir=LTR&amp;d=1495740434" />


	<link rel="stylesheet" href="css.php?css=uix,uix_style&amp;style=3&amp;dir=LTR&amp;d=1495740434" />

	<style>
	/*** UIX -- PER USER STYLES ***/

	

	


	

</style>

	<link rel="stylesheet" href="css.php?css=EXTRA&amp;style=3&amp;dir=LTR&amp;d=1495740434" />

	

	<style>
/* Node Styling */

</style>

	

	

	<script>

	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	
	ga('create', 'UA-3314314-270', 'auto');
	ga('send', 'pageview');

</script>
	
	












<link href="styles/uix/uix/css/font-awesome.min.css" rel="stylesheet">
<link href='//fonts.googleapis.com/css?family=Open+Sans:300,400,700,600' rel='stylesheet' type='text/css'>


<script src="js/jquery/jquery-1.11.0.min.js"></script>



<script src="js/xenforo/xenforo.js?_v=4cc2e9c1"></script>
	<script src="js/xenforo/discussion.js?_v=4cc2e9c1"></script>
	<script src="js/brivium/MailchimpIntegrate/newsletter.js?_v=4cc2e9c1"></script>




<!--[if lt IE 9]>
	
		 
        	<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.2/html5shiv.min.js"></script>
	        
	        <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.js"></script>
	        
	        <script src="//cdnjs.cloudflare.com/ajax/libs/selectivizr/1.0.2/selectivizr-min.js"></script>
	

<![endif]-->



<script>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</script>

<script src="js/audentio/uix_style/functions.min.js?_v=4cc2e9c1_1.5.13.0_1"></script>

<script>
	uix.adminJsError = function(errMsg) {
		console.error(errMsg);

		
	}

	uix.fixJsVisibility = function() {
		var userBar = $('.hasJs #userBar');
		var nodeList = $('.hasJs #forums, .hasJs .category_view .nodeList, .hasJs .watch_forums .nodeList');
		var panels = $('.js-uix_panels')
		if (userBar.length) userBar.css('display', 'block');
		if (nodeList.length) nodeList.css('visibility', 'visible');
		if (panels.length) $('.js-uix_panels').removeClass('needsInit');
		$('html').removeClass('uix_javascriptNeedsInit');
	}

	uix.catchJsError = function(err) {
		console.log("\n\n############============   Begin Copying Here   ============############\n\n")
		var errMsg = "Uh Oh!  It looks like there's an error in your page's javascript.  There will likely be significant issues with the use of the forum until this is corrected.  If you are unable to resolve this and believe it is due to a bug in your Audentio Design theme, contact Audentio support and include a copy of the text between the designated areas from your javascript console.  This is the error: \n\n" + err ;
		uix.fixJsVisibility();
		uix.adminJsError(errMsg);
		console.log("\n\n");
		console.log(err);
		console.log("\n\n");
		try {
			uix.debug(true);
		} catch (err) {
			console.log("Unable to include uix.debug();");
		}

		console.log("\n\n############============   End Copying Here   ============############\n\n");
	}

	$(document).ready(function(){
		if (typeof(audentio) === 'undefined' || typeof(uix.jsVersion) === 'undefined') {
			var errMsg = 'Uh Oh!  It looks like the javascript for your theme was not found in /js/audentio/uix_style/.\n\n';
			if (uix.jsGlobal) {
				errMsg += 'Your forum is set to use the same javascript directory for all your themes.  Consider disabling this or modifying the directory.  Options are located under Options > [UI.X] General.\n\n'
			} else {
				errMsg += 'Your theme has set the location of its javascript directory.  You may need to modify the javascript directory location style property located under [UI.X] Global Settings > Javascript Path.\n\n'
			}
			errMsg += 'If your files are in the directory specified, ensure that your file permissions allow them to be read.  There will likely be significant issues with the use of the forum until this is corrected.  If you are unable to resolve this, contact Audentio support.  This error has also been logged to the javascript console.';

			uix.fixJsVisibility();

			uix.adminJsError(errMsg);
		} else if (uix.jsHeadVersion.split('_')[0] != uix.jsVersion.split('_')[0]) {
			var errMsg = 'Uh Oh! It looks like the version of your javascript functions file does not match the version of your page_container_js_head template.  \n\nYour javascript functions file is version "' + uix.jsVersion + '". \nYour page_container_js_head is version "' + uix.jsHeadVersion + '".  \n\nIf your functions file version number is higher, ensure that you have merged all templates (especially page_container_js_head).  If your page_container_js_head version number is higher, ensure that you have correctly uploaded the latest version of the javascript functions file and that you have cleared anything that could cache an old version of the javascript (CDN / Cloudflare / etc.). \n\nThis issue could cause parts of your forum to not display or function correctly.  If this does not resolve the issue contact Audentio support.  This error has also been logged to the javascript console.';
			
			uix.fixJsVisibility();
			
			uix.adminJsError(errMsg);
		}
	});
</script>

<script>
	try {
		uix.dateHelper.phrase = {
			now: 'now',
			second: 's',
			minute: 'm',
			hour: 'h',
			day: 'd',
			week: 'w',
			year: 'y',
			century: 'c',
			ago: '{time} ago',
			future: 'in {time}'
		}


		uix.sticky.stickyMinDist = parseInt('50');

		$(document).ready(function(){
			try {
				
				
					audentio.pagination.enabled = true;
					
						audentio.grid.parentEle = 'navigation';
					
					audentio.pagination.outOfPhrase = '<span id="audentio_postPaginationCurrent" class="uix_postPagination_x"></span> / <span id="audentio_postPaginationTotal" class="uix_postPagination_y"></span>';
					audentio.pagination.enterIndexPhrase = 'Enter Index';
					audentio.pagination.offset = parseInt('0px');
				

				uix.initFunc();
			} catch (err) {
				uix.catchJsError(err);
			}
		});
	} catch (err) {
		uix.catchJsError(err);
	}
</script>



	<link href="/favicon.ico" rel="icon" type="image/x-icon" />
	<!--
	<link rel="apple-touch-icon" href="https://www.linux.org/images/linuxfav.png" />
	-->
	<link rel="alternate" type="application/rss+xml" title="RSS feed for Linux.org" href="forums/-/index.rss" />
	
	
	<link rel="canonical" href="https://www.linux.org/threads/linux-in-windows-10.4571/" />
	<meta name="description" content="To think of Linux on Windows 10 you may be imagining running it under VirtualBox. Now, you can run Linux on Windows 10 in a Command Shell.

For now, it..." />	<meta property="og:site_name" content="Linux.org" />
	<meta property="og:image" content="https://www.linux.org/data/avatars/m/29/29858.jpg?1495487162" />
	<meta property="og:image" content="https://www.linux.org/images/linuxfav.png" />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="https://www.linux.org/threads/linux-in-windows-10.4571/" />
	<meta property="og:title" content="Linux in Windows 10" />
	<meta property="og:description" content="To think of Linux on Windows 10 you may be imagining running it under VirtualBox. Now, you can run Linux on Windows 10 in a Command Shell.

For now, it..." />
	
	
	




	
		<meta name="theme-color" content="rgb(73, 147, 197)">
		<meta name="msapplication-TileColor" content="rgb(73, 147, 197)">
	

</head>

<body class="node134 node122 SelectQuotable">

	

	
		

<div id="loginBar">
	<div class="pageContent">
		<span class="helper"></span>
	</div>
	<div class="pageWidth">

		

	</div>
</div>
	

	
		
		<div class="js-uix_panels uix_panels ">
			
				

<aside class="js-sidePanelWrapper sidePanelWrapper  sidePanelWrapper--left">
	<a href="#" class="js-panelMask uix_panelMask"></a>
	
		<div class="sidePanel sidePanel--nav">
			<nav>
<ul class="sidePanel__navTabs">
	
							<!-- home -->
							


								<!-- extra tabs: home -->
								
								
									
										
											<li class="navTab articles ">
								
												<a href="https://www.linux.org/" class="navLink">Home</a>
												<a href="https://www.linux.org/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
									
												<div class="tabLinks">
													<ul class="secondaryContent blockLinksList">
	
	<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
	<li><a href="recent-activity/">Recent Activity</a></li>

	<li style="width: 50px; height: 10px;"></li>
	<li><a href="articles/authors">Authors</a></li>
	
</ul>
												</div>
											</li>
										
									
								
								


								<!-- forums -->
								
									
										<li class="navTab forums selected">

											<a href="https://www.linux.org/forums/" class="navLink">Forums</a>
											<a href="https://www.linux.org/forums/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
								
											<div class="tabLinks">
									
													<ul class="secondaryContent blockLinksList">
													
														
														<li><a href="search/?type=post">Search Forums</a></li>
														
														<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
													
													</ul>
									
											</div>
										</li>
								
								

								<!-- extra tabs: middle -->
								


								<!-- members -->
								
									
											<li class="navTab members ">

												<a href="https://www.linux.org/members/" class="navLink">Members</a>
												<a href="https://www.linux.org/members/" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
									
												<div class="tabLinks">
									
													<ul class="secondaryContent blockLinksList">
													
														<li><a href="members/">Notable Members</a></li>
														
														<li><a href="online/">Current Visitors</a></li>
														<li><a href="recent-activity/">Recent Activity</a></li>
														<li><a href="find-new/profile-posts">New Profile Posts</a></li>
													
													</ul>
									
											</div>
										</li>
								

								<!-- extra tabs: end -->
								
								
									
										
											<li class="navTab siropuCustomTab custom-tab-1 ">
												<a href="https://www.linux.org/account/upgrades" class="navLink Tooltip" title="Purchase a membership upgrade!">Membership Upgrade</a>
											</li>
										
									
								
									
										
											<li class="navTab siropuCustomTab custom-tab-2 ">
								
											<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="navLink Tooltip" title="Linux Tutorials">Tutorials</a>
											<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="SplitCtrl"><i class="uix_icon js-offcanvasIcon uix_icon-expandDropdown"></i></a>
								
											<div class="tabLinks">
												<ul class="secondaryContent blockLinksList">
	
		
			<li><a href="https://www.linux.org/forums/beginner-tutorials.123/" class="">Beginner Linux Tutorials</a></li>
		
	
		
			<li><a href="https://www.linux.org/forums/intermediate-tutorials.124/" class="">Intermediate Linux Tutorials</a></li>
		
	
		
			<li><a href="https://www.linux.org/forums/advanced-tutorials.125/" class="">Advanced Linux Tutorials</a></li>
		
	
</ul>
											</div>
										</li>
										
									
								
									
										
											<li class="navTab siropuCustomTab custom-tab-6 ">
												<a href="https://www.linux.org/pages/download/" class="navLink">Download Linux</a>
											</li>
										
									
								
								

	

</ul>
</nav>
		</div>
	
</aside>
			
			
				

<aside class="js-sidePanelWrapper sidePanelWrapper  sidePanelWrapper--right">
	<a href="#" class="js-panelMask uix_panelMask"></a>
	
		
			<div class="sidePanel sidePanel--login">
				<form action="login/login" method="post" class="xenForm--uixLoginForm xenForm">

	<dl class="ctrlUnit fullWidth">
		<dt><label for="ctrl_pageLogin_login">Your name or email address:</label></dt>
		<dd><input type="text" name="login" value="" id="ctrl_pageLogin_login" class="textCtrl uix_fixIOSClickInput" tabindex="21" /></dd>
	</dl>

	<dl class="ctrlUnit fullWidth">
		<dt><label for="ctrl_pageLogin_password">Password:</label></dt>
		<dd>
			<input type="password" name="password" class="textCtrl uix_fixIOSClickInput" id="ctrl_pageLogin_password" tabindex="22" />
			<div><a href="lost-password/" class="OverlayTrigger OverlayCloser" tabindex="26">Forgot your password?</a></div>
		</dd>
	</dl>

	

	<dl class="ctrlUnit submitUnit">
		<dd>
			<input type="submit" class="button primary" value="Log in" data-loginPhrase="Log in" data-signupPhrase="Sign up" tabindex="24" />
			<label class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_pageLogin_remember" tabindex="23" /> Stay logged in</label>
		</dd>
	</dl>

	

	<input type="hidden" name="cookie_check" value="1" />
	<input type="hidden" name="_xfToken" value="" />
	<input type="hidden" name="redirect" value="/threads/linux-in-windows-10.4571/" />
	

</form>
			</div>
		
	
</aside>
			

			<div class="mainPanelWrapper">
				<a href="#" class="js-panelMask uix_panelMask"></a>

	

	

<div class="uix_wrapperFix" style="height: 1px; margin-bottom: -1px;"></div>

<div id="uix_wrapper">
<div class="uix_wrapperFix" style="height: 1px; margin-bottom: -1px;"></div>

<div id="headerMover">
	<div id="headerProxy"></div>
<header>
	


<div id="header">
	



	

	
		<div id="logoBlock" class="header__blockItem withSearch">

	
	<div class="pageWidth">
	

		<div class="pageContent">

		

		
		<div id="logo"><a href="https://www.linux.org/">
			<span></span>
			<img src="styles/uix/uix/logo.png" alt="Linux.org" />
			
		</a></div>
		

		
			

<div id="searchBar" class="hasSearchButton">
	
	<i id="QuickSearchPlaceholder" class="uix_icon uix_icon-search" title="Search"></i>

	
		

	

	<div id="uix_searchMinimal">
		<form action="search/search" method="post">
			<i id="uix_searchMinimalClose" class="uix_icon uix_icon-close"  title="Close"></i>
			<i id="uix_searchMinimalOptions" class="uix_icon uix_icon-cog" title="Options"></i>
			<div id="uix_searchMinimalInput" >
				<input type="search" name="keywords" value="" placeholder="Search..." results="0" />
			</div>
			<input type="hidden" name="_xfToken" value="" />
		</form>
	</div>





	


	<fieldset id="QuickSearch">
		<form action="search/search" method="post" class="formPopup">

			<div class="primaryControls">
				<!-- block: primaryControls -->
				<i class="uix_icon uix_icon-search" onclick='$("#QuickSearch form").submit()'></i>
				<input type="search" name="keywords" value="" class="textCtrl" placeholder="Search..." results="0" title="Enter your search and hit enter" id="QuickSearchQuery" />
				<!-- end block: primaryControls -->
			</div>

			<div class="secondaryControls">
				<div class="controlsWrapper">

					<!-- block: secondaryControls -->
					<dl class="ctrlUnit">
						<dt></dt>
						<dd><ul>
							<li><label><input type="checkbox" name="title_only" value="1"
								id="search_bar_title_only" class="AutoChecker"
								data-uncheck="#search_bar_thread" /> Search titles only</label></li>
						</ul></dd>
					</dl>

					<dl class="ctrlUnit">
						<dt><label for="searchBar_users">Posted by Member:</label></dt>
						<dd>
							<input type="text" name="users" value="" class="textCtrl AutoComplete" id="searchBar_users" />
							<p class="explain">Separate names with a comma.</p>
						</dd>
					</dl>

					<dl class="ctrlUnit">
						<dt><label for="searchBar_date">Newer Than:</label></dt>
						<dd><input type="date" name="date" value="" class="textCtrl" id="searchBar_date" /></dd>
					</dl>

					
					<dl class="ctrlUnit">
						<dt></dt>
						<dd><ul>
								
									<li><label title="Search only Linux in Windows 10"><input type="checkbox" name="type[post][thread_id]" value="4571"
	id="search_bar_thread" class="AutoChecker"
	data-uncheck="#search_bar_title_only, #search_bar_nodes" /> Search this thread only</label></li>
								
									<li><label title="Search only Linux.org Articles"><input type="checkbox" name="nodes[]" value="134"
	id="search_bar_nodes" class="Disabler AutoChecker" checked="checked"
	data-uncheck="#search_bar_thread" /> Search this forum only</label>
	<ul id="search_bar_nodes_Disabler">
		<li><label><input type="checkbox" name="type[post][group_discussion]" value="1"
			id="search_bar_group_discussion" class="AutoChecker"
			data-uncheck="#search_bar_thread" /> Display results as threads</label></li>
	</ul></li>
								
						</ul></dd>
					</dl>
					
				</div>
				<!-- end block: secondaryControls -->

				<dl class="ctrlUnit submitUnit">
					<dt></dt>
					<dd>
						<input type="submit" value="Search" class="button primary Tooltip" title="Find Now" />
						<a href="search/" class="button moreOptions Tooltip" title="Advanced Search">More...</a>
						<div class="Popup" id="commonSearches">
							<a rel="Menu" class="button NoPopupGadget Tooltip" title="Useful Searches" data-tipclass="flipped"><span class="arrowWidget"></span></a>
							<div class="Menu">
								<div class="primaryContent menuHeader">
									<h3>Useful Searches</h3>
								</div>
								<ul class="secondaryContent blockLinksList">
									<!-- block: useful_searches -->
									<li><a href="find-new/posts?recent=1" rel="nofollow">Recent Posts</a></li>
									
									<!-- end block: useful_searches -->
								</ul>
							</div>
						</div>
					</dd>
				</dl>

			</div>

			<input type="hidden" name="_xfToken" value="" />
		</form>
	</fieldset>
	

</div>
		

		<span class="helper"></span>
		</div>
	</div>
</div>
	

	



<div id="navigation" class="header__blockItem  stickyTop">
	<div class="sticky_wrapper">
		<div class="uix_navigationWrapper">
		
		<div class="pageWidth">
		
			<div class="pageContent">
				<nav>
					<div class="navTabs">
						

							<ul class="publicTabs navLeft">

							
							<li id="logo_small">
								<a href="https://www.linux.org/">
								
									<img src="styles/uix/uix/logo_small.png">
								
								</a>
							</li>
							

							





	

	
		
	


	

	
		
	













	<li class="navTab  navTab--panelTrigger navTab--navPanelTrigger PopupClosed">
		<a class="navLink js-leftPanelTrigger" href="#">
			<i class="uix_icon uix_icon-menu"></i><span class="trigger__phrase">Menu</span>
		</a>
	</li>



							<!-- home -->
							


								<!-- extra tabs: home -->
								
								
									
										
											<li class="navTab articles Popup PopupControl PopupClosed">
												<a href="https://www.linux.org/" class="navLink">Home</a>
												<a href="https://www.linux.org/" class="SplitCtrl" rel="Menu"></a>
		
												<div class="Menu JsOnly tabMenu articlesTabLinks">
													
														<div class="primaryContent menuHeader">
															<h3>Home</h3>
															<div class="muted">Quick Links</div>
														</div>
														<ul class="secondaryContent blockLinksList">
	
	<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
	<li><a href="recent-activity/">Recent Activity</a></li>

	<li style="width: 50px; height: 10px;"></li>
	<li><a href="articles/authors">Authors</a></li>
	
</ul>
														
													
												</div>
											</li>
										
									
								
								


								<!-- forums -->
								
									
										<li class="navTab forums selected">
	
											<a href="https://www.linux.org/forums/" class="navLink">Forums</a>
											<a href="https://www.linux.org/forums/" class="SplitCtrl" rel="Menu"></a>
	
											<div class="tabLinks forumsTabLinks">
												
													<div class="primaryContent menuHeader">
														<h3>Forums</h3>
														<div class="muted">Quick Links</div>
													</div>
									
													<ul class="secondaryContent blockLinksList">
													
														
														<li><a href="search/?type=post">Search Forums</a></li>
														
														<li><a href="find-new/posts" rel="nofollow">Recent Posts</a></li>
													
													</ul>
									
													
												
									
											</div>
										</li>
								
								

								<!-- extra tabs: middle -->
								


								<!-- members -->
								
									
										<li class="navTab members Popup PopupControl PopupClosed">
	
											<a href="https://www.linux.org/members/" class="navLink">Members</a>
											<a href="https://www.linux.org/members/" class="SplitCtrl" rel="Menu"></a>
	
											<div class="Menu JsOnly tabMenu membersTabLinks">
												
													<div class="primaryContent menuHeader">
														<h3>Members</h3>
														<div class="muted">Quick Links</div>
													</div>
									
													<ul class="secondaryContent blockLinksList">
													
														<li><a href="members/">Notable Members</a></li>
														
														<li><a href="online/">Current Visitors</a></li>
														<li><a href="recent-activity/">Recent Activity</a></li>
														<li><a href="find-new/profile-posts">New Profile Posts</a></li>
													
													</ul>
									
													
												
									
											</div>
										</li>
								

								<!-- extra tabs: end -->
								
								
									
										
											<li class="navTab siropuCustomTab custom-tab-1 PopupClosed">
												<a href="https://www.linux.org/account/upgrades" class="navLink Tooltip" title="Purchase a membership upgrade!">Membership Upgrade</a>
												
											</li>
										
									
								
									
										
											<li class="navTab siropuCustomTab custom-tab-2 Popup PopupControl PopupClosed">
	
											<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="navLink Tooltip" title="Linux Tutorials">Tutorials</a>
											<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="SplitCtrl" rel="Menu"></a>
	
											<div class="Menu JsOnly tabMenu siropuCustomTab custom-tab-2TabLinks">
												
													<div class="primaryContent menuHeader">
														<h3>Tutorials</h3>
														<div class="muted">Quick Links</div>
													</div>
													<ul class="secondaryContent blockLinksList">
	
		
			<li><a href="https://www.linux.org/forums/beginner-tutorials.123/" class="">Beginner Linux Tutorials</a></li>
		
	
		
			<li><a href="https://www.linux.org/forums/intermediate-tutorials.124/" class="">Intermediate Linux Tutorials</a></li>
		
	
		
			<li><a href="https://www.linux.org/forums/advanced-tutorials.125/" class="">Advanced Linux Tutorials</a></li>
		
	
</ul>
													
												
											</div>
										</li>
										
									
								
									
										
											<li class="navTab siropuCustomTab custom-tab-6 PopupClosed">
												<a href="https://www.linux.org/pages/download/" class="navLink">Download Linux</a>
												
											</li>
										
									
								
								

								<!-- responsive popup -->
								<li class="navTab navigationHiddenTabs navTab--justIcon Popup PopupControl PopupClosed" style="display:none">

									<a rel="Menu" class="navLink NoPopupGadget uix_dropdownDesktopMenu"><i class="uix_icon uix_icon-navOverflow"></i><span class="uix_hide menuIcon">Menu</span></a>

									<div class="Menu JsOnly blockLinksList primaryContent" id="NavigationHiddenMenu"></div>
								</li>

								
								<!-- no selection -->
								
								

								
									
									
								

							</ul>


							


								<ul class="navRight visitorTabs">

								

									
										<li class="navTab audentio_postPagination" id="audentio_postPagination"></li>
									

									

									

									
										

	<li class="navTab login PopupClosed">
		
			<a href="login/" class="navLink uix_dropdownDesktopMenu OverlayTrigger" data-cacheOverlay="false">
				
				<strong class="loginText">Log in</strong>
			</a>
		

		

	</li>

	
	<li class="navTab register PopupClosed">
		<a href="register/" class="navLink">
			
			<strong>Sign up</strong>
		</a>
	</li>
	


									

									

									





	

	
		
	


	

	
		
	











									

								

								</ul>

							

							


						
					</div>

				<span class="helper"></span>

				</nav>
			</div>
		</div>
		</div>
	</div>
</div>



	
</div>

	
	
</header>

<div id="content" class="thread_view">
	
	<div class="pageWidth">
		<div class="pageContent">
	
			<!-- main content area -->

			

			

			
			
			<div class="breadBoxTop  ">
				
				

<nav>

	

	
		
			
				
			
		
			
				
			
		
	

	<fieldset class="breadcrumb">
		<a href="misc/quick-navigation-menu?selected=node-134" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i><!--Jump to...--></a>

		<div class="boardTitle"><strong>Linux.org</strong></div>

		<span class="crumbs">
			
				<span class="crust homeCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="https://www.linux.org/" class="crumb" rel="up" itemprop="url"><span itemprop="title"><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
					<span class="arrow"><span></span></span>
				</span>
			

			
				<span class="crust selectedTabCrumb" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
					<a href="https://www.linux.org/forums/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Forums</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
			

			
				
					<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
						<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux Articles and Tutorials</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
					<span class="crust" itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb">
						<a href="https://www.linux.org/forums/linux-org-articles.134/" class="crumb" rel="up" itemprop="url"><span itemprop="title">Linux.org Articles</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
			
		</span>
	</fieldset>
</nav>
				
			</div>
			
			

			

	<div class="sectionMain funbox">
	<div class="funboxWrapper">
	

		
			
				



				

<div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Text & Display Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4059641217434021"
     data-ad-slot="6079404386"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

			
		

	
	</div>
	</div>



			

			

			


	
	
	
	
	

	



	
	<div id="uix_welcomeBlock" class="">
		
			<span class="uix_welcomeBlock__icon"><i class="uix_icon fa fa-info-circle"></i></span>

<a href="#" class="close"><i class="uix_icon uix_icon-close"></i></a>

<div class="uix_welcomeBlock__content">

	<h3 class="uix_welcomeBlock__header">Welcome to Our Community</h3>

	<p class="uix_welcomeBlock__message">While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users).  If you signed up before April 23rd please sign up again.

Thanks!</p>

	<div class="uix_welcomeBlock__button"><a href="index.php?register" class="signupButton"><span>Sign Up</span></a></div>

</div>
		
	</div>
	

			
				<div class="uix_contentFix">
					<div class="mainContainer">

			
					<div class="mainContent">
						<!--[if lt IE 8]>
							<p class="importantMessage">You are using an out of date browser. It  may not display this or other websites correctly.<br />You should upgrade or use an <a href="https://www.google.com/chrome/browser/" target="_blank">alternative browser</a>.</p>
						<![endif]-->

						
						
						


	
	
	<div class="FloatingContainer Notices">
		
			<div class="DismissParent Notice notice_1 " data-notice="1" data-delay-duration="0" data-display-duration="0" data-auto-dismiss="0">
				<div class="floatingItem primary">
					
						<a href="account/dismiss-notice?notice_id=1"
							title="Dismiss Notice" class="DismissCtrl Tooltip" data-offsetx="7" data-tipclass="flipped">Dismiss Notice</a>
					
					<div class=" baseHtml noticeContent">
						<a href="http://www.linux.org/threads/linux-org-under-new-management.1/">Linux.org under new management -
 click here for details</a>
					</div>
				</div>
			</div>
		
	</div>


						
						

						

						
						
							
								<!-- h1 title, description -->
								<div class="titleBar">
									
									<h1>Linux in Windows 10</h1>

									<p id="pageDescription" class="muted ">
	Discussion in '<a href="forums/linux-org-articles.134/">Linux.org Articles</a>' started by <a href="members/jarret-b.29858/" class="username" dir="auto">Jarret B</a>, <a href="threads/linux-in-windows-10.4571/"><abbr class="DateTime" data-time="1496092381" data-diff="128276" data-datestring="May 29, 2017" data-timestring="10:13 PM">May 29, 2017 at 10:13 PM</abbr></a>.
</p>
								</div>
							
						
						

						

						<!-- main template -->
						
	





	






























	




<div class="pageNavLinkGroup">
	<div class="linkGroup SelectionCountContainer">
		
		
	</div>

	
</div>





<form action="inline-mod/post/switch" method="post"
	class="InlineModForm section"
	data-cookieName="posts"
	data-controls="#InlineModControls"
	data-imodOptions="#ModerationSelect option">

	<ol class="messageList" id="messageList">
		
			
				


<li id="post-12702" class="sectionMain message     uix_threadAuthor uix_discussionAuthor" data-author="Jarret B">

	<div class="uix_message ">

		

	

	














<div class="messageUserInfo" itemscope="itemscope" itemtype="http://data-vocabulary.org/Person">	

<div class="messageUserBlock  is-expanded ">

	
		<div class="avatarHolder is-expanded">
			<div class="uix_avatarHolderInner">
			<span class="helper"></span>
			<a href="members/jarret-b.29858/" class="avatar Av29858m" data-avatarhtml="true"><img src="data/avatars/m/29/29858.jpg?1495487162" width="96" height="96" alt="Jarret B" /></a>

			
			<!-- slot: message_user_info_avatar -->
			</div>
		</div>
	

	
		<h3 class="userText">
			<div class="uix_userTextInner">

				

				<a href="members/jarret-b.29858/" class="username" dir="auto" itemprop="name">Jarret B</a>
				<em class="userTitle" itemprop="title">Member</em>
			</div>
			
			<!-- slot: message_user_info_text -->
		</h3>
	
	
		<div class="extraUserInfo is-expanded">
			
			
				
					<dl class="pairsJustified">
						<dt>Joined:</dt>
						<dd>May 22, 2017</dd>
					</dl>
				
				
					<dl class="pairsJustified">
						<dt>Messages:</dt>
						<dd><a href="search/member?user_id=29858" class="concealed" rel="nofollow">69</a></dd>
					</dl>
				
				
					<dl class="pairsJustified">
						<dt>Likes Received:</dt>
						<dd>2</dd>
					</dl>
				
				
				
				
				
				

			
			
			
		</div>
	


	<span class="arrow"><span></span></span>
</div>
</div>

		<div class="messageInfo primaryContent">
			

			
			<div class="messageContent">
				<article>
					<blockquote class="messageText SelectQuoteContainer ugc baseHtml">
						
						
						To think of Linux on Windows 10 you may be imagining running it under VirtualBox. Now, you can run Linux on Windows 10 in a Command Shell.<br />
<br />
For now, it is only Ubuntu 14.04 but later Fedora and OpenSUSE should be added.<br />
<br />
First you need to Prepare Windows 10 for the addition of Ubuntu.<br />
<br />
<b>Preparation</b><br />
<br />
Perform an update in Windows to make sure the Operating System is up-to-date. Windows 10 must be a client and not a server version. It must also be the 64-bit and not the 32-bit OS.<br />
<br />
Open the Windows Menu and click on the icon for ‘Settings’. Once the Settings window opens you will need to select ‘Update and Security’. Click on ‘For Developers’ and then select the ‘Developers mode’ radio button. You will be prompted to verify that you want to place Windows in Developer Mode. Select ‘Yes’ from the window to continue. The process may take a little to perform its necessary changes. Once Windows is in Developer Mode you will need to open the Windows Menu again. In the dialogue box type ‘Turn Windows Features on or off’. Click on the option which appears for your search.<br />
<br />
A new window will open which shows the various Windows Features. Check the box for the option ‘Windows Subsystem for Linux’ as shown in Figure 1. After the necessary files are downloaded you will be asked to restart the system. Allow the system to restart and perform the updates it needs to complete the change to Developer Mode and set up the windows Subsystem for Linux.<br />
<br />

	
	<img src="https://www.linux.org/attachments/figure-01-jpg.730/" alt="Figure 01.jpg" class="bbCodeImage LbImage" />
		
 <br />
<b>FIGURE 1</b><br />
<br />
After Windows restarts and you’re logged back into the Operating System you need to open the Windows Menu. In the dialogue box type in ‘cmd’ and open a command shell.<br />
<br />
<b>Installation of Linux</b><br />
<br />
At the time this article was written the Windows Subsystem for Linux is/was a Beta version. Only Ubuntu is available for installation. In the Command Shell type the command ‘bash’. The Linux Subsystem will be downloaded and installed after you affirm the installation by typing ‘y’.<br />
<br />
After the Linux System is installed you will be prompted for a user name and password. The password will be asked for again to confirm the password was typed correctly.<br />
<br />
Once the password has been verified you will be at a Linux prompt as shown in Figure 2.<br />
<br />

	
	<img src="https://www.linux.org/attachments/figure-02-jpg.731/" alt="Figure 02.jpg" class="bbCodeImage LbImage" />
		
 <br />
<b>FIGURE 2</b><br />
<br />
You can now update your system by performing the following commands:<br />
<br />
<i>sudo apt-get update<br />
sudo apt-get -y upgrade</i><br />
<br />
You should now have a fully updated Ubuntu Operating System (OS) on your Windows 10 system.<br />
<br />
<b>Linux Folder Structure</b><br />
<br />
The Linux files are stored on the Windows drive at: ‘%localappdata%/lxss’. You cannot see this protected folder unless you choose to see Hidden files and folders as well as being able to see Protected files. The settings are made in the File Explorer under ‘View’, ‘Options’ and then ‘Change folder and search options’. Select the option to ‘Show hidden files, folders and drives’ as well as uncheck the option for ‘Hide protected operating system files’.<br />
<br />
To see the location of ‘%localappdata’ you can open a Command Prompt and type the command ‘echo %localappdata%’. The output should be something like ‘c:\Users\[username]\appdata\local’. The ‘[username]’ is your Windows username. Each user account can have a separate copy of Linux installed and updated to their wishes.<br />
<br />
Do not make any changes to these folders from Windows. The account settings for these folders are different and any new files added by Windows will have Windows security settings. By making any changes you take the chance of corrupting your Linux install.<br />
<br />
At the current stage it is best to not try to load a desktop environment. Most will fail or produce errors. Some people have been able to get the Graphical User Interface (GUI) to start, but some programs will not run correctly.<br />
<br />
Linux can save files to the folders as well as to mounted drives. For example, you can change the directory to ‘/mnt/c’ and run the command ‘mkdir TEMP’. If you open Windows File Manager you can see the folder ‘TEMP’ in the root of C. Inside Windows you can create a folder inside ‘TEMP’ and call it ‘test.txt’. Place some text in the file using Windows Notepad and save it. After exiting Notepad bring the ‘bash’ window to the front again and change to the folder ‘TEMP’. Once in ‘TEMP’ you can use the command ‘cat test.txt’ and see the text you placed into the file.<br />
<br />
Within the ‘lxss’ folder you can perform all file functions just like on Linux. For example, in the HOME folder under ‘bash’ you can perform the following commands:<br />
<ul>
<li>mkdir Temp</li>
<li>mkdir TEMP</li>
</ul><br />
Now, when you perform an ‘ls’ command you will see two folders with the same name but different case. The files and folders you create will have the permissions of the current Linux user.<br />
<br />
If you open Windows File manager and go to the ‘lxss’ folder and then to ‘HOME’ you will see the two folders ‘Temp’ and ‘TEMP’.<br />
<br />
If you should change to the root of C ‘cd /mnt/c’. Perform the following commands:<br />
<ul>
<li>mkdir Temp</li>
<li>mkdir TEMP</li>
</ul>When you execute the second command you will get an error since the folder already exists. There is no case-sensitivity when outside the Linux file structure. Outside the Linux file structure is ‘/mnt/c/’ and other drives which are controlled by Windows.<br />
<br />
Any files or folders created outside Linux in the Windows file system will have the permissions of the currently logged in Windows user.<br />
<br />
<b>How it works</b><br />
<br />
The Windows Subsystem for Linux (WSL) allows for the 64-bit ELF binaries to be run in the Windows kernel.<br />
<br />
The WSL is made up of two subsystems. The two subsystems are:<br />
<ol>
<li>lxss</li>
<li>lxcore.sys</li>
</ol><br />
These two subsystems manage the Linux virtualization on the Windows NT Kernel.<br />
<br />
The ‘lxss’ manager will control how the ‘bash’ environment invokes the binaries. All user process are placed into a ‘Linux Instance’. The ‘Instance’ tracks the processes, threads and run time states. Once a user enters the command ‘exit’ then the ‘Instance’ is shut down. When the Linux ‘Instance’ is shut down then every process, thread and run time state is also turned off.<br />
<br />
The ‘lxcore.sys’ translates the Linux system calls into compatible Windows system calls. If a compatible call is not found, then the Windows Mode Kernel will manage the system call. Once a translation is made to a compatible system call then the Windows kernel will receive the translated call and perform it.<br />
<br />
Inside the Linux file system, when using Linux System Calls, the driver used is the Windows Virtual File System (VoiFS). VoiFS allows you to perform all file functions on the Windows system just as if you were running Linux. This is proven when you created the folders ‘Temp’ and ‘TEMP’ inside the ‘HOME’ folder.<br />
<br />
If you change the directory to that of a Windows drive (/mnt/c) then you will use the Microsoft Distributed File System (DrvFS).<br />
<br />
<b>Install/Uninstall Linux</b><br />
<br />
If you corrupt Linux, or the WSL, you can easily remove and reinstall it. Once you have performed all the prerequisites from the ‘Preparation’ section, the rest is easy.<br />
<br />
To remove WSL you can run the following command from a command-shell in Windows:<br />
<br />
<i>lxrun /uninstall /full</i><br />
<br />
<b>NOTE:</b> Before removing WSL you may need to make copies of any files you have under Linux that you want to keep.<br />
<br />
Once WSL has been removed you can reinstall it with the command:<br />
<br />
<i>lxrun /install</i><br />
<br />
You can also use the optional parameter ‘/y’ so there are no prompts to accept. The parameter ‘/setdefaultuser’ followed by a user name will automatically create the user. When using ‘setdefaultuser’ you can use the option ‘/y’ so there is no prompt for a password.<br />
<br />
To update the package index the command ‘lxrun /update’ can be used.<br />
<br />
<b>NOTE: </b>You can, of course, run the command ‘bash’ as before.<br />
<br />
lxrun Adding Linux to Windows can allow Windows users to get a taste of Linux. For those of you running Windows 10 you can now have Linux too. Maybe you can get rid of Windows and make the switch.
						<div class="messageTextEndMarker">&nbsp;</div>
					</blockquote>
				</article>

				
			</div>
			

			
			
				
				
				<div class="baseHtml signature messageText ugc">
					<div class="uix_signatureWrapper uix_signatureToggleHover">
						<div class="uix_signatureWrapperInner">
							<aside class="uix_signature">
								I work at home and I have an extremely beautiful wife named Cassandra.  We&#039;ve been married nearly 24 years.  We have four children at home: Eilly, Alyse, Morgan and Grant.<br />
<br />
I had a book come out called <b>EPUB: From the Ground Up</b>.<br />
<br />
Go to Amazon or Barnes and Noble to order a copy.<br />
<br />
<img src="http://img2.imagesbn.com/p/9780071830539_p0_v1_s260x420.JPG" class="bbCodeImage" alt="[&#x200B;IMG]" data-url="http://img2.imagesbn.com/p/9780071830539_p0_v1_s260x420.JPG" /><br />
<br />
You can contact me through <b>Linux.org</b> or at <a href="mailto:jarretbuse@hotmail.com">jarretbuse@hotmail.com</a>.
							</aside>
							

						</div>
						
					</div>
				</div>
				
			

			<div class="messageDetails">

				

		

		<a href="threads/linux-in-windows-10.4571/" title="Permalink" class="item muted postNumber hashPermalink OverlayTrigger" data-href="posts/12702/permalink">#1</a>

		<span class="item muted">
			<span class="authorEnd"><a href="members/jarret-b.29858/" class="username author" dir="auto">Jarret B</a>,</span>
			<a href="threads/linux-in-windows-10.4571/" title="Permalink" class="datePermalink">
			
				<abbr class="DateTime" data-time="1496092381" data-diff="128276" data-datestring="May 29, 2017" data-timestring="10:13 PM">May 29, 2017 at 10:13 PM</abbr>
			
			</a>
		</span>

	

				

			</div>
			


			

		 

	

			<div id="likes-post-12702">
	
	<div class="likesSummary secondaryContent">
		<span class="LikeText">
			<a href="members/mikeyd.29105/" class="username" dir="auto">MikeyD</a> likes this.
		</span>
	</div>
</div>
		</div>

	</div> 

	

	
<div class="underPost" style="padding-top:30px;text-align:center"><div align="center">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Text & Display Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4059641217434021"
     data-ad-slot="6079404386"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></div>
	
</li>
			
		
		
	</ol>

	

	<input type="hidden" name="_xfToken" value="" />

</form>

	<div class="pageNavLinkGroup">
			
				<div class="linkGroup">
					
						
							<a href="login/" class="concealed element OverlayTrigger">(You must log in or sign up to post here.)</a>
						
					
				</div>
			
			<div class="linkGroup" style="display: none"><a href="javascript:" class="muted JsOnly DisplayIgnoredContent Tooltip" title="Show hidden content by ">Show Ignored Content</a></div>

			
	</div>












	



	

	<div class="sharePage">
		<h3 class="textHeading larger">Share This Page</h3>
		
			
			
				<div class="tweet shareControl">
					<a href="https://twitter.com/share" class="twitter-share-button"
						data-count="horizontal"
						data-lang="en-US"
						data-url="https://www.linux.org/threads/linux-in-windows-10.4571/"
						data-text="Linux in Windows 10"
						
						>Tweet</a>
				</div>
			
			
				<div class="plusone shareControl">
					<div class="g-plusone" data-size="medium" data-count="true" data-href="https://www.linux.org/threads/linux-in-windows-10.4571/"></div>
				</div>
			
			
				<div class="facebookLike shareControl">
					
					<div class="fb-like" data-href="https://www.linux.org/threads/linux-in-windows-10.4571/" data-width="400" data-layout="standard" data-action="recommend" data-show-faces="true" data-colorscheme="light"></div>
				</div>
			
			
		
	</div>






	





						

						
							<!-- login form, to be moved to the upper drop-down -->
							







<form action="login/login" method="post" class="xenForm " id="login" style="display:none">

	

	<div class="ctrlWrapper">
		<dl class="ctrlUnit">
			<dt><label for="LoginControl">Your name or email address:</label></dt>
			<dd><input type="text" name="login" id="LoginControl" class="textCtrl" tabindex="101" /></dd>
		</dl>
	
	
		<dl class="ctrlUnit">
			<dt>
				<label for="ctrl_password">Do you already have an account?</label>
			</dt>
			<dd>
				<ul>
					<li><label for="ctrl_not_registered"><input type="radio" name="register" value="1" id="ctrl_not_registered" tabindex="105" />
						No, create an account now.</label></li>
					<li><label for="ctrl_registered"><input type="radio" name="register" value="0" id="ctrl_registered" tabindex="105" checked="checked" class="Disabler" />
						Yes, my password is:</label></li>
					<li id="ctrl_registered_Disabler">
						<input type="password" name="password" class="textCtrl" id="ctrl_password" tabindex="102" />
						<div class="lostPassword"><a href="lost-password/" class="OverlayTrigger OverlayCloser" tabindex="106">Forgot your password?</a></div>
					</li>
				</ul>
			</dd>
		</dl>
	
		
		<dl class="ctrlUnit submitUnit">
			<dt></dt>
			<dd>
				<input type="submit" class="button primary" value="Log in" tabindex="104" data-loginPhrase="Log in" data-signupPhrase="Sign up" />
				<label for="ctrl_remember" class="rememberPassword"><input type="checkbox" name="remember" value="1" id="ctrl_remember" tabindex="103" /> Stay logged in</label>
			</dd>
		</dl>
	</div>

	<input type="hidden" name="cookie_check" value="1" />
	<input type="hidden" name="redirect" value="/threads/linux-in-windows-10.4571/" />
	<input type="hidden" name="_xfToken" value="" />

</form>
						
					</div>
			

					</div>

					<!-- sidebar -->
					<aside class="uix_mainSidebar">
						<div class="inner_wrapper">
							<div class="sidebar">
								
								

	<div class="section funbox">
		<div class=" funboxWrapper">
		

			
				
					


					

<a href="https://m.do.co/c/10b82948a627"><i class="fa fa-server" aria-hidden="true"></i> <b>$10 Credit with DigitalOcean!</b> <i class="fa fa-server" aria-hidden="true"></i></a>
<br /><br />

<a target="_blank" href="https://www.linuxforum.com"><b>LinuxForum.com domain is for sale</b></a><br /><br />
				
			
			

		
		</div>
	</div>


								

<div class="section loginButton">
	<div class="secondaryContent">
		<label id="SignupButton"><a href="login/" class="inner OverlayTrigger" data-cacheOverlay="false">Sign up now!</a></label>
	</div>
</div>







	<div class="section funbox">
	<div class=" funboxWrapper">
	

		
			
				



				

<div align="center">
<iframe data-aa='528747' src='//ad.a-ads.com/528747?size=200x90' scrolling='no' style='width:200px; height:90px; border:0px; padding:0;overflow:hidden' allowtransparency='true'></iframe>
<br />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive Text & Display Ad -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-4059641217434021"
     data-ad-slot="6079404386"
     data-ad-format="rectangle"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

			
		

	
	</div>
	</div>


								<div class="section">
		<div class="secondaryContent widget WidgetFramework_WidgetRenderer_Poll" id="widget-13">
			<h3><a href="threads/poll-favorite-text-editor.6/">Favorite Text Editor</a></h3>

			



<div id="PollContainer" class="NoAutoHeader PollContainer widget-poll">
	<form action="threads/poll-favorite-text-editor.6/poll/vote" method="post" class="pollBlock AutoValidator PollVoteForm"
		data-container="#PollContainer" data-max-votes="1">

		<div class="pollContent">
			
					
						


<div class="overlayScroll pollResultsOverlay">

	<ol class="pollResults noResults">
	
		<li class="pollResult ">
			
				<div class="votedIconCell"></div>
			
			<h3 class="optionText" >
				vi/vim
			</h3>

			<div class="count" class="Tooltip" title="48.2%">
				
					54 vote(s)
				
			</div>
		</li>
	
		<li class="pollResult ">
			
				<div class="votedIconCell"></div>
			
			<h3 class="optionText" >
				emacs
			</h3>

			<div class="count" class="Tooltip" title="8.9%">
				
					10 vote(s)
				
			</div>
		</li>
	
		<li class="pollResult ">
			
				<div class="votedIconCell"></div>
			
			<h3 class="optionText" >
				nano
			</h3>

			<div class="count" class="Tooltip" title="16.1%">
				
					18 vote(s)
				
			</div>
		</li>
	
		<li class="pollResult ">
			
				<div class="votedIconCell"></div>
			
			<h3 class="optionText" >
				pico
			</h3>

			<div class="count" class="Tooltip" title="7.1%">
				
					8 vote(s)
				
			</div>
		</li>
	
		<li class="pollResult ">
			
				<div class="votedIconCell"></div>
			
			<h3 class="optionText" >
				other
			</h3>

			<div class="count" class="Tooltip" title="19.6%">
				
					22 vote(s)
				
			</div>
		</li>
	
	</ol>
</div>
					
				
		</div>

		<input type="hidden" name="_xfToken" value="" />
		<input type="hidden" name="_fromWidget" value="1" />
	</form>
</div>
		</div>
	</div><div class="section BRMIcontainer">
		<div class="secondaryContent brmiMailchimpForm">
			<h3>Newsletter</h3>
			<div class="innerContent"></div>
		</div>
	</div>
								
								
							</div>
						</div>
					</aside>
				</div>
			

			
			
				<div class="breadBoxBottom">

<nav>

	

	

	<fieldset class="breadcrumb">
		<a href="misc/quick-navigation-menu?selected=node-134" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i><!--Jump to...--></a>

		<div class="boardTitle"><strong>Linux.org</strong></div>

		<span class="crumbs">
			
				<span class="crust homeCrumb">
					<a href="https://www.linux.org/" class="crumb"><span><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
					<span class="arrow"><span></span></span>
				</span>
			

			
				<span class="crust selectedTabCrumb">
					<a href="https://www.linux.org/forums/" class="crumb"><span>Forums</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
			

			
				
					<span class="crust">
						<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="crumb"><span>Linux Articles and Tutorials</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
					<span class="crust">
						<a href="https://www.linux.org/forums/linux-org-articles.134/" class="crumb"><span>Linux.org Articles</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
			
		</span>
	</fieldset>
</nav></div>
			
			

			

			</div>
	
		</div>
	</div>
	

</div>

<footer>
	










<div class="footer">
	<div class="pageWidth">
		<div class="pageContent">
			

				
				
					<dl class="choosers chooser_widthToggle">
						<dt>Toggle Width</dt>
						<dd><a href="javascript: uix.toggleWidth.toggle()" class='Tooltip' title="Toggle Width" rel="nofollow"><span class="uix_icon js-widthIcon uix_icon-compressWidth"></span></a></dd>
					</dl>
				
				
				
				
				<ul class="footerLinks">
					
						<li><a href="https://www.linux.org/" class="homeLink">Home</a></li>
						
							<li><a href="misc/contact" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}">Contact Us</a></li>
						
						<li><a href="help/">Help</a></li>
					
					
						<li><a href="help/terms">Terms and Rules</a></li>
						
					
					<li class="topLink"><a href="/threads/linux-in-windows-10.4571/#XenForo"><i class="uix_icon uix_icon-jumpToTop"></i> <span class="uix_hide">Top</span></a></li>
				</ul>
				

			

			<span class="helper"></span>

			
		</div>
	</div>
</div>

<div id="uix_stickyFooterSpacer"></div>






	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	







<div class="bigFooter">
	<div class="pageWidth">
		<div class="pageContent">
			

			


			<ul class="bigFooterRow bigFooterRow--mainRow bigFooterRow--has4Columns">
				<li class="bigFooterCol bigFooterCol--col1">
					<div class="section">

						
							<h3 class="bigFooterHeader">
								<i class="uix_icon fa fa-caret-square-o-right"></i>
								About Us
							</h3>

							Linux.org is a friendly community where you won't be berated for asking questions.
<br /><br />
We're all here to learn and help solve Linux issues.  Some of us novice, others experts.
<br /><br />
Sign up and let us know what you're working on!
						

					</div>
				</li>
				<li class="bigFooterCol bigFooterCol--col2">
					<div class="section">

						
							<h3 class="bigFooterHeader">
								<i class="uix_icon fa fa-caret-square-o-right"></i>
								Quick Navigation
							</h3>

							<ul class="footerMenu">
        <li><a href="/">Home</a></li>
        <li><a href="/">Forums</a></li>
        <li><a href="/pages/download/">Downloads</a></li>
        <li><a href="/misc/contact">Contact</a></li>
        </ul>
        <p>Open the <a href="misc/quick-navigation-menu" class="OverlayTrigger jumpMenuTrigger" data-cacheoverlay="true" title="Open quick navigation">Quick Navigation</a></p>
						

					</div>
				</li>
				<li class="bigFooterCol bigFooterCol--col3">
					<div class="section">

						
							<h3 class="bigFooterHeader">
								<i class="uix_icon fa fa-facebook-square"></i>
								Like us on Facebook
							</h3>

							<div id="fb-root"></div>
        <script>(function(d, s, id) {
        var js, fjs = d.getElementsByTagName(s)[0];
        if (d.getElementById(id)) return;
        js = d.createElement(s); js.id = id;
        js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=235988599753831";
        fjs.parentNode.insertBefore(js, fjs);
        }(document, 'script', 'facebook-jssdk'));</script>
        <div class="fb-page" data-href="https://www.facebook.com/TheLinuxForum/" data-tabs="timeline" data-height="260" data-small-header="true" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/TheLinuxForum/"><a href="https://www.facebook.com/TheLinuxForum/">Linux.org</a></blockquote></div></div>
						

					</div>
				</li>
				<li class="bigFooterCol bigFooterCol--col4">
					<div class="section">

						
							<h3 class="bigFooterHeader">
								<i class="uix_icon fa fa-users"></i>
								Membership Upgrade
							</h3>

							The management works very hard to make sure the community is running the best software, best designs, and all the other bells and whistles. Support the site by purchasing a membership upgrade.  We'd really appreciate it!
        <br><br>
        <a class="callToAction" href="/account/upgrades"><span>More Information</span></a>
						

					</div>
				</li>
			</ul>

			

		</div>
	</div>
</div>




<div class="footerLegal">
	<div class="pageWidth">
		<div class="pageContent">
			
			
				<ul class="uix_socialMediaLinks">
	<li class="uix_socialLink uix_socialLink--facebook"><a href="https://www.facebook.com/TheLinuxForum/" target="_blank"><i class="uix_icon uix_icon-facebook"></i></a></li>

        

        

        

        

        

        

        

        

        

        

        

        

        

        

        

        

	
	
	    <li class="uix_socialLink uix_socialLink--contact"><a href="misc/contact" class="OverlayTrigger" data-overlayOptions="{&quot;fixed&quot;:false}"><i class="uix_icon uix_icon-email"></i></a></li>
	
	

        



<!--ADD LIST ITEMS HERE -->



        <li class="uix_socialLink uix_socialLink--rss"><a href="forums/-/index.rss" rel="alternate}" target="_blank"><i class="uix_icon uix_icon-rss"></i></a></li>
</ul>
			
			<div id="copyright"><div><a href="https://marketplace.digitalpoint.com/digital-point-ad-positioning.989/item" target="_blank">Advertising Positioning</a> by <a href="https://www.digitalpoint.com/" target="_blank">Digital Point</a></div>
				<a href="https://xenforo.com" class="concealed">Forum software by XenForo&trade; <span>&copy;2010-2017 XenForo Ltd.</span></a> 
				<div class="thCopyrightNoticeStyle">Theme designed by <a href="https://www.themehouse.com/xenforo/themes" title="Premium XenForo Themes" rel="nofollow" target="_blank">ThemeHouse</a>.</div>
				
			</div>
			<div id="BRCopyright" class="concealed muted" style="float:left;margin-left: 10px;"><style>@media (max-width:480px){.Responsive #BRCopyright span{display: none;}}</style><div class="muted"><a href="http://brivium.com/" class="concealed" title="Brivium Limited"><span>XenForo </span>Add-ons by Brivium<span> &trade;  &copy; 2012-2017 Brivium LLC.</span></a></div></div>
			<span class="helper"></span>
			
		</div>
	</div>
</div>



	<div id="uix_jumpToFixed">
		
			<a href="#XenForo" title="Top" data-position="top"><i class="uix_icon uix_icon-jumpToTop"></i></a>
		
		
			<a href="#XenForo" title="Bottom" data-position="bottom"><i class="uix_icon uix_icon-jumpToBottom"></i></a>
		
	</div>

</footer>

<script>


jQuery.extend(true, XenForo,
{
	visitor: { user_id: 0 },
	serverTimeInfo:
	{
		now: 1496220657,
		today: 1496185200,
		todayDow: 3
	},
	_lightBoxUniversal: "0",
	_enableOverlays: "1",
	_animationSpeedMultiplier: "0.5",
	_overlayConfig:
	{
		top: "10%",
		speed: 100,
		closeSpeed: 50,
		mask:
		{
			color: "rgb(255, 255, 255)",
			opacity: "0.6",
			loadSpeed: 100,
			closeSpeed: 50
		}
	},
	_ignoredUsers: [],
	_loadedScripts: {"EWRporta2_Global":true,"thread_view":true,"message":true,"bb_code":true,"message_user_info":true,"likes_summary":true,"share_page":true,"wf_default":true,"polls":true,"BRMI_forum_list_sidebar":true,"login_bar":true,"moderator_bar":true,"uix_welcomeBlock":true,"notices":true,"uix_extendedFooter":true,"js\/xenforo\/discussion.js?_v=4cc2e9c1":true,"js\/brivium\/MailchimpIntegrate\/newsletter.js?_v=4cc2e9c1":true},
	_cookieConfig: { path: "/", domain: "", prefix: "xf_"},
	_csrfToken: "",
	_csrfRefreshUrl: "login/csrf-token-refresh",
	_jsVersion: "4cc2e9c1",
	_noRtnProtect: false,
	_noSocialLogin: false
});
jQuery.extend(XenForo.phrases,
{
	cancel: "Cancel",

	a_moment_ago:    "A moment ago",
	one_minute_ago:  "1 minute ago",
	x_minutes_ago:   "%minutes% minutes ago",
	today_at_x:      "Today at %time%",
	yesterday_at_x:  "Yesterday at %time%",
	day_x_at_time_y: "%day% at %time%",

	day0: "Sunday",
	day1: "Monday",
	day2: "Tuesday",
	day3: "Wednesday",
	day4: "Thursday",
	day5: "Friday",
	day6: "Saturday",

	_months: "January,February,March,April,May,June,July,August,September,October,November,December",
	_daysShort: "Sun,Mon,Tue,Wed,Thu,Fri,Sat",

	following_error_occurred: "The following error occurred",
	server_did_not_respond_in_time_try_again: "The server did not respond in time. Please try again.",
	logging_in: "Logging in",
	click_image_show_full_size_version: "Click this image to show the full-size version.",
	show_hidden_content_by_x: "Show hidden content by {names}"
});

// Facebook Javascript SDK
XenForo.Facebook.appId = "";
XenForo.Facebook.forceInit = true;


</script>







</div> 

<div class="uix_wrapperFix" style="height: 1px; margin-top: -1px;"></div>


		</div> 
	</div> 

	


<script>

</script>

<div class="breadcrumbMeta">
	

<nav>

	

	

	<fieldset class="breadcrumb">
		<a href="misc/quick-navigation-menu?selected=node-134" class="OverlayTrigger jumpMenuTrigger" data-cacheOverlay="true" title="Open quick navigation"><i class="uix_icon uix_icon-sitemap"></i><!--Jump to...--></a>

		<div class="boardTitle"><strong>Linux.org</strong></div>

		<span class="crumbs">
			
				<span class="crust homeCrumb">
					<a href="https://www.linux.org/" class="crumb"><span><i class="uix_icon uix_icon-home" title="Home"></i><span class="uix_breadcrumb__home__title">Home</span></span></a>
					<span class="arrow"><span></span></span>
				</span>
			

			
				<span class="crust selectedTabCrumb">
					<a href="https://www.linux.org/forums/" class="crumb"><span>Forums</span></a>
					<span class="arrow"><span>&gt;</span></span>
				</span>
			

			
				
					<span class="crust">
						<a href="https://www.linux.org/forums/#linux-articles-and-tutorials.122" class="crumb"><span>Linux Articles and Tutorials</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
					<span class="crust">
						<a href="https://www.linux.org/forums/linux-org-articles.134/" class="crumb"><span>Linux.org Articles</span></a>
						<span class="arrow"><span>&gt;</span></span>
					</span>
				
			
		</span>
	</fieldset>
</nav>
</div>

<!-- UI.X Version: 1.5.13.0 //-->

</body>
</html>