Linux Headers messing up?

InvaderSumo

Member
Joined
Apr 25, 2024
Messages
129
Reaction score
15
Credits
1,411
been trying to install things and keep getting dpkg errors.. this is the error

does anybody know how to fix this?

sudo apt install --fix-broken
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
4 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up linux-image-6.1.0-21-amd64 (6.1.90-1) ...
/etc/kernel/postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-21-amd64.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
make -j2 KERNELRELEASE=6.1.0-21-amd64 all KERNEL_SRC=/lib/modules/6.1.0-21-amd64
/build...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-21-amd64 (x86_64)
Consult /var/lib/dkms/anbox-ashmem/1/build/make.log for more information.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
make -j2 KERNELRELEASE=6.1.0-21-amd64 all KERNEL_SRC=/lib/modules/6.1.0-21-amd64
/build...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-21-amd64 (x86_64)
Consult /var/lib/dkms/anbox-binder/1/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-21-amd64 failed!
run-parts: /etc/kernel/postinst.d/dkms exited with return code 11
dpkg: error processing package linux-image-6.1.0-21-amd64 (--configure):
installed linux-image-6.1.0-21-amd64 package post-installation script subproces
s returned error exit status 1
dpkg: dependency problems prevent configuration of linux-image-amd64:
linux-image-amd64 depends on linux-image-6.1.0-21-amd64 (= 6.1.90-1); however:
Package linux-image-6.1.0-21-amd64 is not configured yet.

dpkg: error processing package linux-image-amd64 (--configure):
dependency problems - leaving unconfigured
Setting up linux-headers-6.1.0-21-amd64 (6.1.90-1) ...
/etc/kernel/header_postinst.d/dkms:
dkms: running auto installation service for kernel 6.1.0-21-amd64.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
make -j2 KERNELRELEASE=6.1.0-21-amd64 all KERNEL_SRC=/lib/modules/6.1.0-21-amd64
/build...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-21-amd64 (x86_64)
Consult /var/lib/dkms/anbox-ashmem/1/build/make.log for more information.
Sign command: /usr/lib/linux-kbuild-6.1/scripts/sign-file
Signing key: /var/lib/dkms/mok.key
Public certificate (MOK): /var/lib/dkms/mok.pub

Building module:
Cleaning build area...
make -j2 KERNELRELEASE=6.1.0-21-amd64 all KERNEL_SRC=/lib/modules/6.1.0-21-amd64
/build...(bad exit status: 2)
Error! Bad return status for module build on kernel: 6.1.0-21-amd64 (x86_64)
Consult /var/lib/dkms/anbox-binder/1/build/make.log for more information.
Error! One or more modules failed to install during autoinstall.
Refer to previous errors for more information.
dkms: autoinstall for kernel: 6.1.0-21-amd64 failed!
run-parts: /etc/kernel/header_postinst.d/dkms exited with return code 11
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-head
ers-6.1.0-21-amd64.postinst line 11.
dpkg: error processing package linux-headers-6.1.0-21-amd64 (--configure):
installed linux-headers-6.1.0-21-amd64 package post-installation script subproc
ess returned error exit status 1
dpkg: dependency problems prevent configuration of linux-headers-amd64:
linux-headers-amd64 depends on linux-headers-6.1.0-21-amd64 (= 6.1.90-1); howev
er:
Package linux-headers-6.1.0-21-amd64 is not configured yet.

dpkg: error processing package linux-headers-amd64 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
linux-image-6.1.0-21-amd64
linux-image-amd64
linux-headers-6.1.0-21-amd64
linux-headers-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
 

Members online

No members online now.

Top