Linux CLI Command issue

Joined
Mar 26, 2021
Messages
81
Reaction score
41
Credits
863
Linux CLI Command issue
I am being prevent from upgrading my system OS on the Host Linux Laptop and all commands to resolve the issue seem to not work, please help.
I have tried all commands found online such as; apt remove, apt autoremove, apt-get update, apt update, clear, purge, install, fix, -f etc and many many more but still i dont seem to be able to resolve this issue.

I have provided the CLI Output as below for easy read incase anyone knows how to resolve please;
-------------------------------------------------------
root@mint:/home/admin# apt update
Hit:1 http://archive.canonical.com/ubuntu focal InRelease
Hit:2 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:3 https://brave-browser-apt-release.s3.brave.com stable InRelease
Hit:4 https://deb.tmiland.com/debian ./ InRelease
Hit:5 http://archive.ubuntu.com/ubuntu focal InRelease
Ign:6 http://packages.linuxmint.com una InRelease
Get:7 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Hit:8 http://packages.linuxmint.com una Release
Hit:9 http://archive.ubuntu.com/ubuntu focal-backports InRelease
Get:11 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [2,981 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/main i386 Packages [912 kB]
Fetched 4,007 kB in 4s (953 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done

1 package can be upgraded. Run 'apt list --upgradable' to see it.
root@mint:/home/admin# apt list --upgradable
Listing... Done
dpkg/unknown 1.20.12 amd64 [upgradable from: 1.19.7ubuntu3.2]
N: There are 2 additional versions. Please use the '-a' switch to see them.
root@mint:/home/admin# apt list --upgradable -a
Listing... Done
dpkg/unknown 1.20.12 amd64 [upgradable from: 1.19.7ubuntu3.2]
dpkg/focal-updates,focal-security,now 1.19.7ubuntu3.2 amd64 [installed,upgradable to: 1.20.12]
dpkg/focal 1.19.7ubuntu3 amd64

root@mint:/home/admin# apt install dpkg
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
dpkg : PreDepends: libc6 (>= 2.34) but 2.31-0ubuntu9.12 is to be installed
PreDepends: libselinux1 (>= 3.1~) but 3.0-1build2 is to be installed
PreDepends: libzstd1 (>= 1.5.2) but 1.4.4+dfsg-3ubuntu0.1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@mint:/home/admin#
---------------------------------------
Host OS is Mint 20 im on a Linux Machine running coreboot
 
Last edited:


which distribution are you using?
 
For mint, I usually use
sudo apt update && sudo apt upgrade [or you could run them separately sudo apt update, enter, and when finished sudo apt upgrade, enter] followed by Sudo apt autoremove
 
For mint, I usually use
sudo apt update && sudo apt upgrade [or you could run them separately sudo apt update, enter, and when finished sudo apt upgrade, enter] followed by Sudo apt autoremove
did all of that many many many times yet to no avail
 
I dont understand, what did i forget to add to post pls?
When I first read the post you hadn't added your terminal output yet, I was commenting about that.
 
i got
When I first read the post you hadn't added your terminal output yet, I was commenting about that.
ya got u now, i think this website is slow as i edited it within a few seconds, or u r very quick or a bit of both, much appreciated anyways, thanx
 
The following packages have unmet dependencies.
dpkg : PreDepends: libc6 (>= 2.34) but 2.31-0ubuntu9.12 is to be installed
PreDepends: libselinux1 (>= 3.1~) but 3.0-1build2 is to be installed
PreDepends: libzstd1 (>= 1.5.2) but 1.4.4+dfsg-3ubuntu0.1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@mint:/home/admin#
Something looks off with your installation, I just installed Linux Mint 20 in a vm and for those listed dependencies I get the following versions.
tux@mint:~$ grep -i version /etc/os-release | head -n1
VERSION="20 (Ulyana)"
tux@mint:~$ dpkg --list | egrep "libselinux1|libzstd1|libc6:amd64"
ii libc6:amd64 2.31-0ubuntu9.12 amd64 GNU C Library: Shared libraries
ii libselinux1:amd64 3.0-1build2 amd64 SELinux runtime shared libraries
ii libzstd1:amd64 1.4.4+dfsg-3ubuntu0.1 amd64 fast lossless compression algorithm
And according to your output your system is trying to install higher versions of those dependencies. Did you recently try running an upgrade to a higher version of Linux Mint?
 
Last edited:
I upgraded that same vm to 20.3 and I still have the same versions.
tux@mint:~$ grep -i version /etc/os-release | head -n1
VERSION="20.3 (Una)"
tux@mint:~$ dpkg --list | egrep "libselinux1|libzstd1|libc6:amd64"
ii libc6:amd64 2.31-0ubuntu9.12 amd64 GNU C Library: Shared libraries
ii libselinux1:amd64 3.0-1build2 amd64 SELinux runtime shared libraries
ii libzstd1:amd64 1.4.4+dfsg-3ubuntu0.1 amd64 fast lossless compression algorithm
So that would make me think you have added a source to your system that makes your package manager finder higher package versions and libraries than what the Mint repos provide. Can you share your source files under /etc/apt/sources.list.d?
 
Yes, that smells like a PPA or a testing stream has been added to the sources. However the system doesn't seem to be broken; removing the problematic repository may be the way to solve this.
 

Staff online

Members online


Latest posts

Top