LetsEncrypt says "DNS validation failed". Site is behind Cloudflare


Jul 8, 2017
Reaction score
Hello, i tried to disable FULL SSL option in my cloudflare account to become "Off" and then attempt to setup wildcard free LetsEncrypt certificate from within DirectAdmin control panel. But it continue to fail. "DNS validation failed"
I would rather think it is problem related to Cloudflare. Maybe i have to "Pause" cloudflare for that domain entirely and retry?

This issue is interesting because also the Gmail is unable to connect mail.mydomain.com using SSL even the "Full SSL" is enabled in Cloudflare account (so i would expect *.mydomain.com (including mail.) would use the cert. too..

i've had that - i couldn't be bothered to understand why but by simple trial and error of clicking unclicking options as you say email . mine worked .From memory the domains i had a problen with were the ones where via cpanel i had set up email via webmail. i had choice of 2 validation http-01 or dns-1 dns gave me trouble http worked. i left wildcards out and didn't find any lose in that
Last edited:
Thanks @captain-sensible , that helped. So i tried to select only main domain, www and mail to be SSL protected instead of a wildcard and then it used "https://acme-v02.api.letsencrypt.org" and succeeded and Gmail can now get mail via SSL.

Yet if someone else have feedback or some solutions to do wildcard SSL, it is welcome.

Members online