Lenovo ThinkPad T590: Crackling microphone in Arch Linux

AKM123

New Member
Joined
May 14, 2022
Messages
9
Reaction score
0
Credits
86
I need to be able to use Zoom for business, and I've managed to turn on my microphone by installing alsa-utils as instructed by this YouTube video; however, the sound is crackling, no matter what the volume I set for my microphone is. I tried following the instructions on the ArchWiki, including adding
Code:
options snd-hda-intel model=MODEL position_fix=3
to my
Code:
/etc/modprobe.d/modprobe.conf
file (which was empty btw, something which gave me a pause), and yet I still have a crackling playback whenever I run:
Code:
arecord --duration=5 --format=dat test-mic.wav
aplay test-mic.wav
as suggested by the ArchWiki. I know my microphone is undamaged physically because I had no issues with it using Debian 11 before I switched a couple weeks or so ago. Other than my microphone, I'm having no evident technical issues at this point with my Arch install.
 


D

Deleted member 140690

Guest
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
4,638
Reaction score
3,341
Credits
33,667
The other option would be to try to use Pipewire instead of Pulseadio.
 
OP
A

AKM123

New Member
Joined
May 14, 2022
Messages
9
Reaction score
0
Credits
86
Thanks for the help! I did this and it seems to have worked. I'll mark this thread solved.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Latest posts

Top