Solved Laptop keeps freezing

Solved issue

dormutonton

New Member
Joined
Apr 29, 2023
Messages
10
Reaction score
5
Credits
92
A problem is that laptop keeps freezing. Usually it happens when the google chrome (or brave or firefox) browser is opened and I don't do anything (I am not touching the laptop).
It has never happened while I was using the laptop (typing or using touchpad).
By freezing I mean it stops responding. The screen is working and it shows the last image before it freezed, but I can't interact with the system. The only option I have is to turn it off by holding power button for 10 secs.

I have been using linux for about 5 days now and this problem only appeared yesterday (or at least I don't remember it happening). But I didn't do any changes to the system that day, apart from adding a git repository and formatting a flash drive, which probably don't cause such problems.

Also, after typing "journalctl | grep 'error', I found that this is the last error that I get before a freeze:
kernel: pcieport 0000:00:1d.4: DPC: error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
kernel: EXT4-fs (nvme0n1p4): re-mounted. Opts: errors=remount-ro. Quota mode: none.

I found out that this same error occured about the time I installed the system, so probably it's not the issue?


I have attached a document with the output from 'lshw' command and here is information about my system:
Linux dormu 5.15.0-71-generic #78-Ubuntu SMP Tue Apr 18 09:00:29 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux

And also I have a dual boot with Windows 11 and Linux Mint

Thanks
 

Attachments

  • lshw.html
    97.4 KB · Views: 197
Last edited:


These matters can be hardware or software.

Since the machine is multiple booting, if the freeze happens on all the installations, then you are likely looking at a hardware issue. If it only happens when using the google chrome browser, then try using another browser. There are plenty to select from both chromium types like brave, and firefox types like firefox, firefox-esr or librewolf.

It appears from the description that the display is freezing. It's worth checking that all the microcode and firmware is installed for the intel chips and the i915 driver which is shown as the graphics driver in the lshw output. Run:
Code:
dmesg | grep -i microcode
dmesg | grep -i firmware
to see if the kernel detects any deficits. If there are, install them.

The i915 has firmware in the package: firmware-misc-nonfree. That is the package's name in debian which may be different in Ubuntu. Install the relevant package to get all the relevant firmware if it's not already installed.

There's a bug in the Linux 5.15.0-71-generic kernel on the machine: https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/2017990, but the bug is not describing the problem mentioned in your description. Consider upgrading the kernel anyway.

The above is just what I'd look to at first. If none of that works, there are other things that can be looked at.
 
It could be caused by graphics acceleration, you might try turning off use acceleration in the browser settings
 
These matters can be hardware or software.

Since the machine is multiple booting, if the freeze happens on all the installations, then you are likely looking at a hardware issue. If it only happens when using the google chrome browser, then try using another browser. There are plenty to select from both chromium types like brave, and firefox types like firefox, firefox-esr or librewolf.

It appears from the description that the display is freezing. It's worth checking that all the microcode and firmware is installed for the intel chips and the i915 driver which is shown as the graphics driver in the lshw output. Run:
Code:
dmesg | grep -i microcode
dmesg | grep -i firmware
to see if the kernel detects any deficits. If there are, install them.

The i915 has firmware in the package: firmware-misc-nonfree. That is the package's name in debian which may be different in Ubuntu. Install the relevant package to get all the relevant firmware if it's not already installed.

There's a bug in the Linux 5.15.0-71-generic kernel on the machine: https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/2017990, but the bug is not describing the problem mentioned in your description. Consider upgrading the kernel anyway.

The above is just what I'd look to at first. If none of that works, there are other things that can be looked at.
I installed brave and it freezed in two minutes.
For the code you recommended, this:
Code:
dmesg | grep -i microcode
[    0.000000] microcode: microcode updated early to revision 0xf4, date = 2022-07-31
[    0.093950] SRBDS: Mitigation: Microcode
[    0.817759] microcode: sig=0x806ec, pf=0x4, revision=0xf4
[    0.817939] microcode: Microcode Update Driver: v2.2.
dmesg | grep -i firmware
[    0.142109] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.299110] ACPI: thermal: [Firmware Bug]: No valid trip found
[    1.406312] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    4.833014] iwlwifi 0000:00:14.3: loaded firmware version 66.f1c864e0.0 QuZ-a0-hr-b0-66.ucode op_mode iwlmvm
[    5.053505] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    5.055327] Bluetooth: hci0: Found device firmware: intel/ibt-19-0-4.sfi
[    6.793175] Bluetooth: hci0: Waiting for firmware download to complete
[    6.793474] Bluetooth: hci0: Firmware loaded in 1697407 usecs
[    6.813557] Bluetooth: hci0: Firmware revision 0.4 build 126 week 5 2022

I guess except for two [Firmware Bug]s there are no problems. And there are no deficits.

As for firmware-misc-nonfree, I could download it by adding 'deb http://ftp.de.debian.org/debian stretch main non-free' to '/etc/apt/sources.list' ,I think. I'm not sure whether it would work though.

Thanks for your help
 
Firmware and microcode look fine. For firmware-misc-nonfree there should be an ubuntu equivalent, so you needn't mix up repos with debian. That's not advised. The kernel isn't complaining.

How did you find the suggestion of KGIII described at linux-tips?

If there's no improvement I guess the next thing I would try is to upgrade the kernel.

If you are still at a loss, it may be worth booting linux to a text prompt rather than the GUI and see if it freezes in text mode. If it doesn't freeze in text mode, then you are probably seeing a problem with the graphics card, which amounts to driver problems. To get to text mode, hit e at the grub menu, navigate down to the linux line with the arrow keys, add 3 after a space and hit cntl+x to boot. It only applies to that boot.

If text mode doesn't freeze, you could try and add the kernel option: nomodeset, on the kernel line and see whether that avoids the freeze. It will likely reduce the resolution on screen. That may or may not be tolerable, but if the freeze disappears using nomodeset, then it implicates the graphics drivers.

On the i915 firmware, despite there showing to be no deficits, I suspect that the ubuntu installation doesn't have the latest i915 firmware, the latest of which is at: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915, updated on 2023-05-02. If your system doesn't have the latest it's worth considering downloading all the latest files from kernel.org and placing them into /lib/firmware/i915. Back up your current i915 directory before doing that so that you can reverse the state if there's no effect.
 
Last edited:
Firmware and microcode look fine. For firmware-misc-nonfree there should be an ubuntu equivalent, so you needn't mix up repos with debian. That's not advised. The kernel isn't complaining.

How did you find the suggestion of KGIII described at linux-tips?

If there's no improvement I guess the next thing I would try is to upgrade the kernel.

If you are still at a loss, it may be worth booting linux to a text prompt rather than the GUI and see if it freezes in text mode. If it doesn't freeze in text mode, then you are probably seeing a problem with the graphics card, which amounts to driver problems. To get to text mode, hit e at the grub menu, navigate down to the linux line with the arrow keys, add 3 after a space and hit cntl+x to boot. It only applies to that boot.

If text mode doesn't freeze, you could try and add the kernel option: nomodeset, on the kernel line and see whether that avoids the freeze. It will likely reduce the resolution on screen. That may or may not be tolerable, but if the freeze disappears using nomodeset, then it implicates the graphics drivers.

On the i915 firmware, despite there showing to be no deficits, I suspect that the ubuntu installation doesn't have the latest i915 firmware, the latest of which is at: https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/i915, updated on 2023-05-02. If your system doesn't have the latest it's worth considering downloading all the latest files from kernel.org and placing them into /lib/modules/firmware/i915. Back up your current i915 directory before doing that so that you can reverse the state if there's no effect.
I tried to find an ubuntu equivalent of firmware-misc-nonfree, but couldn't. Except for something similar - linux-firmware, which was already installed.

I tried disabling hardware acceleration but chrome freezed again.

Just upgraded the kernel and waiting for the result.

A little problem is that I don't know what triggers a freeze. For example, I waited almost two days after disabling hardware acceleration for it to freeze again. So booting linux to a text prompt probably is a good idea but can be very time-consuming. I might try it out if nothing else helps.


I will probably try to update the i915 firmware if updating the kernel doesn't help.
Although it seems I don't have /lib/modules/firmware directory:
Code:
ls /lib/modules
5.15.0-56-generic  5.15.0-71-generic  5.19.0-41-generic
I suppose those are the versions of kernels that were installed previously.
 
I tried to find an ubuntu equivalent of firmware-misc-nonfree, but couldn't.

I don't know as that'll help, but that's possible and trivial in Ubuntu:


(You'll need the 'Restricted' repo available, so I just gave you the link as I don't know what you've got configured.)
 
I don't know as that'll help, but that's possible and trivial in Ubuntu:


(You'll need the 'Restricted' repo available, so I just gave you the link as I don't know what you've got configured.)
I did what was written in the tutorial, but still can't find this package (If that was the goal of adding restricted repo)
Also, for the last command in the guide:
Code:
sudo ubuntu-drivers autoinstall
All the available drivers are already installed.
 
All the available drivers are already installed.

That's what I expected. It was more a matter of answering your question AND just making sure all the bases have been covered. I don't want to say it's a hardware problem. I don't have enough reasons to think that.

There's the text mode and wait for it to reboot thing. You can also go through the logs, which I seem to recall you've already done.

I have a dumb question... Above, you tried Brave. Brave is based on Chromium (as is Chrome).

Have you actually tried Firefox or a Firefox-related browser, like Pale Moon or LibreWold - or just plain ol' Firefox?
 
Have you actually tried Firefox or a Firefox-related browser, like Pale Moon or LibreWold - or just plain ol' Firefox?
Well, I did launch it a few times, but never stayed in it long enough for it to freeze. As I said before, I don't really know what triggers these freezes, so I can only wait until one occurs. Really wanted to stay on chromium-based browser.
But even more I wouldn't like to boot from text mode, so I guess I have to try Firefox first.
 
dormutonton wrote:
I wouldn't like to boot from text mode
To clarify post #6, you wouldn't have to boot from text mode. The suggestion was to boot into text mode and leave the computer on to see if it freezes in text mode. You could play around with it in text mode while waiting for time to elapse to see if it freezes. Run some commands which if you aren't familiar with you can find online, or ask here. It was a way of testing whether the graphics card was likely to be part of the issue. The means of getting into text mode was described, but it will only boot into text for that boot. The adjustment to the linux line doesn't persist, so that the next boot up would boot your machine in the normal way it does for you. It's the same single occurrence if you tried to use the kernel option, nomodeset. It only lasts for that boot. To make these changes permanent you would have to do more things that don't seem to be relevant at the moment.
 
I hear you... I'm not a fan of current Firefox. Or, I'm too invested in other browsers (might be more accurate).

I'd say try Firefox and see how it goes. You can also disable hardware acceleration in Firefox, which does require a browser restart.

This could just be a temporary thing and cured by a future update (hopefully).

As we learn more, we might even be able to properly file a bug that gets noticed and acted on.
 
I hear you... I'm not a fan of current Firefox. Or, I'm too invested in other browsers (might be more accurate).

I'd say try Firefox and see how it goes. You can also disable hardware acceleration in Firefox, which does require a browser restart.

This could just be a temporary thing and cured by a future update (hopefully).

As we learn more, we might even be able to properly file a bug that gets noticed and acted on.
I have been using Firefox for about five days now, and it didn't freeze once.
I guess this means that the problem is with Chrome.
 
With reference to @KGIII 's Linux-Tips article, yeah; I have to agree.

Google say they won't even consider implementing hardware acceleration under Linux for one simple reason. Unlike Windows - where everybody & his dog are singing from the exact same hymn-sheet - Linux just has too MANY "variables" for them to be able to code for it effectively.

There ARE a few "workarounds" floating around the web, but essentially the browser has to be re-compiled from source with the VAAPI driver enabled at build-time. By default, this is disabled.

The only person I know of that supplies Chromium with VAAPI enabled & ready-to-go is a guy who goes by the handle "Marmaduke" on the Woolyss Chromium site. This guy provides a regularly-updated build of Ungoogled Chromium over at Github:-

https://github.com/macchrome/linchrome/releases

....where he uses the name "macchrome". Full instructions are supplied for using hardware acceleration, which involves adding a number of additional "--switches" to the exec line of the wrapper-script.

I use this to create a Puppy-portable build for the community, but I've never tried the VAAPI stuff myself. One of our other members has, and he reports that although it's quite fiddly to set-up, it does in fact work pretty well once it's operational.

But not many will have the time - OR patience - to work their way through all the various steps like our friend "Grey" does!


Mike. ;)
 
Last edited:
I guess this means that the problem is with Chrome.

I suspect that you'll have issues with all the Chromium-based browsers, with this current information.

You can keep Chrome installed and check it after you get any major updates (like a kernel update). It may be one of those things that just goes away on its own, for reasons we don't know.

As you've tried with HA turned off, it makes me think that's definitely not the problem.
 
I suspect that you'll have issues with all the Chromium-based browsers, with this current information.

You can keep Chrome installed and check it after you get any major updates (like a kernel update). It may be one of those things that just goes away on its own, for reasons we don't know.

As you've tried with HA turned off, it makes me think that's definitely not the problem.
Ok, should I leave this post as it is or mark it 'Solved' ?
 
I'd mark it solved, as we've at least found the problem and you have a workaround. You can also test it now and then to see if the problem has been fixed. You could try reporting a bug at Google, but good luck with that... It might be easier to try reporting it as a bug to one of the derivatives, like Opera. They're pretty receptive.
 

Members online


Top