• Important: We recently upgraded our forum software - please let us know if you run into any issues.

Kernel Ring Message Bothering

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Capta, this may be a silly question, but is there an option in your BIOS Setup Utility to enable/disable a webcam?

On my Toshiba, I have the InsydeH20 Setup Utility when I hit my F12 button at startup, and in there, at Advanced - System Configuration, I have the option to enable or disable my webcam, just above my choice of UEFI/CSM.

BTW - on my /dev/sda25 Swagarch, I now have through VirtualBox 5.2.10 ... (drum roll) Arch Linux installed, fullscreen and I have chosen MATE for the DE. I have only put GParted and Firefox on it so far, and yes I can download.

I've run a Timeshift snapshot on it so I don't lose the bugger :rolleyes:

Cheers

Wizard
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Well, I, for one, am gratified that the Levels 12 and 14's (whatever that means) at linuxmint.com appear to be using almost the same diagnostic techniques as we use here :rolleyes:, but that does not solve your problem :(.

Clix Trix there said

it might be possible to blacklist the cam or the hub.
... but that will be tricky, for the camera, without a device number having been detected.

To blacklist, I would normally add to, or set up a file blacklist.conf in /etc/modprobe.d/ , and enter in that eg

Code:
/dev/video0
- that's a zero

But our attempts to get back anything on the camera have so far failed.

I will continue to keep my eye out for a solution, and check those links from linuxmint.com but I do not have high hopes for a quick solution from me.

It may provide a workaround if we can inhibit the generation of the dmesg output, but until I research that, or someone tells me otherwise, I am not sure if that is a good practice or bad. Regrets, my friend, that I can't assist better, for now.

Cheers

Wizard
 

JasKinasis

Well-Known Member
I assume this Arch installation is just a bare-bones Arch install with a single log-in shell/terminal and no GUI?

If so, another"workaround" could be to install and start a terminal multiplexer like screen or tmux.

Multiplexers like screen and tmux allow you to use simple key-binds to create multiple terminals and lay them out in different ways.

Personally, I prefer tmux, but a lot of people still use screen.

Whatever you choose - once you have a terminal multiplexer installed, whenever you log-into the log-in shell/terminal - the first thing you should do is start your multiplexer.

NOTE: You can either start it manually, or set it up to automatically run when you log in.

Here are instructions for setting up tmux on arch:
https://wiki.archlinux.org/index.php/Tmux

There is a similar page for screen too:
https://wiki.archlinux.org/index.php/GNU_Screen

Once the multiplexer is running, the original log-in shell/terminal will continue to get spammed throughout the session. But it will be in the background - so you will no longer see it or be bothered by it until you exit tmux/screen.

Not ideal, but it should make your Arch system more usable until you can find a definitive fix for the problem.

If blacklisting the device doesn't work, maybe physically removing it might help?!

If it's a problem with the built in USB web-cam itself - then physically unplugging/removing it might fix the issue. But if the problem is the USB controller, it could be that there is no fix for it and you just have to live with the error messages. I don't know!
 

Members online

No members online now.

Latest posts


Top