karnel update error --skip-broken

srsachin

New Member
Joined
Oct 4, 2020
Messages
2
Reaction score
0
Credits
19
sudo dnf install https://www.elrepo.org/elrepo-release-8.0-2.el8.elrepo.noarch.rpm
Last metadata expiration check: 5:54:16 ago on Saturday 17 October 2020 12:19:32 PM.
elrepo-release-8.0-2.el8.elrepo.noarch.rpm 4.7 kB/s | 12 kB 00:02
Error:
Problem: conflicting requests
- nothing provides glibc = 2.28 needed by elrepo-release-8.0-2.el8.elrepo.noarch
(try to add '--skip-broken' to skip uninstallable packages)
 


f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,893
Reaction score
2,633
Credits
28,122
What distribution are you running on your system? By the looks of the error I'm guessing Fedora since Fedora and Centos8 have different glibc versions, the elrepo repository is meant for Centos/Rhel not for Fedora.
 
Last edited:

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,893
Reaction score
2,633
Credits
28,122
If you want to install the latest mainline kernel you might as well do it the way that it is advised by the Fedora wiki.
 

f33dm3bits

Gold Member
Gold Supporter
Joined
Dec 11, 2019
Messages
3,893
Reaction score
2,633
Credits
28,122
I don't know much about the kernel but if I am not mistaken I think it's because glibc is compiled against kernel version.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top