Kali Linux in to alienware area 51m

lucomputer

New Member
Credits
0
hi all,
sorry for my english but i don't speak it correctly.
As the title of the post says, I'm trying to install kali linux on my alienware area 51, but without success.
Before you ask me why kali linux and not any other linux distribution, I answer simply because I am taking a course ceh comptia, it is kali linux is among the indispensable requirements. I also thought about installing debian and then inserting the tools, but kali was requested.
now let's get to the point:
I have tried different solutions but each time a different problem.
We start from the already pre-installed operating system which is windows 10 so I would like to use it in dual boot, I would also use 2hd different one for each operating system. windows is installed on an nvme while linux is on an ssd. initially I wanted to install everything on the nvme but it is not recognized in the linux installer (it does not appear among the selection of the disks) so I opted to insert it in the ssd.
20200325_155433.jpg

Bios is an uefi, and as can be seen from the partitions they are both efi.
hence the first problems. During the kali installer recognizes the presence of another operating system but does not recognize it as uefi so he asks me whether to force the installation.
20200325_145418.jpg

if I click no, I proceed with the installation but it does not add the bootloader to the bios, if I do it proceeds with installation and creates the bootloader to the bios, but it does not recognize the presence of the second operating system and therefore requires you to install grub.
20200325_150125.jpg


In any case, upon completion of the installation, as soon as I start os kali, the screen remains locked as in the photo:
20200325_145010.jpg

obviously everything is blocked and does not carry out any command
I tried version on hdd, live version etc ... the result is always the same. I can install via USB stick loaded with Rufus. could the drivers of the video card hit anything?
20200325_225119.jpg

I tried to edit the quiet command by adding the nomodeset command and it stops at this point:
20200325_225654.jpg


I tried to use the live version too, but it doesn't start me either. usual black screen with lines and does not go further.
I tried live version with safe mode and it stops at the following screen:
I wanted to disable bios integrated vga, but it is not possible.

20200326_113851.jpg

thx for help.
 


Drizzit89

Member
Credits
21
Only one drive can be set as the boot device. In your case it's the NvME device. Most likely why Kali doesn't recognize it is because it doesn't have a driver for it.
I have not setup multiple boots across multiple drives before and personally wouldn't recommend it. From reading about setting up dual/multiple boot systems, this configuration is very advanced and requires making manual changes to the grub boot loader.
For CEH study I would find and download Virtual Box. It's a free Hypervisor that can be installed in windows. With VirtualBox you can setup multiple machines and run simultaneously. For example your Kali box and a target box to "attack". There is an extra benefit to using a Hypervisor, you can configure your virtual systems with a network that never leaves the virtual environment. You won't accidentally hit unintended targets like your 51M, other devices on network, or worst case the internet. Hitting unintended targets on the internet can lead to consequence from your internet service provider or Government, depending on location and what accidentally occurred.
In my opinion a dual boot Kali system is for work and not for study.
 

smooth_buddha

Active Member
Credits
2
I would recommend running kali from a virtual machine . It’s much easier , plus the virtual machine allows you to save the state of kali and incase something goes wrong you can easily restore it back the saved machine state.

Go for a Linux Ubuntu or mint install then download oracle virtual box and run install kali into into the virtual box (make sure you download the virtual box version of kali for best results)

If your doing a pent testing course they will usually tell you to set up labs this way. That way if your kali virtual machine is compromised it will not affect your host or main operating system
 



Latest posts

Top