Kali Linux 2020.1 WIFI issues

Spressed

New Member
Credits
52
Well, I’ve been struggling with this for over a week now, I got kali linux on dual boot all set up, but I can’t get it to connect to any WIFI as it it not able to find any, I tried most of the possible solutions that were provided around but nothing worked.
My network driver is Realtek 8822CE Wireless LAN, the wlan shows as a driver, it shows that it exists I have the latest updates, upgrades, and everything it is just that it’s impossible to get it to scan anything.
Help would really be appreciated, I will provide any information necessary
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
10,019
I have the latest updates, upgrades, and everything...
Do I take it then, that it connects with Ethernet OK?

Chris Turner
wizardfromoz
 

Spressed

New Member
Credits
52

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
10,019
Thanks, OK.

I am neither a Kali expert, nor a wifi expert, but I can Google.

Realtek 8822CE kali

... results may assist, especially first one, from Kali Forums.

If you are unsure whether you have Synaptic Package Manager

Code:
apt-cache policy synaptic

# and if available but not yet installed, then

sudo apt-get -y install synaptic
Good luck

Wizard
 

Spressed

New Member
Credits
52
Thanks a lot, but I have tried that. i downloaded the driver, which only caused issues with my windows then 5( (it couldn’t find any wifi from there also until I updated the drivers), i tried to use synaptic but it didn’t work either.

the driver is installed properly it just doesn’t scan properly
 

Alexzee

Well-Known Member
Credits
5,200
Thanks a lot, but I have tried that. i downloaded the driver, which only caused issues with my windows then 5( (it couldn’t find any wifi from there also until I updated the drivers), i tried to use synaptic but it didn’t work either.

the driver is installed properly it just doesn’t scan properly
Dmessage the driver and see what the output says. Maybe that will give you a clue why it's not working.
If the wrong module is loading it will cause the driver/device not to work.
Check if other module's/drivers are loading first.

dmesg <name of driver>

 

Spressed

New Member
Credits
52
Dmessage the driver and see what the output says. Maybe that will give you a clue why it's not working.
If the wrong module is loading it will cause the driver/device not to work.
Check if other module's/drivers are loading first.

dmesg <name of driver>

This is what dmesg shows on my module
741CF80E-384D-44BF-A318-42EC69D17BF5.jpeg
This is what lsmod shows
38F28C80-AE29-459F-A2F7-9A85667811AE.jpeg

9C985B68-D742-4BE6-A623-99D43AF31A98.jpeg

CE178EA6-599C-433F-82DD-BC9F814FC803.jpeg

CBCBA2C9-0B90-45B9-89A4-BD117347ECB8.jpeg

CBCBA2C9-0B90-45B9-89A4-BD117347ECB8.jpeg

Also I ran iwconfing and ip link show where it shows the status of wlan0 is down even after using sudo iwconfing wlan0 up

here are the photos
8DE41CA2-D93A-476A-83FF-EA48DB5E40C9.jpeg
07D2F9A9-568B-471A-A762-96BE073EA2F6.jpeg
 

Attachments

Carosone

Member
Credits
240
Well, I’ve been struggling with this for over a week now, I got kali linux on dual boot all set up, but I can’t get it to connect to any WIFI as it it not able to find any, I tried most of the possible solutions that were provided around but nothing worked.
My network driver is Realtek 8822CE Wireless LAN, the wlan shows as a driver, it shows that it exists I have the latest updates, upgrades, and everything it is just that it’s impossible to get it to scan anything.
Help would really be appreciated, I will provide any information necessary
 

Alexzee

Well-Known Member
Credits
5,200
TP Link, Atheros if I'm not wrong, I can't get you the full details now.
Wireless dongle works,
normal one doesn't work.
Glad to hear that the wireless dongle works.
Beats a blank.
 

Alexzee

Well-Known Member
Credits
5,200
Yeah but the dongle is rather weak and I can barely scan anything with it, do you have any idea how to solve the issue at hand?
No-

If the dongle is working (eventho it's weak) and the driver is installed I don't know what else you could try but to get closer to the router/modem.
 

JasKinasis

Well-Known Member
Credits
5,076
Maybe you’re missing some firmware for your card?
What is the output from running:
Bash:
apt policy firmware-realtek
If it shows up as uninstalled, you should install the firmware-realtek package.
 

Members online


Latest posts

Top