Purchase Linux CDs / DVDs / Flash Drives at OSDisc.com

Welcome to Our Community

While Linux.org has been around for a while, we recently changed management and had to purge most of the content (including users). If you signed up before April 23rd please sign up again. Thanks!

Kali Linux 2.0/ Rolling Distro ugrade issue

Discussion in 'Kali Linux' started by zzDopey, Jul 11, 2017.

  1. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    Ok, so i am trying to install the rolling distro on my kali 2.0. I have it running directly off a 1tb HD. I have persistence enabled and 800gb roughly available. I have tried this a few times and found different errors which i have been working on. THis one i have no clue how to fix as i can only access a tty command line without Internet connection once i ran the Distro upgrade. The install of the ugrade failed and made me reboot giving me the error that some of the items were not installed. Currently it stalls on Started Update UTMP about System Runlevel Changes. Then gives me an IPv6 wlan0: link is not ready. Gives same error in command line for eth0 and l0. Can anyone help me run through some troubleshooting. i can boot into my live version and have persistence mounted.


     
  2. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    165
    Likes Received:
    123
    Hi @zzDopey, and welcome to the forum! Networking is disabled by default in Kali, which may be part of your problem. But really, it sounds like you are rather new to this, and Kali is a very poor choice for new users. It is especially designed for Linux security professionals, and the folks at Kali recommend Ubuntu, Mint, or Debian, as good alternatives. You can read more from them here. If you really want to learn Kali, I would suggest running your live version only... it will work fine for what it is designed to do from the live environment.

    Good luck!
     
  3. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    I am fairly new to setting up the kali rolling distros. However i do work on ubuntu and i am taking classes for kali, hence why i need the rolling distro as i cannot upgrade some of the programs i need to run for my course work.
    I deleted my partition where the GUI failed. Set up another one and have done this again. Now i get to another error. following code is where the error is occuring. And no the network works fine in kali that was fixed ages ago. I however was unable to connect thru tty once the system rebooted on previous attempt.

    Unpacking glib-networking:amd64 (2.50.0-1+b1) over (2.42.0-2) ...
    Errors were encountered while processing:
    /var/cache/apt/archives/vlc-bin_2.2.6-2+b3_amd64.deb
    Can't locate Term/ANSIColor.pm in @INC (you may need to install the Term::ANSIColor module) (@INC contains: /etc/perl /usr/local/lib/x86_64-linux-gnu/perl/5.20.2 /usr/local/share/perl/5.20.2 /usr/lib/x86_64-linux-gnu/perl5/5.20 /usr/share/perl5 /usr/lib/x86_64-linux-gnu/perl/5.20 /usr/share/perl/5.20 /usr/local/lib/site_perl .) at /usr/share/perl5/Dpkg/ErrorHandling.pm line 48.
    BEGIN failed--compilation aborted at /usr/share/perl5/Dpkg/ErrorHandling.pm line 48.
    Compilation failed in require at /usr/share/kali-menu/update-kali-menu line 6.
    BEGIN failed--compilation aborted at /usr/share/kali-menu/update-kali-menu line 6.
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    E: Problem executing scripts DPkg::post-Invoke '[ ! -x /usr/share/kali-menu/update-kali-menu ] || /usr/share/kali-menu/update-kali-menu wait_dpkg'
    E: Sub-process returned an error code


     
  4. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    i am quite aware what kali is used for and i actually have quite a bit of experience in kali, but without the distros half of the applications will not work properly, trying to educate me on the uses is not helpful. However if someone could explain to me why this error is occuring them im sure i could figure out how to resolve it. If i reboot now im pretty sure this is where i had the issue with the GUI the last time. Any ideas?
     
  5. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    uname -a
    Linux kali 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux

    [email protected]:~# cat /etc/apt/sources.list
    deb http://http.kali.org/kali kali-rolling main contrib non-free
    # For source package access, uncomment the following line
    # deb-src http://http.kali.org/kali kali-rolling main contrib non-free
     
  6. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    I ran apt-get install -f

    Errors were encountered while processing:
    /tmp/apt-dpkg-install-2MDfpZ/08-vlc-l10n_2.2.6-2_all.deb

    [email protected]:~# apt-get clean
    [email protected]:~# apt-get update
    Hit:1 http://mirrors.ocf.berkeley.edu/kali kali-rolling InRelease
    Reading package lists... Done
    [email protected]:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
    vlc : Depends: vlc-l10n (= 2.2.6-2) but it is not installed
    Recommends: vlc-plugin-skins2 (= 2.2.6-2+b3) but it is not installed
    Recommends: vlc-plugin-video-splitter (= 2.2.6-2+b3) but it is not installed
    Recommends: vlc-plugin-visualization (= 2.2.6-2+b3) but it is not installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
     
    #6 zzDopey, Jul 11, 2017
    Last edited: Jul 11, 2017
  7. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    Hi zzDopey (which I gather you are not, lol)

    I have read through, but am not about to address, yet, the errors you have faced.

    Rather, I would like to ask about your course, in particular, does it require the use of the Kali you are using?

    I typically run 20 - 70 Linux (no typo there) over three home computers - two lappies and one desktop, from Debian-based, RPM-based, Gentoo-based, and Arch-based, "families".

    One of my stumbling blocks was getting Kali to install correctly, up until recently. Didn't matter whether I burned the iso using Unetbootin, Multisystem or other, Distro-based options (all using USB stick) ... or using <dd> - wouldn't take.

    This year, I tried:

    • kali-linux-light-2.0-amd64.iso
    • kali-linux-mate-2016.2-amd64.iso
    ... still, no joy.

    FINALLY, kali-linux-2017.1-amd64.iso - worked for me.

    So the question I would ask is with regard to your course outline.

    Would the full version suffice?

    Do you have a link to, or a digitised version of, the course outline requirements?

    Does it have to be Kali, or is Parrot any good?

    etcetera, etcetera. Tell us more about what you need.

    I am by no means an expert (yet) in Kali, nor in pen testing in general. But I may be able to help with some ideas if you can tell us a little more about your needs, timeframe, etc.

    Cheers

    Wizard
     
    atanere likes this.
  8. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    I am doing pen testing on ubuntu and windows in school, but on the side i am studying with kali linux. I am using Web Penetration Testing with Kali Linux by Joesph Muniz/Aamir Lakhani to expand my knowledge base in my spare time. I have already gone through a few books on Kali such as Kali Linux Wireless Penetration Testing by Vivek Ramachandran/ Cameron Buchanan. The issue is my Kali 2.0 is on a portable 1tb HDD and i cannot upgrade it to 2017.1 without recieveing this error. I need to update Maltego for the lab im running. Due to it being on the old Sana Repos, which doesn't seem to like my kali 2.0 system. Would a better method be to uninstall my kali 2.0 and install a completely new copy of 2017.1 ? Cause i feel like linux should be able to be fixed through command line better then most others? This doesn't seem like a major issue i am just unfamiliar with dpkg errors haven't had to work with them much. And to the moderator who posted, learning by doing is better any day then saying people should try a different distro.

    apt --fix-broken install
    ## was ran
    Installing new version of config file /etc/lvm/lvm.conf ...
    I: update-initramfs is disabled (live system is running without media mounted on /lib/live/mount/medium).
    update-rc.d: We have no instructions for the lvm2-lvmetad init script.
    update-rc.d: It looks like a non-network service, we enable it.
    update-rc.d: We have no instructions for the lvm2-lvmpolld init script.
    update-rc.d: It looks like a non-network service, we enable it.
    Created symlink /etc/systemd/system/sysinit.target.wants/lvm2-lvmpolld.socket → /lib/systemd/system/lvm2-lvmpolld.socket.
    Processing triggers for libc-bin (2.24-12) ...
    Processing triggers for libvlc-bin:amd64 (2.2.6-2+b3) ...
    Processing triggers for dbus (1.10.20-1) ...
    Processing triggers for systemd (233-9) ...
    Processing triggers for tex-common (6.07) ...
    Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/^(.*?)(\\)?\${ <-- HERE ([^{}]+)}(.*)$/ at /usr/share/perl5/Debconf/Question.pm line 72.
    Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^}]+)}/ at /usr/share/perl5/Debconf/Config.pm line 30.
    Running updmap-sys. This may take some time... done.
    Running mktexlsr /var/lib/texmf ... done.
    Building format(s) --all.
    This may take some time... done.
    W: APT had planned for dpkg to do more than it reported back (918 vs 922).
    Affected packages: prosper:amd64
    and this is where failed

    i assume dpkg is failing for a reason ... but unsure what exactly is going on . An explanation would be helpful lol
     
    #8 zzDopey, Jul 11, 2017
    Last edited: Jul 11, 2017
  9. Rob

    Rob Administrator
    Staff Member

    Joined:
    Oct 27, 2011
    Messages:
    145
    Likes Received:
    397
    @zzDopey welcome to the forum!

    I'm sure @atanere agrees that learning while doing is a great thing, but I'm with him on making sure the person you're helping has a good understanding and background with basic Linux distributions before installing and hitting a wall with Kali.. that's all he meant.

    Anyway, sorry to see you're having an issue w/ the rolling release. i've only dabbled with Kali and i'm strictly on the rpm-based distributions currently since that's what I use mainly at work, but did find this that may help you:
    http://www.kalitut.com/2015/03/how-to-update-kali-linux-and-fix-update.html

    Let us know how that goes - good luck!

    Rob
     
    atanere likes this.
  10. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    165
    Likes Received:
    123
    Okay @zzDopey, forgive me for misjudging your abilities. I'll try to do better.
     
  11. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    165
    Likes Received:
    123
    Kali 2.0 was their first attempt at a rolling distribution model, but that was now nearly 2 years ago (with 2 other releases made in 2016). They announced here that the Sana repositories have officially been retired. So I think you and @wizardfromoz are both hitting on the best course of action: do a full install of 2017.1 (and then keep it current).

    The world needs more security experts, so I wish you very good luck in pursuing this course! :)

    Cheers!
     
    wizardfromoz and Rob like this.
  12. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    Alright right sir ! Sounds good i was just dreading another full install lol, Took me ages to get an actual working copy of kali 2.0 back when i had it installed lol. Guess things have changed alot since then lol.

    It seems the steps i took has resolved most of the errors fter a second runthrough of the same commans most of the install was completed.
     
    #12 zzDopey, Jul 11, 2017
    Last edited: Jul 11, 2017
    atanere, wizardfromoz and Rob like this.
  13. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    @zzDopey, @All - good morning I am just on my 2nd coffee (for the benefit of the OP I come from DownUnder - Australia). My highlighting above.

    Took me two years, lol, to get a working Kali up and running on the PC in the Garage, and then within weeks, that PC fell over (not because of the 40 Distros on it, it has been falling over for years). So today I will be attempting to install the 2017 Kali on the Toshiba Satellite in the Laundry - let's hope I hold my mouth the right way?

    To make an antiquated analogy:

    In the early Noughties, Mandrake was one of the pre-eminent RPM Distros. It ultimately languished, and a collaboration between them and a Distro known as Connectiva was forged, and Mandriva was the outcome (with Mageia forking off in a different direction). Nowadays we have OpenMandriva to show for it.

    Wearing my best Spock hat "It's only logical "Jim", to have the cutting edge tools at your disposal, if you wish to pursue a vocation, a career, or even an active interest, in ethical hacking. If it is your ambition to help corporate entities, right down to the individual home user, to implement and maintain a safe and secure working environment, then to have less than the latest (stable) software on board would be folly".

    Under the above premise, for me to perform pen testing on Mandrake would be a waste of time, other than to see if you could drive a Mack truck through the holes (vulnerabilities) exposed, just as it would be pointless to use a Kali from that time to examine one of today's products.

    You, though are behind the steering wheel of your own PC, and so the choices are yours to be made.

    Kali, if I am not mistaken, is based on Debian Wheezy, and Debian itself have released v9 "Stretch" recently (I have it onboard), but I do not see that as presenting problems.

    If you like, I can drop a note here when I have installed the 2017 Kali, but it may be you teaching me where Kali is concerned, lol.

    Cheers

    Wizard
     
    atanere likes this.
  14. atanere

    atanere Moderator
    Gold Supporter

    Joined:
    Apr 6, 2017
    Messages:
    165
    Likes Received:
    123
    Yeah, sometimes a full install is the only way to go. You still may run into snags... things like UEFI plays many tricks from one distro to another, and Kali is still not the friendliest out there. Hopefully you won't have any issues, or if so, only minor ones. :cool:

    Cheers!
     
  15. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    Hi All

    Just added a couple of essentials (to me) - GNOME Screenshot, Synaptic Package Manager, GParted (already installed), and GTKHash ... to the Panel

    Other than that, pristine (yeak OK I like green on black in my Terminal, lol), and I am up & running.

    [​IMG]

    @zzDopey - When you set yours up, you might like to take a look at options such as Aptik and Timeshift from Tony George (he also provides the industry standard Conky Manager) at teejeetech.in ... I have a Tute about Aptik kicking around here somewhere,

    Cheers

    Wizard

    BTW I have only given this install 50 gigs for the moment whilst I evaluate its working options, but can allocate more.
     
    atanere and Rob like this.
  16. zzDopey

    zzDopey New Member

    Joined:
    Jul 11, 2017
    Messages:
    8
    Likes Received:
    6
    Well i thought i would just add that i resolved the issue on my kali 2.0 to kali 2017.1 upgrade by following the steps i posted lol. I just had to run them 3x then finally completed the 2017.1 with full upgrade :)
    I was very tired after spending 12 hours at work and then 8 hrs trying to install kali was fed up lol. the answer to my questions was only shown when i reread my posts and noticed the command line was telling me what to do lol.


    [email protected]:~# apt-get install -f
    [email protected]:~# apt-get clean
    [email protected]:~# apt-get update
    [email protected]:~# apt --fix-broken install
    [email protected]:~# apt-get install
    [email protected]:~# apt-get dist-upgrade
    [email protected]:~# apt-get install -f
    [email protected]:~# apt-get clean
    [email protected]:~# apt-get update
     
    #16 zzDopey, Jul 13, 2017
    Last edited: Jul 13, 2017
    Rob, atanere and wizardfromoz like this.
  17. wizardfromoz

    wizardfromoz Member

    Joined:
    Apr 30, 2017
    Messages:
    77
    Likes Received:
    75
    Mate you are going to be a champion at Linux and at Kali if you stick with it :)

    8 hours :eek:

    Interesting with the "apt-get install -f" 's of having to force it.

    But the bottom line is good, in that you have it up and running.

    Good news for me is that I have the Garage computer up and running, so now I have two versions of the same Kali as you, if that can help you at any time, to compare.

    Take care, and I look forward to hearing of your continuing voyages with Linux and with Kali, if you share them.

    Cheers

    Wizard
     
    atanere likes this.

Share This Page