Is there a way to update GLIB on ElementaryOS?

Rafaelys

Member
Joined
Jan 29, 2020
Messages
47
Reaction score
24
Credits
464
Hi everyone,

I've tried to install Duckstation (a PS1 emulator) using AppImage on Elementary 5.1, and it didn't work:

/lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.30' not found

Apparently the latest Glibc version (2.30 or higher) is required to install it, and turns out that EOS is based on Ubuntu 18.04, which supports Glibc only up to 2.27.

While searching other threads I've learned its not recommended to manually install newer Glibc versions on 18.04 though, since this can potentially "broke the entire system".

So I'm thinking if there's anything else to do, such as upgrading Ubuntu version or start using a more updated linux distro.

Thanks!
 


Most of your system is dependent on those libraries and if you try to install an updated version if will break your system or you will run into a lot of problems so you better option is to upgrade your system to a newer version of the distribution you are running.
 
Last edited:
Elementary 5.1 is based on Ubuntu 18.04 hence the latest version is 2.27 you will need to migrate your application to a system that supports GLIBC higher than or equal to 2.30. Elementary 6.0 is beta right now based on Ubuntu 20.04 final version will hopefully be out soon
 
Thanks friends, I understood by reading you that it would require installing another OS, and I certainly wouldn't make such a radical change just to be able to play an emulator for 15 minutes a week lol

It's nice to know that a new version of EOS is coming anyway :cool:
 
It's nice to know that a new version of EOS is coming anyway :cool:

If you're interested in the beta:

 
It's also been available for 3 days on Distro Watch , although your link looks interesting reading.

Wiz
 

Staff online

Members online


Latest posts

Top