Installing PHP and Composure for Laravel framework

rgbellotti

New Member
Joined
Nov 2, 2020
Messages
17
Reaction score
11
Credits
168
I've tried in two distros now and ran into the same roadblock, but when I'm installing the necessary components to start building with Laravel, I get a message about needing to enable openssl in PHP, or that I should "recompile PHP with --with-openssl option". From what I was able to find online, it's necessary to uncomment the "extension=openssl" line in the php.ini. So I did this, in both the -dev and -pro versions of the php.ini file, and still gt the same message when trying to install Composure, that I need to enable the openssl to install. I'm currently trying in a new install of MXLinux, and I previously tried in Parrot OS but had the same problems
 


OP
R

rgbellotti

New Member
Joined
Nov 2, 2020
Messages
17
Reaction score
11
Credits
168
Update:

Currently running Lubuntu 22.04, and have php installed via "sudo apt install php8.1" and "sudo apt install php8.1-dev". I've got OpenSSL 3.0.2.

Per recommendation, I've edited all the php.ini files to un-comment the line where "extension=openssl"
And now, any time I run a php script in the terminal, I get the a warning as well that says:

"PHP Warning: PHP Startup: Unable to load dynamic library 'openssl' (tried: /usr/lib/php/20210902/openssl (/usr/lib/php/20210902/openssl: cannot open shared object file: No such file or directory), /usr/lib/php/20210902/openssl.so (/usr/lib/php/20210902/openssl.so: cannot open shared object file: No such file or directory)) in Unknown on line 0"

I don't have an openssl.so file on my hard drive, and haven't been able to find one online. The closest thing I can find are some other util-openssl.so files that are in other program directories. In the directory mentioned in the warning message, I do have other .so files, so I imagine I just need to place it in that directory to fix the situation
 
OP
R

rgbellotti

New Member
Joined
Nov 2, 2020
Messages
17
Reaction score
11
Credits
168
Update2:

Despite php not being able to locate the openssl.so file, Composer still installed this time around, because the php.ini had the option enabled I'm assuming. And from there, Laravel installed fine afterwards. Afterwards, I commented the "extension=openssl" line in the php.ini file, and that stopped the "Warning" message every time PHP ran.

So while it's not a "fix" (apparently still don't have ssh setup right), it's still possible to install Laravel
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation


Latest posts

Top