• We did not send an email asking for donations - please read this post.

[info] If you have large hard disks and they keep grinding at every reboot

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
647
Reaction score
518
Credits
3,613
For months I had this weird problem where the hard disks kept grinding at every reboot. At first I thought the cause was gnome-search-tool because it has an indexing process which allows faster finding of files. But uninstalling GST didn't fix anything, so I kept looking. And half an hour ago I found not only the solution but also the cause! It turns out that at some point the kernel devs have added this process named "ext4lazyinit" to the kernel which starts grinding while dmesg is running on the screen. The larger the EXT4 filesystem is, the longer the grinding is. And since two of my filesystems are respectively 1TB and 4TB the grinding kept going for 3 to 5 minutes at every reboot.

The solution:
Open fstab and add
Code:
no_prefetch_block_bitmaps
in the mount options. As an example I'm posting my own fstab.

Code:
# /dev/sdc1 Arch Linux
UUID="44b6676c-7c54-49b5-8357-b1bcd78712d8"    /             ext4          rw,relatime    0 1
UUID="57bd3dcf-68e1-4d2d-8a19-c9e81142c66b" /media/1000GB ext4 defaults,relatime,no_prefetch_block_bitmaps,auto 0 0
UUID="8c2610c6-cea7-49b7-8f19-54ef476b631f" /media/4000GB ext4 defaults,relatime,no_prefetch_block_bitmaps,auto 0 0
UUID="727923DC502A69D8" /media/390GB ntfs-3g defaults,relatime,no_prefetch_block_bitmaps,auto,uid=1000,gid=1000,umask=000 0 0
UUID="2022A53729C8B29D" /media/500GB ntfs-3g defaults,relatime,no_prefetch_block_bitmaps,auto,uid=1000,gid=1000,umask=000 0 0

In principle ext4lazyinit doesn't "touch" NTFS filesystems but I can't know when and what the devs will decide to change, so I added this option to the NTFS filesystems as well. I already tried it and it doesn't hurt to have this option for them as well.
On the internet you can find adding "noinit_itable" or "init_itable=0" to the mount options as a possible solution but these two don't work AT ALL - I already tried them. Only "no_prefetch_block_bitmaps" brings you the peace and quiet you used to have.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top