I'm stuck in recovery-mode, can't boot

terereking17

New Member
I cant start ubuntu normally in my notebook hp Pavilion 15. I had ubuntu for a while alongside windows 10 in this computer. I used both OS normally until last week, when suddenly after choosing Ubuntu in grub it went to recovery mode, showing some errors like:

" modsign: Couldn't get UEFI db list",

"do_IRQ: 1.55 No irq habdler for vector",

"do_IRQ: 2.55 No irq habdler for vector",

""do_IRQ: 3.55 No irq habdler for vector",

"couldn't get size: 0x800000000000000e"

It didn´t bother me much because I was already thinking about making a new-clear install of both Windows 10 and ubuntu this weekend(windows has been a bit laggy lately), however... I used a LiveCD again after using "boot-repair" today trying to recover my data before wiping my HDD and making a clean install, but I forgot some of my files were "protected"/"encrypted" so I wasn´t able to get all my docs, classes, etc. I really need to recover those files back :(


This is what i've tried so far, with no results:

I installed and used via sudo and ppa the "grub-recovery" in the liveCD command prompt, but grub is still not available when turning on the computer (I checked the BIOS Menu and the secureboot/fastboot option is disabled; the same goes for the windows 10 fastboot).

I can only access to grub menu through "advanced boot options" in windows and choosing "Ubuntu".

Already in grub menu, I pressed "c" and changed "quiet splash" with "noapic noacpi nosplash". Still the same. Then I used "sudo blkid" in recovery mode, and looked whether the UUID in grub was the same as the one where my Ubuntu partition is(which is sda5, ext4 type). They were not different. What can I do?

Here is my partition list: includes windows, ubuntu(ext4 and swap) and the win recovery partition(which came with computer by default. windows OEM and some programs,etc)





A picture of the errors showing up at boot:




The log of boot-repair:



Thanks!
 



Staff online

Members online


Top