I still cannot find why my wireless is not working?

M

milla_strive

Guest
HI!
Can you give me some advice about this question?

My OS: Red Hat 5.8 kernel 2.6.18-308.el5
My wireless card: Atheros AR9285

After installed the OS, the card named wlan0 conld be identified by it, but could not be used.
I first find the drive is madwifi -0.9.4-tar.gz, but it doesnot support well to this device. It need to modify and compile the rpm file which is so hard to me.
Second, Some one told me that the tool ndiswrapper can resolve my problem. So, I worked with ndiswrapper step by step. It good, after this work. When I restart the network manager, it scans and returns some wireless signal for me.

But, the question is:

1>Why cannot I active my wireless card also?
2>Why can the card scan and return the wireless signal of others but not mine?

I mean I still can not work with the wireless card, although I spent a great deal of time handling this problem ?

Can you help me ? Give me some advice or give me the drive?

Thanks a lot!!!
 


A

arochester

Guest
If I Google: Redhat Atheros AR9285
the first 4 things which appear are Bugs. It looks like many people have problems with them.

With the advent of the Raspberry Pi computer there has been a surge of interest in nano (very small) wifi dongles which work out-of-the-box and cost about $10.

Daniel Bull wrote an interesting review of the:
Duronic IR786N (RTL8188CUS chipset*)
Dynamode WL-700N-RXS (RT5370 chipset*)
Edimax EW-7811Un (RTL8188CUS chipset*)
at https://plus.google.com/u/0/109352235257103413028/posts?hl=en

It might save you lots of trouble if you could used one of these dongles instead...
 
R

ryanvade

Guest
Any chance you can update to a newer system (kernel 2.6 is pretty old) ?
That wifi chipset uses the ath9k driver.

RHEL 5.5 get a wireless facelift. The facelift consists of getting a new mac80211, cfg80211 and some wireless drivers backported from 2.6.32 down to 2.6.18. Along with it came ath9k. This section documents how to get the kernels to get ath9k on your Centos5/RHEL5 kernels and tries to track any issues present on them.
 

samK

New Member
Credits
200
Make sure your computer/device is still in the range of your router/modem. Move it closer if it is currently too far away. Go to Advanced > Wireless > Wireless Settings, and check the wireless settings. Double check your Wireless Network Name and SSID is not hided.
 

darry1966

Active Member
Credits
1,149
Sam K I have come to the conclusion you are an archeologists as you love to dig up old threads.
 


Members online

No members online now.

Latest posts

Top