I can't mount ntfs filesystem with write

JackeyHere

New Member
Joined
Nov 6, 2021
Messages
7
Reaction score
1
Credits
61
Today,I complete Linux kernel 5.15 and install it,I complete ntfs driver in kernel,too.I test mount the ntfs filesystem to "/home/user/data",it's OK.But I can not wirte anything in it.
 


stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
I can't speek english very much(-_-).
We appreciate your effort, Jackey, and welcome to the forum. You might try to use a translator like DeepL or Google Translate... they may help you.

If the NTFS drive you are trying to write to is your Windows drive (or partition)... this is a common problem. It happens because when you tell Windows to "shut down".... it doesn't. Instead it goes into "hibernation"... which means that Windows is still running, and Linux will not write to that drive to protect your Windows from damage.

To test this, boot into Windows and instead of choosing "shut down".... choose "restart".... but then boot into Linux instead. Windows will not "hibernate" if it is restarted. You should be able to write to the NTFS drive now, if this is the problem.

If this fixes the problem, you may want to permanently disable hibernation in Windows so then you could "shut down" again as usual. This is a very simple step:

1. Boot Windows
2. Run CMD (the Windows Command Prompt) as Administrator
3. Give this command: powercfg.exe /hibernate off

(These instructions are also provided by Microsoft here.)
 

Fanboi

Well-Known Member
Joined
Apr 16, 2021
Messages
499
Reaction score
409
Credits
6,114
If not using/dual-booting Windows...
Try option (-o) to mount:
Code:
sudo -i
mount -t ntfs -o rw /dev/sdXY /home/user/data
chown 1000:1000 /home/user/data
Explicit tell mount make writable. Explicit ownership. You need superuser/root to mount.
Hope this helps.

Another thing:
Translates best: https://www.deepl.com/translator
 
OP
J

JackeyHere

New Member
Joined
Nov 6, 2021
Messages
7
Reaction score
1
Credits
61
We appreciate your effort, Jackey, and welcome to the forum. You might try to use a translator like DeepL or Google Translate... they may help you.

If the NTFS drive you are trying to write to is your Windows drive (or partition)... this is a common problem. It happens because when you tell Windows to "shut down".... it doesn't. Instead it goes into "hibernation"... which means that Windows is still running, and Linux will not write to that drive to protect your Windows from damage.

To test this, boot into Windows and instead of choosing "shut down".... choose "restart".... but then boot into Linux instead. Windows will not "hibernate" if it is restarted. You should be able to write to the NTFS drive now, if this is the problem.

If this fixes the problem, you may want to permanently disable hibernation in Windows so then you could "shut down" again as usual. This is a very simple step:

1. Boot Windows
2. Run CMD (the Windows Command Prompt) as Administrator
3. Give this command: powercfg.exe /hibernate off

(These instructions are also provided by Microsoft here.)
Thanks for your help,but they could not provide me with practical help.233
What I'm trying to say is that after compiling the new Linux 5.15 release (and compiling it with NTFS read/write support), I still can't use the mounted.I would like to try to see feedback from pioneers like me on the forum.
 
OP
J

JackeyHere

New Member
Joined
Nov 6, 2021
Messages
7
Reaction score
1
Credits
61
If not using/dual-booting Windows...
Try option (-o) to mount:
Code:
sudo -i
mount -t ntfs -o rw /dev/sdXY /home/user/data
chown 1000:1000 /home/user/data
Explicit tell mount make writable. Explicit ownership. You need superuser/root to mount.
Hope this helps.

Another thing:
Translates best: https://www.deepl.com/translator
Thanks for you help,too.But they could not provide me with practical help.(T⌓T)
 

stan

Well-Known Member
Joined
Mar 19, 2018
Messages
1,004
Reaction score
1,134
Credits
9,370
Thanks for your help,but they could not provide me with practical help.233
What I'm trying to say is that after compiling the new Linux 5.15 release (and compiling it with NTFS read/write support), I still can't use the mounted.I would like to try to see feedback from pioneers like me on the forum.
I don't think I clearly understand your problem. You should not need to compile a kernel to get R/W support on NTFS.

Good luck... I hope that you find your solution!
 

JasKinasis

Well-Known Member
Joined
Apr 25, 2017
Messages
1,631
Reaction score
2,336
Credits
12,442
Does the NTFS drive/partition you’re trying to mount have Windows installed on it?
If so, does that version of windows have any fastboot options set?
If so, then that is probably the reason that it is failing to mount in read/write mode.

When fastboot is enabled, Windows doesn’t fully shut down when you shut-down and the NTFS file system is locked.
As Stan said, windows hibernates instead.
So when you boot to Linux and try to mount the NTFS drive/partition, it can only be opened in read mode.

In this situation, the fix is to disable fastboot in Windows. Then when you shut windows down after fastboot has been disabled, the file system should not be locked. And when you boot to Linux - it should be possible to mount/open in read/write mode.

Unfortunately, I’m not a windows 10 user. All of my PC’s run Linux.
And at work, I haven’t used anything past Windows 7. And my work PC doesn’t support fastboot. So I don’t know the exact steps to disable fastboot. I’m just aware that it can cause problems when mounting NTFS drives/partitions in Linux.
 

wizardfromoz

Administrator
Staff member
Gold Supporter
Joined
Apr 30, 2017
Messages
8,139
Reaction score
7,019
Credits
31,439
Today,I complete Linux kernel 5.15 and install it,...

For "complete" I suspect "update" or "upgrade" is appropriate.

@JackeyHere , welcome.

What Linux distribution are you using? Name and version number?

For example

Linux Mint 20.2

Ubuntu 21.10

and so on.

Chris Turner
wizardfromoz
 
OP
J

JackeyHere

New Member
Joined
Nov 6, 2021
Messages
7
Reaction score
1
Credits
61
For "complete" I suspect "update" or "upgrade" is appropriate.

@JackeyHere , welcome.

What Linux distribution are you using? Name and version number?

For example

Linux Mint 20.2

Ubuntu 21.10

and so on.

Chris Turner
wizardfromoz
I use Debian Unstable(sid),upgrade Kernel to 5.15,kernel.org release new NTFS supprot here.Now I use ntfs-3g to give me temporary NTFS read and write support.
I think the packet "linux-util" isn't support kernel NTFS support.
 

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
647
Reaction score
520
Credits
3,613
I use Debian Unstable(sid),upgrade Kernel to 5.15,kernel.org release new NTFS supprot here.Now I use ntfs-3g to give me temporary NTFS read and write support.
I think the packet "linux-util" isn't support kernel NTFS support.
Or, you can write it in the file fstab:
Code:
sudo gedit /etc/fstab
put the following code in fstab, then save and close. You'll need to reboot after that.

Code:
/dev/sdXY /home/drive ntfs-3g defaults,auto,nofail,x-systemd.device-timeout=10,uid=1000,gid=1000,umask=000 0 0

Before you do these things, please note:

• /dev/sdXY must be replaced with the device name you wanna mount. The easiest way to find its name is to use the command "sudo blkid", assuming it exists in Debian. There you'll find a list of all of your storage devices. Once you identify the device you wanna mount and write on it, see what name it has been given and it will look like this: /dev/sdXY where X is a letter of the alphabet and Y is a number. So it will be sda1, sda2, sda3, sdd4 and so on.
• replace /home/drive with the desired mount point. If you wanna see that device to appear named as (for example) "Drive_D", write the mount point to be /Drive_D or /media/Drive_D. I for one prefer to mount them all in /media - makes it easier to find them all when needed.

After you've made these changes to fstab, save the file, reboot and if you've done things right, you should be able to permanently write on that drive, for as long as this distribution is running. Here's what MY fstab looks like and I don't need to temporarily mount anything, I can always write on these devices:
Code:
/dev/sdc1 /media/1000GB ntfs-3g defaults,auto,nofail,x-systemd.device-timeout=10,uid=1000,gid=1000,umask=000 0 0
/dev/sda2 /media/390GB ntfs-3g defaults,auto,nofail,x-systemd.device-timeout=10,uid=1000,gid=1000,umask=000 0 0
 
OP
J

JackeyHere

New Member
Joined
Nov 6, 2021
Messages
7
Reaction score
1
Credits
61
This problem is solutions.When we mount the ntfs devices with ntfs3 driver,we should use the optiton "-t ntfs3"
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top