I cannot get on Netflix. Why?



TechnoJunky

Well-Known Member
First of all you can give us some info. We’re not mind readers. What distro are you using? What error are you getting?

I run a Ubuntu based OS and have no issues at all.
 

Condobloke

Well-Known Member
What version of Firefox are you using ?.....how old is it ?
 

Condobloke

Well-Known Member
Are you using the chameleon add on ?

Add netflix.com to your whitelist if you are
 

Condobloke

Well-Known Member
Which Linux are you using ???

Try a different browser ?
 

Condobloke

Well-Known Member
click on menu...(bottom left hand corner) start to type in Welcome Screen..........click on that......your operating system version etc will show......
 

Condobloke

Well-Known Member
Good.
Again in menu, type in Chromium

If you get no 'answer', go back to menu and locate "Software Manager'

Click on that to open it

In top right hand corner type in chromium browser

It will open to a page where that is shown....click on Install

It may open a small window saying that 'additional software has to be installed'

Click on Continue

Then enter your password

It will install (it may take a few minutes....)

Click on 'Launch' You can always find it in the menu later, and right click on 'Chromium Web Browser'....and select either add to panel or add to desktop...depending on where you want the shortcut

You now have another browser.

Try it out
 

Sandi

New Member
Good.
Again in menu, type in Chromium

If you get no 'answer', go back to menu and locate "Software Manager'

Click on that to open it

In top right hand corner type in chromium browser

It will open to a page where that is shown....click on Install

It may open a small window saying that 'additional software has to be installed'

Click on Continue

Then enter your password

It will install (it may take a few minutes....)

Click on 'Launch' You can always find it in the menu later, and right click on 'Chromium Web Browser'....and select either add to panel or add to desktop...depending on where you want the shortcut

You now have another browser.

Try it out
Thank you, I did. But it still doesn't work.
 

Condobloke

Well-Known Member
Try turning ON DRM in Firefox

click on three horizontal lines in top right hand corner....the click on preferences.

Type in DRM in the search box....hit enter....put a tick in the box. Close the browser. Restart Firefox.

Works Now ?
 

atanere

Well-Known Member
I tried Chromium too... doesn't work. :(

Firefox not working for me either, even with DRM enabled, and even after starting Firefox in safe mode to disable other addons. My Firefox is up to date. This should work, but it doesn't. :(

Solution: install Google Chrome. The real-deal Google Chrome. I think it is also available in your Software Manager, which is probably the best way to install it. This worked for me. :D

The Opera web browser may work also. Whichever works for you, be sure to keep it up to date.

Good luck!
 
Last edited:

TechnoJunky

Well-Known Member
I had previously had Fedora and I couldn't get Netflix to work in Firefox on it. I gave up on Fedora because I had so many issues with it and went back to Neon. On Neon, I've had no issues watching Netflix or any other streaming service on Firefox. As @Condobloke says above, all you have to do is enable DRM. With that being said, there are a few things that could get in the way. VPNs can block ports and streaming services don't like them. If you use one, try turning it off and see if that resolves it. Browser addons can cause issues as well, disable all of them and see if you still have the same issues. I used to use UserAgent Switcher and had to stop because of similar issues.
 

ReginaBob

New Member
Last time I tried,Netflix didn't work on Chromium.It does work fine on Chrome.,right out of the box ,no tweaking neccessary.
 

Staff online

Members online


Latest posts

Top