• We did not send an email asking for donations - please read this post.

HP Laserjet m140we Setup Problems

Nik-Ken-Bah

Well-Known Member
Joined
Sep 9, 2019
Messages
719
Reaction score
687
Credits
2,584
@Condobloke
Help!!!
I just bought a new HP LaserJet m140we.
I installed it on my Linux Mint 20.3 una.
It recognizes the printer.

View attachment 13534

However, it will not even print a test page.
I have an idea that there is a driver missing somewhere along the way.
I do get this message:
View attachment 13535

I don't know where to find the meaning of the error (5012).
I am confused.
Thanks in advance for your help. (Or anyone else who might help).
OG TC
This link my help you as it is HP device manager that I use plus going of memory since it is while since I set this up on my computer
Go to the downloads and you can down load it from there. Also just browser around the site to familiarise yourself with it you may encounter things that are useful to remember for ron later on that is.
 


OP
charlie.corder

charlie.corder

Active Member
Joined
May 25, 2019
Messages
70
Reaction score
180
Credits
665
May have something for you, Charlie.

I ran a Google search with keywords

linux driver HP LaserJet m140we 3.21.10

then confined the search to linux results

"linux" driver HP LaserJet m140we 3.21.10

That lead me to a page

https://ubuntuhandbook.org/index.php/2021/11/hplip-3-21-10-debian-11-zorin-os-support/

and within that to a link



From that page, you can see 3.21.10 about 5 down, so go for that?

See how you go and let us know.

Cheers

Chris
Chris,
I found all the things you mentioned.
Downloaded them and installed them according to the directions.
Results so far are the same.
Next I went to another desktop I have and installed LM 19:3, thinking that it has been around a while and still has support until 2023. Downloaded and installed the current 3.22.6 per their instructions. No success.
The printer will still print what you see in #12 above, but will not print even a test page.
I can understand why it prints those two items in #12. Those are already part of the printer itself, it does not have need of any drivers.
I will keep on poking around the internet and LM and HP to see if I can find anything that will help.
Many thanks to all you folks for your concern for me.
OG
PS I will post back here as soon as I have any good news to report.
 
Joined
Nov 30, 2020
Messages
3
Reaction score
0
Credits
24
charlie.corder wrote:


If you search online for "Device Communication Error (5012) HP" there's quite a few proposals.
If you are running cups, what do the logs at /var/log/cups/error_log say? Are there any other logs information such as from journalctl, or in /var/log/syslog?
Code:
 journalctl -u cups.service -e
grep -i cups /var/log/syslog
less /var/log/cups/error_log

Further if cups is controlling the printer then, before trying a re-installation of the printer, you could try to cancel all jobs, power-cycle the printer and try again for a test page. To do this, bring up cups in a web browser with: http://localhost:631, then run through the menu: Administration -> Manage Printers -> <select printer> -> Maintenance -> Cancel All Jobs. Power-cycle, try and print the test page. Sometimes a printer can choke on jobs and this procedure has fixed it.

Edit: sorry I didn't see the output in post #12 before. Didn't appear on my screen. The problem is clear from the output.
Thank for the post , but another problem with cups that s no matching this one , but maybe , i tried to go console sudo mode. when i read the log i see 3 lines written that my access to http mode is denied by localhost. But localhoost is my machine , how is it possible , i am administratos in my account . use Elementary os. is it EOS protect mode ?
 

Attachments

  • Capture d’écran de 2022-11-04 15-17-49.png
    Capture d’écran de 2022-11-04 15-17-49.png
    169.6 KB · Views: 24
  • Capture d’écran de 2022-11-01 19-23-40.png
    Capture d’écran de 2022-11-01 19-23-40.png
    58.7 KB · Views: 8
Joined
Nov 30, 2020
Messages
3
Reaction score
0
Credits
24
the HP printer is ok and the linuxmint is ok . like I. it's use to works.
I have a Canon printer but does'n t print with EOS. But it should work. on another PC no problem with it.
I solve my cups problem. I have two admin accounts. when i use admin commands with cups , i should login admin.
then my only pb is the printer driver. but for your problem if you only want to print , because to scan after it's another software with other protocol. than no idea for you. try to use lpadmin...
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top