[how-to,nvidia] Force flipping to stay ON

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
603
Reaction score
483
Credits
3,137
Some programs, such as OBS Studio and SSR, tend to disable flipping which in turn disables VSync not only for the desktop but also for games. Which in turn causes breaking up graphics and low FPS in games. The problem is that newer versions of SSR disable flipping permanently. Older versions of that program only disabled it temporarily - while the program is running. But the newer ones don't enable it back. Suppose you checked the OpenGL setting "allow flipping" in the NVIDIA control panel but it remains disabled no matter what you do.
Steam also disables flipping, for unknown reasons, when it displays achievements. Even when the achievements hide, flipping remains OFF.
So here's the deal - you have to explicitly mention flipping in the config file of NVIDIA. Open terminal and type
Code:
sudo nvidia-xconfig
then press Enter. This will generate an 'xorg.conf' file in your system, since newer drivers (starting from 390, if I'm not mistaken) don't generate it automatically.

Note: nvidia-xconfig needs to write in the root file system. If you don't use the 'sudo' command, this how-to won't work!

Keep the terminal open and now type

Code:
sudo gedit /etc/X11/xorg.conf

where 'gedit' is your favorite editor. You can do it even with 'nano', if you prefer.

Find "Section "Device"" (it's almost at the end of the file) and add

Code:
Option "NoFlip" "false"

then save the file and restart the X server by pressing Ctrl+Alt+Backspace. Or reboot the whole system, if you like.

In case you wonder where to put that line, here's what my "Section "Device"" looks like:

Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    Option "NoFlip" "false"
EndSection
 


OP
rado84

rado84

Well-Known Member
Joined
Feb 25, 2019
Messages
603
Reaction score
483
Credits
3,137
A little addition to this topic - this addition only relates to Gnome-based DEs - Cinnamon, Budgie and if I'm not mistaken, also Deepin.
Soon after I posted the topic, nvidia released a driver version which somehow caused a major bug - flipping was permanently disabled. At least for me it is a major one because it didn't allow me to play my favorite native games in any Gnome-based DE. I spent 22 tormenting days with KDE - until Daniel Jackson planted the thought in my mind that the reason for the permanently disabled flipping is actually another nvidia option which contradicts with flipping - in Cinnamon, at least.
So the solution is simple - if you use forced full composition (FFC), disable it. In Cinnamon 4.2.3 there's no need for it. Until recently FFC was needed to prevent screen tearing when scrolling up and down in the web browser. However, in this moment I'm using Cinnamon 4.2.3 and FFC is not necessary - even with FFC disabled, there's no tearing at all!
If you already followed the instruction in my previous post, simply disable FFC and flipping (VSync) will return in your linux games, such as Euro Truck Simulator 2 which highly depends on VSync for a smooth ride. ;)
 

kibasnowpaw

Active Member
Joined
Jan 2, 2022
Messages
188
Reaction score
103
Credits
1,543
i think it funny i felled over this post but hey always here to learn a little more.
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Staff online

Members online


Top