• We did not send an email asking for donations - please read this post.

How to hide a "Broken" file from Synaptic [SOLVED]

frazelle09

New Member
Joined
Apr 14, 2021
Messages
6
Reaction score
0
Credits
62
Am trying to install and use the two or three [email protected] files in order to continue folding after a hard disk reinstall of the OS.

i can download the files and use rpm -i --nodeps [email protected] and when i go to Synaptic and hit Reload, it complains that the file is "Broken".

Note: These files are not in our repos because the dev who maintains this OS - PCLinuxOS - does not like the idea of [email protected] running on computers because they use a lot of electricity. ??¿¿¿

When i had this problem the first time - a couple of years ago and on the now defunct hard disk, i kinda remember that there was a command line that i could use to "hide" or make Synaptic not consider that file as broken but can't find the command. i thought it might be the flag --justdb but if i install the file with this flag, Synaptic still complains.

Have a great afternoon and please stay safe! :)
 


OP
frazelle09

frazelle09

New Member
Joined
Apr 14, 2021
Messages
6
Reaction score
0
Credits
62
Dear fred> This command as root seemed to solve the problem

rpm -e --justdb fahclient-7.6.21-1.x86_64

rpm -e --justdb fahviewer-7.6.21-1.x86_64

Note that it does not include the .rpm extension. Make sure that Synaptic is closed as well.

¡Folding again!

Have a super afternoon and be happy! :)
 
Last edited:

kc1di

Well-Known Member
Joined
May 14, 2021
Messages
1,263
Reaction score
1,044
Credits
9,058
Am trying to install and use the two or three [email protected] files in order to continue folding after a hard disk reinstall of the OS.

i can download the files and use rpm -i --nodeps [email protected] and when i go to Synaptic and hit Reload, it complains that the file is "Broken".

Note: These files are not in our repos because the dev who maintains this OS - PCLinuxOS - does not like the idea of [email protected] running on computers because they use a lot of electricity. ??¿¿¿

When i had this problem the first time - a couple of years ago and on the now defunct hard disk, i kinda remember that there was a command line that i could use to "hide" or make Synaptic not consider that file as broken but can't find the command. i thought it might be the flag --justdb but if i install the file with this flag, Synaptic still complains.

Have a great afternoon and please stay safe! :)
I take it your using pclinuxos. Did you try the fix broken in synaptic? It's found under the edit tag.
 
OP
frazelle09

frazelle09

New Member
Joined
Apr 14, 2021
Messages
6
Reaction score
0
Credits
62
Good morning, kc1di! Just created a new install a while back and of course the [email protected] files are again recognized as " broken" by Synaptic. i'm going to use the the solution posted above but just wanted to let you know that when we use the "Edit" and "Fix" buttons in Synaptic, Synaptic "fixes" the issue by deleting the files - lol. So, we've stopped using that "solution".

Thanks for replying and please have a wonderful day! :)
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top