How to fix error: no such device: bootloader

Rupert Bogensperger

New Member
Credits
0


Hi!

I have a problem after i tried install a OS(Debian) on a USB device. Now if i start the ps, only the rescue mode of grub starts.

I tried to run some commands which i found in the web but it don't work as i want it.

The commands where like ls, but it allways says: "Filesystem is unknown". I don't have any idea to do right now. Please help me!

I have a Notebook with a SSD and a HDD.
 


arochester

Moderator
Staff member
Gold Supporter
Credits
1,807
Did you install with your notebook on USB? Is that a USB stick or an external USB drive?

Now if i start the ps
Ps? Is that a PlayStation? Which PlayStation?

How is the USB device formatted?
 
Credits
25
Just a minor point that may help .
The ls command in grub rescue needs a forward slash at the end , for example
ls (hd0)/

Repeat it for hd1 and hd2 .
You will know when you get the right one because it will display a line that includes " lost+found " ,
among other bit's and pieces
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
4,771
I'm guessing that "ps" is a typo for OS.

Wizard
 


Members online


Top