How to connect to router to configure it.

DRCars

New Member
Credits
41
Rather new to linux. Please excuse my ignorance,

When I connect a router that I want to configure direct to the LAN (ethernet) port I get the message "Activation of network connection failed". This Linksys router (wrt54G) has DD-WRT on it. I configured it with a windows PC and thought I would learn how to do it on linux. I really would like to dump windows. I have succesfully connected linux to an Asus router but it was setup as a gateway. The Linksys is set as an Access Point and therefore is not set to handle DHCP.

On Windows machine this is pretty straight-forward. Just connect to the router LAN port (not WAN) and the PC ethernet port. They negotiate and then I can use a browser to access the router via it's configured IP address (192.168.1.3)

I have been in NetworkManager trying to figure how I can do this on Linux Mint with no luck so far. It seems that it assumes that there is a configured internet gateway connection on the other end of the ethernet cable. What am I missing here? What settings might I need to make and where?

Your help would be appreciated. I haven't had much luck searching how to do this on the internet (except for how to do it in windows).
 


DRCars

New Member
Credits
41
Nevermind, I figured it out. Since this is the first topic I see when searching the internet for "How to connect to router to configure it" maybe I should post the solution.

With PC connected to LAN (not WAN) port on router via ethernet cable:

Use NetworkManager on LInux Mint 20: Left lick on the network icon in the main panel. Mine was a wireless signal icon. You can also access it by searching "network" in the apps menu. Click on Network Connections. Then under Ethernet double-click that connection (mine was "Auto Ethernet"). On Ethernet tab on next screen choose the device. Mine was "enp3s0 (40:B0:34:BF:49:90)".

The next steps held the solution to my problem. On the IPv4 tab select method as "manual" then make up an address in same range as the router (I used 192.168.1.200). Put in the subnet mask of the router (mine was 255.255.255.0). And, lastly, put in the ip address of the router as the gateway (mine was 192.168.1.3). I also put in a DNS server (8.8.8.8 google) but I don't think that was necessary.

Finally, click Save close the windows and use the network icon (left click) and checkmark the wired network choice (if not automatic). Voila!
 
Last edited:

Alexzee

Well-Known Member
Credits
7,849
Do you have the manual to the Linksys router?

IF not maybe try to find the manual online.

Have you tried going through the settings in the Linksys router and see 'if' it can be set up for DHCP?

What version and desktop environment of Linux Mint are you running?

Maybe this will help?
 

DRCars

New Member
Credits
41
Thanks for the reply.

It wasn't a problem with either the router or the PC. Was a learning curve problem. I described what I finally learned 2 posts above this one.
 

Alexzee

Well-Known Member
Credits
7,849
Thanks for the reply.

It wasn't a problem with either the router or the PC. Was a learning curve problem. I described what I finally learned 2 posts above this one.
You're welcome.

Glad to hear you got it working.

Enjoy your Linux Mint and have a good week ahead!
 
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Members online


Top