• We had to restore from a backup today after a failed software update. Backup was from 0000 EDT and restored it at 0800 EDT so we lost about 8hrs. Today is 07/20/2024. More info here.

How to change laptop power management from powersave to performance

cedb

New Member
Joined
Nov 8, 2023
Messages
3
Reaction score
1
Credits
43
Hi,
I have a pcspecialist laptop with i7-1360P 32 Gb ram and 2Tb 990 pro nvm ssd and I have installed dual boot on this laptop, with Windows 11 pro and Ubuntu 22.04 LTS.
When I run passmark performance 11 test with ubuntu I get 13 000 score for CPU running it with Ubuntu where as I get 20800 running the same test with Windows 11.
The difference is so important that I guess the laptop performance is deliberately diminished by linux but don't know how to get the full performance of it.
In Settings menu, I have set Power mode to Performance, but if I type in a terminal cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor, I only get powersave as result.
I have tried to set /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor to performance but it doesn't work, sys/devices/system/cpu/cpu*/cpufreq/scaling_governor all stay equal to powersave
I've also tried slimbook software,and to modify /etc/default/grub without success ( adding
GRUB_CMDLINE_LINUX="cpufreq.default_governor=performance" , updating with update-grub and rebooting )
The passmark score stays the same between 13000 and 15000 and cmd :
cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor
still results only to powersave for each cpu core.
Any ideas ?
Thx a lot !
 


Not being familiar with passmark benchmarking, the question arises: can linux do at some smaller value what MS does at a much greater value?

The sort of test that reflects upon this is would be running the same cpu intensive process on both systems to determine which performs better. If it were two linux systems, one could run a cpu intensive process such as compiling a kernel on both systems and see the difference measured in time perhaps. On MS, I can't say what might be a correspondingly appropriate test.

To change the governor, the following has been successful here.

With the package: cpufrequtils installed, see what's available:
Code:
# cpufreq-info
<snip>
available cpufreq governors: performance, powersave
<snip>
or
Code:
# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors

To change to performance governor:
Code:
# cpufreq-set -c 0 -g performance
where -c 0 refers to the cpu no. 0, (the first cpu) and -g refers to the new governor to be set. Any or all cpus can be set.

It's also possible to see the range of available frequencies allowed:
Code:
# cpufreq-info -l
800000 3600000

With that info the user can set a frequency of choice between the allowed values for the cpu with commands such as the following where -d specifies the minimum frequency and, -u the maximum frequency and -c the cpu being set:
Code:
# cpufreq-set -c 0 -d <FREQ>
# cpufreq-set -c 0 -u <FREQ>

From the cpufreq-set manpage:
FREQuencies can be passed in Hz, kHz (default), MHz, GHz, or THz by postfixing the value with the wanted unit name, without any space
 
Hi
Thanks for your answer !
Up to now I haven't succeed to set scaling_governor to performance, with or without intel_pstate active.
Now, I am running intel_pstate passive and all scaling governors are ondemand.
if I use cpufreq-set command to set, for instance cpu0 scaling governor to performance, and check after that the setting has been done, it is done but around 4 to 5 seconds after it goes back to ondemand. There's some other process, daemon or maybe just the intel_pstate driver that sets back the scaling governor to ondemand.
When intel_pstate was active, I had the same issue when setting scaling governor to performance, it went back to powersave within a few seconds :-(
 
Hi,
Thanks for your help
I have found the daemon that was resetting my choices concerning driver_governor. It was tccd , a daemon part of Tuxedo control center. I had installed this control center in order to try to have a better control over the fans, it didn't work actually.

Thus now, I have set scaling_governor to performance and I get a slight improvement as the benchmark score is 16000, actually still quite far from windows score around 21 000, it's 25% less performance, not that good...
Running turbostat, I get the following results during test with scaling_governor set to performance :

Code:
    root@kakak:/home/cedric# sudo turbostat --quiet --Summary --show Busy%,Bzy_MHz,IRQ,PkgWatt,PkgTmp,RAMWatt,GFXWatt,CorWatt --interval 15
Busy%    Bzy_MHz    IRQ    PkgTmp    PkgWatt    CorWatt    GFXWatt    RAMWatt
0.63    1001    21451    56    5.21    2.16    0.00    0.00
0.65    1043    21507    56    5.18    2.16    0.00    0.00
79.76    3261    117029    74    31.77    28.60    0.00    0.00
89.74    1926    73125    77    17.92    12.52    0.00    0.00
95.25    1940    75463    81    18.66    14.06    0.00    0.00
63.52    1954    55714    72    13.85    10.38    0.00    0.00
87.20    1910    69199    85    18.98    14.09    0.00    0.00
17.41    1648    31664    70    7.42    4.06    0.00    0.00
0.59    954    20488    68    5.67    2.43    0.00    0.00
The 2 first and last lines where displayed before and after the test was run.
The max cpu frequency is 5 GHz and the fan is unhearable during the whole test !
There seem to be some place left for some performance improvements, frequency upraisal as the cpu temperature is not that high, but how ?
 

Members online


Top