Hiya Everybody

G

golfngeezer

Guest
Glad to be able to join the Linux community. Am very new to Linux, and at 63yo, somewhat slow to understand all the computer lingo. But, I am certainly looking forward to getting Windows out of my life. ;)
 


A

atanere

Guest
Welcome! The lingo can be tough at first, but a quick Google will probably always give you an explanation. No one is a total expert either, so just jump in, have fun, and learn as you go.

Cheers!
 
G

golfngeezer

Guest
tyvm for the welcome. been and is a lot of fun. and google and the forums are a great help. very nice to get away from Windows. the only thing i cannot seem to find out, is how to get my second hd (nsft ?) to mount so i don't lose access to all my family pics and vids. seems everyone has a different way of doing. and I don't want to lose them by doing something stupid. but i will keep researching till someone tells a way i can grasp. ;)
 
A

atanere

Guest
tyvm for the welcome. been and is a lot of fun. and google and the forums are a great help. very nice to get away from Windows. the only thing i cannot seem to find out, is how to get my second hd (nsft ?) to mount so i don't lose access to all my family pics and vids. seems everyone has a different way of doing. and I don't want to lose them by doing something stupid. but i will keep researching till someone tells a way i can grasp. ;)
What distro are you using? Linux recognizes the ntfs drives just fine, and all the distros should be similar. Open your file manager and you probably have a "pane" on the left side of the window. Your drive may have a name... for example, mine shows "HP" which is my Windows ntfs partition. In my case, I single-click on HP, and then I get a window popup requiring a password (your root password, if it is different from your user password). That opens up the whole Windows drive for me in the right-side pane now, and I can browse to Users/myusername/Pictures or wherever to find photos, videos, etc. After you're done viewing or copying, go back to the left pane, right-click on the drive name, and choose "unmount volume" to break the connection to that drive or partition.

You ALWAYS want to unmount cleanly or you could have data corruption. This is especially true with thumb drives or external hard drives that you might plug in. With those, you might have an option to "safely eject" which is fine also. If in doubt, or if your systems does not want to eject properly (it might say device still in use)... you can also safely shut down the computer if you are sure that all your transfers have been completed.

Clear as mud? :confused::D
 
G

golfngeezer

Guest
i believe i understand (?) I did a clean install, so i don't believe i have partitions. the left pane lists:
'My Computer' with home, desktop, documents, blah blah blah listed under. Then 'Devices'. the only thing listed under that is '500 gb volume'. If i left click it gives me a error page. if i right click, it gives me several choices. 'Open' 'Open in new window' 'Open in new tab' 'Mount' every one give me the error page again. Here is the error page it gives me:


Error mounting /dev/sda2 at /media/geezer/569E15479E152153: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda2" "/media/geezer/569E15479E152153"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda2': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

I believe that paragraph is littered with french, russian, or some alien language. lol windows is not on my pc now, so i cannot shut windows down, hibernate or fast restart. So it seems like i need to 'ro' mount???

what is your diagnosis? tyvm for ur time and patience.
 
G

golfngeezer

Guest
under 'My Computer' is 'File System' and in that is
/initrd.img (shortcut) with quite a few choices like 'Open with disc image mounter'

and this shortcut /vmlinuz with a windows logo
with choices like 'open with archive manager.

does this help?
 
G

golfngeezer

Guest
very interesting. sounds like a more refined version of linux. and i see that i can run it in ram off the disc or thumbdrive, without affecting Mint on my hd. but wonder if it will recognize my second drive (windows). gonna have to do some more reading on this and give this some serious thought. tyvm for the info.
 
A

atanere

Guest
Well, if MX-16 were magical, it might fix this problem. But it isn't.

@golfngeezer -- you do need to proceed carefully. You may have already lost your photos/videos, but I can't tell yet. If you told Linux to do a "clean install" or something like that, it may have erased everything from your previous Windows installation. But that may not be what you actually did, or else I don't think you would now see that 500GB drive under Devices.

You say Windows is not on your PC now, but the error is definitely telling you that your 500GB drive was left in a hibernated state. You also called this your "2nd HD"... which I want to try to confirm. The 500GB is a 2nd physical drive inside your computer... are you sure? The error report makes me think that it is not a 2nd drive, but is another partition on the same drive.

Oops, you just posted... good! I see now that you're running Mint. I'll be back in a bit....

Cheers!
 
C

Crippled

Guest
very interesting. sounds like a more refined version of linux. and i see that i can run it in ram off the disc or thumbdrive, without affecting Mint on my hd. but wonder if it will recognize my second drive (windows). gonna have to do some more reading on this and give this some serious thought. tyvm for the info.
There is a Disk Manger tool in MX-16 for that. The problem is you would need to format a partition in NTFS or FAT depending on what it was formatted as in Windows in order for MX-16 or any Linux to see it. I recommend you ask on the MX forum for clarification.
 
A

atanere

Guest
The problem you're having is very well described in this article:
https://www.howtogeek.com/236807/how-to-mount-your-windows-10-or-8-system-drive-on-linux/

But since you seem to have deleted Windows, you can skip all the Windows-based solutions. Scroll down to the bottom and begin with the section, "Have Linux Remove the Hiberfile.sys File"

Mint has the same Disk Management tool as shown for Ubuntu in the article. Click your Mint start menu, type disk, and the application should appear for you to click and run (Disks - Manage Drives and Media). Following the article, look at the diagram of "Volumes" on the right and click on the 500GB NTFS. Click the little "gear" icon below the diagram, and choose Edit Mount Options. Again following the article, you'll have to switch off the Automatic Mount Options so you can add ,remove_hyberfile as shown (don't forget the comma). You'll be prompted for your password to make these changes.

You may have access to the 500GB drive from your file manager immediately, but if not, then reboot and try to access it again. It should be available to you, and you can look to see if your data is still there or not.

Good luck!
 
G

golfngeezer

Guest
real easy to follow that, but still no mount. but i do have another thing in 'my computer'.
computer:///A4821374821349E6.volume which gives me the following error:

mount: only root can mount /dev/disk/by-uuid/A4821374821349E6 on /mnt/A4821374821349E6

this is turning into a big pain. sorry everyone
 
A

atanere

Guest
Not a pain... but it is a challenge! :D

I don't know what computer:/// is representing, but I don't think it is part of the issue either, nor the other things, initrd and vmlinuz shortcuts. But they do make me wonder how you installed Mint. Do you recall when you installed if you checked a box for "LVM" (Logical Volume Management)? I'm not familiar with LVM.

I'm surprised the article's directions did not work. But in spite of @Crippled 's misgivings about the command line, I'd suggest you try to do what your error said we could try... lets try to mount the 500GB drive as read-only with just 2 commands. If successful, you would be able to browse the drive to see if there is any data or if LInux wiped it clean. If the Windows folders are still there, you could find your photos, etc and COPY them to your Linux side (if you have enough free hard drive space... but one thing at a time). But in read-only mode you cannot "move" or "delete" anything on that drive. Its just a reconnaissance mission, and maybe rescue later.

First, open your File Manager. Click the UP ARROW (near the top, just below all the Menu Options) until you can't click it anymore, and you'll get the screen showing many folders... bin, boot, cdrom, and so on. For this test, double click the mnt folder. It is probably empty.

Open your Terminal with CNTL+ALT+T

1. Copy and paste this into the terminal: sudo mkdir /mnt/win (hit enter and then enter your password when prompted). You should see the folder named win appear in your file manager immediately. Yes?

2. Copy and paste this into the terminal: sudo mount -o ro /dev/sda2 /mnt/win (and hit enter)

3. Double-click the win folder and see if there is anything there! If so, are there Windows and Users folders? If so, look in Users, then your Username, then Music... if that is where you stored your stuff. Yes?

When finished with this session, you should unmount the partition too. So do this before you close the Terminal:
sudo umount /mnt/win (you can double check in the file manager and see that it is no longer accessible).

OK, lets see if you managed all this... or if you even attempted it. If the recon worked, lets see if you have anything there to rescue.
 
G

golfngeezer

Guest
just to fill in some blanks. it is a 2nd physical 500gb hd. i physically disconnected it before the clean install fearing it might clean everything. so the installation didn't wipe any data.

went to file manger, clicked up, found mnt folder. it wasn't empty. had folder named /mnt/A4821374821349E6 in it. that folder was empty. closed that folder so i was back to the page with lots of folders including mnt. opened terminal. put in
sudo mkdir /mnt/win was prompted for password. would not let me put in password. tried typing and copy/paste and neither way would it let me enter password.

are we having fun yet?
 
A

atanere

Guest
Heck yeah... I'm having fun! But will be more fun when it's solved, and we all learn something from it. :D

About passwords... do you know that they do not echo back any characters when you type them in terminal? Not even stars, nothing. You just have to type it correctly and hit enter. The most common mistake then is that the CAPS lock is on. Passwords are case sensitive. Its okay that there was another folder in /mnt... that was the computer:/// you mentioned before. If you follow the "mkdir" command and enter the password, there is nothing to stop the new folder "win" from being created, so be in the /mnt folder and you'll see it appear. There is nothing really to stop the read-only mount of your 500GB drive either (unless you don't have it plugged in! LOL).

If you didn't know that about passwords, you can try to mount your other drive again. Its good to know that it is a physical drive, and you were definitely smart to remove it before installing Linux. Unfortunately you didn't know the Windows often does not really shut down, and it only hibernates instead. This makes people think it boots faster, which is sort of true, but its a trick. This has caused a lot of trouble for Linux users before.

Hopefully you can get into this drive now and access the data you want to save. Yes?
 
G

golfngeezer

Guest
okay. i think we are getting closer. lol put in sudo mkdir /mnt/win. enter, password
then put in sudo mount -o ro /dev/sda2/mnt/win enter, password
got= mount: can't find /dev/sda2/mnt/win in /etc/fstab

i'm gonna leave everthing open because don't know if closing them will cause a problem

i await further instruction
the drive still shows in 'my computer'
and gives the same error
and the win folder is in the mnt folder
 
Last edited:
A

atanere

Guest
You missed a "space"... here it is again

sudo mount -o ro /dev/sda2 /mnt/win (space between /dev/sda2 and /mnt/win)

It should get you in there!
 
A

atanere

Guest
After you get this command entered, browse with your file manager (UP, UP, UP to the top again), and double-click the mnt folder, then double-click the win folder. That's where you will see your 500GB drive right now. The one in My Computer will probably still not work.
 
G

golfngeezer

Guest
it is open. i'll see if anything is missing, and let ya know
so i unmount before i close the terminal
and when i want to reopen
create the win folder and the do the ro mount again?

ty so very much
 

Members online


Latest posts

Top