help with sound on my gateway nv55c with linux 10

K

katie

Guest
today i had to fix some problems with my computer and ended up reinstalling linux 10...i have a gateway nv55c. i knew once i reinstalled i would have to find my sound drivers, well i have done this before and seems now cant find the post that i found the answer on. soooo, i have messed with the ALSA and still no luck i have tried and tried for hours today and i just cant seem to figure it out again! please if you know my solution let me know! (i dont have the capabilities to download 12 so im stuck with 10 still) lol
 


OP
A

Akendo

Guest
What do you mean with Linux 10? Do you mean mint?

Anyhow, can you give us some information about your Sound Hardware in deep? Try this:
Code:
hwinfo --sound
What kernel do you run? Please make sure you have the alsa sound daemon running.
Code:
/etc/init.d/alsasound status

Do you may have PulseAudio enabled?

so far
akendo
 
OP
K

katie

Guest
What do you mean with Linux 10? Do you mean mint?

Anyhow, can you give us some information about your Sound Hardware in deep? Try this:
Code:
hwinfo --sound
What kernel do you run? Please make sure you have the alsa sound daemon running.
Code:
/etc/init.d/alsasound status

Do you may have PulseAudio enabled?

so far
akendo



when i type the first one into terminal this is what it tells me,
hwinfo --sound
> hal.1: read hal dataprocess 3381: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
11: PCI 1b.0: 0403 Audio device
[Created at pci.318]
Unique ID: u1Nb.V+xRVOdS_1D
SysFS ID: /devices/pci0000:00/0000:00:1b.0
SysFS BusID: 0000:00:1b.0
Hardware Class: sound
Model: "Intel Ibex Peak High Definition Audio"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x3b56 "Ibex Peak High Definition Audio"
SubVendor: pci 0x1025 "Acer Incorporated [ALI]"
SubDevice: pci 0x0487
Revision: 0x05
Memory Range: 0xb4400000-0xb4403fff (rw,non-prefetchable)
IRQ: 10 (no events)
Module Alias: "pci:v00008086d00003B56sv00001025sd00000487bc04sc03i00"
Driver Info #0:
Driver Status: snd_hda_intel is active
Driver Activation Cmd: "modprobe snd_hda_intel"
Config Status: cfg=new, avail=yes, need=no, active=unknown

when i type in the second one this is what it says,
/etc/init.d/alsasound status
bash: /etc/init.d/alsasound: No such file or directory


this makes no sense i installed everything for alsa yesterday, and yes i am running linux mint 10. thanks!
 
OP
A

Akendo

Guest
So when your runnung mint you should be able to upgrade easly to the next realase. Try this or this. The first is the Version with the GUI. Make sure you have a backup of your system.

Else you can go on. As you can see, is there a kernel module for the Sound driver. Try to find it inside of the loaded module list:
Code:
lsmod|grep  snd_hda_inte
When nothing is displayed use the command:
Code:
modprobe snd_hda_inte # You have to be root or use sudo before

Maybe that will fix your sound problem, but i guess you have to go a bit more advanced.

so far
akendo

PS: Have you check alsamixer that you have all sounds stream no muted?
 
OP
K

katie

Guest
$ lsmod|grep snd_hda_inte
snd_hda_intel 37964 1
snd_hda_codec 100919 1 snd_hda_intel
snd_pcm 89104 2 snd_hda_intel,snd_hda_codec
snd 64117 8 snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
snd_page_alloc 8588 2 snd_hda_intel,snd_pcm


this is what it shows for the first command, i know its my drivers cuz the last time i put mint on here it was the same version and i had to find the drivers, the thread i found them at is gone now :( hopefully i can get something else figured out because my internet isnt fast enough to dl the newest linux :(


sudo modprobe snd_hda_inte
[sudo] password for katie:
FATAL: Module snd_hda_inte not found.


this is what i get on the second command :(
 
Top