Help an Old Fart . . .

johnnyb

New Member
Credits
70
Been getting an ERROR msg on a fresh install of Mint 19.3, not ready to jump into 'the latest and greatest' like me 19.3 --- info follow:

dpkg: error processing package shim-signed (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
grub-efi-amd64-signed
shim-signed

Here is the system it is on:

System: Host: Jacinta Kernel: 5.4.0-42-generic x86_64 bits: 64 compiler: gcc v: 7.5.0
Desktop: Cinnamon 4.4.8 wm: muffin dm: LightDM Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine: Type: Laptop System: HP product: HP Laptop 14-cm0xxx v: N/A serial: Chassis:
type: 10 serial:
Mobo: HP model: 84A0 v: 83.16 serial: <filter> UEFI: AMI v: F.12 date: 08/28/2018

has anyone [?] seen this one, new to me, D'oh!!! Could use any and all info from all... Tks in advance Johnny B
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,153
You ARE an old fart, if you have seen Ralph Bakshi's Wizards, 1977 - I have :)

G'day @johnnyb and welcome to linux.org

If you have not tried these, try them and please report back to us (my comments prefaced by a #):

Code:
sudo dpkg --configure -a

# that's a double dash before configure, single before a

#if no joy, then

sudo apt-get install -f

# to fix broken packages, followed again by

sudo dpkg --configure -a
Cheers

Chris Turner
wizardfromoz
 

johnnyb

New Member
Credits
70
You ARE an old fart, if you have seen Ralph Bakshi's Wizards, 1977 - I have :)

G'day @johnnyb and welcome to linux.org

If you have not tried these, try them and please report back to us (my comments prefaced by a #):

Code:
sudo dpkg --configure -a

# that's a double dash before configure, single before a

#if no joy, then

sudo apt-get install -f

# to fix broken packages, followed again by

sudo dpkg --configure -a
Cheers

Chris Turner
wizardfromoz
Also saw Wizards in 1974 loved it and have it in me archive
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
6,153
OK, thanks for that.

This is starting to sound like your Linux is not recognising your /boot/efi partition properly, so I need you to give me the output for some more commands.

See if you can put them in code boxes as I did above.

On your Reply Pane toolbar right of the smiley face are three periods (actually ellipses) and a down elevator button - click that and find Code and click, then copy paste the output in the popup box.

If you can do 3 individual boxes (separated by a couple of lines between, that will help our reading of it.

They don't need sudo unless mentioned.

Code:
blkid
and

Code:
cat /etc/fstab
and

Code:
sudo fdisk -l


# that's a lowercase L - Wizard
Also, was there any error output prior to

dpkg: error processing package shim-signed (--configure):
... that you haven't given us?

TIA (thanks in advance).

Wizard

BTW - NOT sorry I welcomed you, but sorry I had not noticed you have been a member for 6 months :)
 


Members online


Top