HDMI not working with Nvidia GTX1050 on Ubuntu 18.04

nicoroma

New Member
Credits
0
I have a Lenovo Legion Y530 with a integrated Intel graphics board and a dedicated Nvidia GTX1050 graphic board.
I installed Ubuntu 18.04 (followed the Lenovo guide) and installed the drivers for both graphic boards, Nvidia is using the 430 drivers which are the latest.

I'v read that the HDMI port is wired directly to the Nvidia GPU and for that reason the HDMI por will work only if you are using the Nvidia GPU option. The thing is that is the HDMI port is now working at all.
I've been trying to solve this for a few day now with out success, there a few guides and I still can not put all the pieces together. I contacted Nvidia but the said that they don't provide support (shrug).

I read about xRandR but I don't see the HDMI port in the output. I'm using Prime in order to switch between GPUs.
Also read about bumblebee but I'm not sure about that.

Can some one guide me through this with reading material or telling me which are the steps in order to troubleshoot this issue.
What thing should I double check?
What should I see in the outputs?
Can I send a test singal to the HDMI port?
FYI : The HDMI wire and the external monitor work fine I have tested them the with a Macbook.

Thanks in advanced

Code:
# xRandR output
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.16*+  60.01    59.97    59.96    59.93
   1680x1050     59.95    59.88
   1600x1024     60.17
   1400x1050     59.98
   1600x900      59.99    59.94    59.95    59.82
   1280x1024     60.02
   1440x900      59.89
   1400x900      59.96    59.88
   1280x960      60.00
   1440x810      60.00    59.97
   1368x768      59.88    59.85
   1360x768      59.80    59.96
   1280x800      59.99    59.97    59.81    59.91
   1152x864      60.00
   1280x720      60.00    59.99    59.86    59.74
   1024x768      60.04    60.00
   960x720       60.00
   928x696       60.05
   896x672       60.01
   1024x576      59.95    59.96    59.90    59.82
   960x600       59.93    60.00
   960x540       59.96    59.99    59.63    59.82
   800x600       60.00    60.32    56.25
   840x525       60.01    59.88
   864x486       59.92    59.57
   800x512       60.17
   700x525       59.98
   800x450       59.95    59.82
   640x512       60.02
   720x450       59.89
   700x450       59.96    59.88
   640x480       60.00    59.94
   720x405       59.51    58.99
   684x384       59.88    59.85
   680x384       59.80    59.96
   640x400       59.88    59.98
   576x432       60.06
   640x360       59.86    59.83    59.84    59.32
   512x384       60.00
   512x288       60.00    59.92
   480x270       59.63    59.82
   400x300       60.32    56.34
   432x243       59.92    59.57
   320x240       60.05
   360x202       59.51    59.13
   320x180       59.84    59.32

# lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Device 3e9b
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

# lspci -vv -s 01:00.0
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Lenovo GP107M [GeForce GTX 1050 Mobile]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 255
        Region 0: Memory at a3000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at 90000000 (64-bit, prefetchable) [size=256M]
        Region 3: Memory at a0000000 (64-bit, prefetchable) [size=32M]
        Region 5: I/O ports at 5000 [disabled]
        Expansion ROM at a4000000 [disabled] [size=512K]
        Capabilities: <access denied>
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
 
Last edited:


TechnoJunky

Well-Known Member
Credits
304
What desktop are you running? Gnome? That's the default for Ubuntu. And unfortunately the only one that I find nearly impossible to work with in Settings options. I have the same video card, but I have a Dell and run Neon, which is based on 18.04 but uses KDE for the desktop. Every time I do a new install of Linux, I have to go into Settings, Display and Monitor, and setup my custom layout, setting the HDMI monitor as the Primary display and unchecking Enabled for the laptop monitor. After that, every time I plug the HDMI cable into the laptop, it automatically switches over. I have Gnome installed on a VM, but I could not find these settings in it. I don't know if it's just me not being familar with Gnome or if Gnome just doesn't have this feature baked in. I hope this helps or maybe someone who's more familiar with Gnome can use what I've provided to tell you where to find it.
 

nicoroma

New Member
Credits
0
I'm not really sure about that, it seems to be something deeper that the desktop settings, is true that Ubuntu gnome does not gives information about the displays, I haven't tried yet to use another distribution or desktop, but I will.
I'm really lost here, I wrote an email to Nvidia, and they answer that they don't give support for Linux users... awful. They aren't responsible for they drivers.
 

TechnoJunky

Well-Known Member
Credits
304
FYI, I can find the settings mentioned in Cinnamon, KDE, Mate and Xfce. I just can't find them in Gnome. All settings in Linux are in a file somewhere. Unfortunately I don't know what file controls this. Maybe someone else knows. You could always install one of the other desktops, make the setting change, then go back to Gnome.
 

JulienCC

Active Member
Credits
0
Hello,

I'm not sure i understood the problem well. You can't get the signal to go through your HDMI port ?

Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
I might be wrong but having at the same time the nouveau (free) and the nvidia (proprietary) drivers enabled at the same time can cause problems.

Can you give us the content of /var/log/Xorg or any file that looks alike ?

Since everything tends to be "automatic" nowaday it's hard to find working configurations examples but there's a high chance we will have to mess with xorg.conf to get your system working.
 

nicoroma

New Member
Credits
0
HI JulienCC, thanks for your reply.
This are the things that I was able to find, could you tell me if any of this is useful for you. Thanks!

@ /usr λ $ find . -name "xorg*"
./include/xorg
./share/bug/xorg
./share/man/man5/xorg.conf.d.5.gz
./share/man/man5/xorg.conf.5.gz
./share/doc/xserver-xorg-video-intel-hwe-18.04/xorg.conf
./share/doc/xorg-docs-core
./share/doc/keyboard-configuration/xorg.lst
./share/X11/xkb/rules/xorg.xml
./share/X11/xkb/rules/xorg
./share/X11/xkb/rules/xorg.lst
./share/X11/xorg.conf.d
./lib/python3/dist-packages/DistUpgrade/xorg_fix_proprietary.py
./lib/python3/dist-packages/DistUpgrade/__pycache__/xorg_fix_proprietary.cpython-36.pyc
./lib/python3/dist-packages/xkit/xorgparser.py
./lib/python3/dist-packages/xkit/__pycache__/xorgparser.cpython-36.pyc
./lib/x86_64-linux-gnu/pkgconfig/xorg-wacom.pc
./lib/x86_64-linux-gnu/nvidia-430/xorg
./lib/xorg

./share/X11/xorg.conf.d
10-amdgpu.conf 10-nvidia.conf 10-quirks.conf 10-radeon.conf 40-libinput.conf 70-wacom.conf
 

JulienCC

Active Member
Credits
0
Mh that's the xorg files in /usr directory.

Could you give us the output of :
Code:
$ cd /var/log/
$ ls -l
And do something like
Code:
$ cat /var/log/Xorg.0.log
I don't remember the xorg log file name that's why i can't give you a simple command to type. But i need the content of the xorg log file.
 

nicoroma

New Member
Credits
0
I'm sorry there is no Xorg file inside /var/log of any type, the most related file to this subject that i found is gpu-manager.log
 

JulienCC

Active Member
Credits
0
Mh i've seen somewhere that the log might be at "~/.local/share/xorg/".
Maybe Ubuntu isn't using Xorg and switched to wayland.

What's the output of
Code:
$ ps -A | grep -i xorg
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Credits
2,003
exaclty the same issue...
Maybe ... maybe not ... you are running a different flavour of Ubuntu (Kubuntu used KDE Desktop Environment)
, with a different version (19.10 cf 18.04) on a different computer (Samsung cf Lenovo) :)



(Wizard appears in a puff of smoke)

G'day @wowbagger and welcome to linux.org :D

I will likely "carve off" your Post above and give you a separate Thread under your userid, with a link to this Thread.

While we have not heard from the OP (original poster) for 3 weeks, there was a period prior to that of 7 weeks where he was absent. If he returns, this Thread will get confusing as to whom is being helped.

In the meantime, if we adopt the approach taken by @JulienCC above, we will be looking for

Xorg.0.log

... so you can prepare for that with the output of the command at Terminal/Konsole

Code:
locate -Ai xorg.0.log
It, and the previous (old) log may appear in /var/log in some cases, and in

"~/.local/share/xorg/"

in other cases.

The reason this differs is to do with the DM (Display Manager) used by different DEs (Desktop Environment)s.

On Kubuntu you will likely be using kdm, the KDE Display Manager.

In case I get run over by a Mac truck in the meantime (hope not), if we need to establish your DM, we can use

Code:
systemctl status display-manager
... top few lines is all that is needed.

OR

Code:
grep '/usr/s\?bin' /etc/systemd/system/display-manager.service
With different Distros, some store it in /usr/bin , others in /usr/sbin - the above will cover both.

Cheers

Chris Turner
wizardfromoz
 

fifinonz

New Member
Credits
0
This worked for me:
1.First check the recommended nvidia driver `sudo ubuntu-drivers devices`

2. Install the recommended driver, in my case
`sudo apt-get install nvidia-418`

3. Install nvidia-prime and nvidia-settings
`sudo apt-get install nvidia-prime nvidia-settings`

4. Reboot...and you will probably get into a login loop

5. If 4 above happens edit `/etc/default/grub` and look for the line `GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"`
remove the 'nomodeset'.

This was only necessary when installing Ubuntu. Now it's just causing your video drivers not to be loaded.

6. Run
`sudo update-grub`

7. Voila! HDMI works.

8. BUT....audio might not work! To fix this run
`pulseaudio -k`

9. Go to System Settings->Sound and set HDMI as default audio

Hope it helps somebody!

Links That helped me:



 


Members online


Latest posts

Top