• Important: We recently upgraded our forum software - please let us know if you run into any issues.

HDD configuration

CptCharis

Well-Known Member
Hello everybody!!!
It's a long time not see you.
So here we are again. I have an old external USB 1T Transcend and play with it for fun and education.
Yesterday I erased everything inside it and went one more step further. I override everything with
Code:
dd if=/dev/zero of=/dev/sdb status=progress
Once progress was completed, I partitioned my HDD with
Code:
fdisk /dev/sdb
I made the whole disk one partition with ext.4 file system,
and I can see my HDD with command
Code:
lsblk
and
Code:
fdisk -l
I reboot but HDD didn't mount automatically, as it used to be.
So I made a mount point with
Code:
mkdir mnt
and try to mount my HDD with
Code:
mount /dev/sdb /mnt
but I received the below warning msg
Code:
mount: wrong fs type, bad option , bad superblock on /dev/sdb, missing codepage or helper program, or other error

In some cases useful info is found in syslog - try dmesg | tair or so
What I miss guys ?
Thanks in advance
 


wizardfromoz

Super Moderator
Staff member
Gold Supporter
In some cases useful info is found in syslog - try dmesg | tair or so
Love that #2 slogan, got to get that :)

"dmesg | tail" not "tair" - small l L not a small r R.

Gotta fly mate but I'll be back (Arnold Schwarzenegger) tomorrow

Wiz
 

CptCharis

Well-Known Member
ok solved !!!
HDD should Reformatted as NTFS
I did it with fdisk tool but I read that even mkfs.ntfs could make the trick
 

Steve

New Member
Hello everybody!!!
It's a long time not see you.
So here we are again. I have an old external USB 1T Transcend and play with it for fun and education.
Yesterday I erased everything inside it and went one more step further. I override everything with
Code:
dd if=/dev/zero of=/dev/sdb status=progress
Once progress was completed, I partitioned my HDD with
Code:
fdisk /dev/sdb
I made the whole disk one partition with ext.4 file system,
and I can see my HDD with command
Code:
lsblk
and
Code:
fdisk -l
I reboot but HDD didn't mount automatically, as it used to be.
So I made a mount point with
Code:
mkdir mnt
and try to mount my HDD with
Code:
mount /dev/sdb /mnt
but I received the below warning msg
Code:
mount: wrong fs type, bad option , bad superblock on /dev/sdb, missing codepage or helper program, or other error

In some cases useful info is found in syslog - try dmesg | tair or so
What I miss guys ?
Thanks in advance
Forgot to format it.
Code:
mkfs.ext4 /dev/sdb1
NOTE: Untested code, didn't check, going offa' memory.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Dammit I missed all the fun :mad:

1. Goodonyer, Capta ;)

2. Hi Steve, you've been quiet for a year, nice to see you :p

3. Welcome to linux.org @RockDoctor :), and Ta (pron. "tar" Aussie for thanks) for getting in and helping so early. If you get a chance, swing by https://www.linux.org/forums/member-introductions.141/ and say "Hi", and you'll meet a few of The Gang. Plenty of us 60-plussers here, too.

Cheers all and

Avagudweegend

Chris Turner
wizardfromoz
 

Staff online

Members online



Top