Solved Getting Started I Hope.

Solved issue


changing password.....,,,open the Terminal


If you already know the root passwd....

start by typing into Terminal

su -
( you will be prompted for the root password here )

then type in
passwd xxxxx <<<<your pc's name

You will be prompted for a new password.
You will have to type it in twice.





If you have neither, it gets quite a bit more complicated.

If you have lost or forgotten it, maybe the guys in Alice will remember it....I hope so....It gets a bit complicated....
 
I know the password, the name, is that the model number?
 
The name will likely be your christian name...bill, william, will ....etc

When you open Terminal, it will look like mine. My christian name is brian.....so......
1717399627511.png

only type it in once ....always in lower case. (no capitals)
 
is that the model number
it's the name the system knows your computer by, it may be, make, make and model name, make and model number, or any other name you have given it examples such as Dell Insperon, Wallys computer, Acer zg5, .
if you can open the terminal it will be there.

I have several machines, so they all have individual names [example brian@the-answer-42]
 
When I go into Terminal I get this,

userd@userd-Aspire-TC-1760:


This is the reply I got from the lady in the computer shop,

Sorry for the delay, hearing back from the technician, the name may just be “user” as he didn’t set one in set up and the computer would set itself a default name.
should that not be the default name, type “ whoami “ at the command line. This will print your computer name on the next line.

userd@userd-Aspire-TC-1760:~$ whoami
userd
userd@userd-Aspire-TC-1760:~$ w
17:11:42 up 40 min, 1 user, load average: 0.93, 0.66, 0.57
USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT
userd tty7 :0 16:35 40:23 1:14 0.19s cinnamon-sessio
userd@userd-Aspire-TC-1760:~$
 
The root passwd is that the password I use to log on?
 
Whoever set it up has probably used the same password for both root [sudo] and user, again once you're up and running these can both be changed
 
The shop said that the logon password is password, when I set the computer up when I got home logged on OK, changed the password now log on no problem.
I put my password in Terminal it tells me,

"command not found"

So tried password and got this.

userd@userd-Aspire-TC-1760:~$ password
Command 'password' not found, did you mean:
command 'assword' from deb assword (0.12.2-1)
Try: apt install <deb name>

When I try assword I get this,

userd@userd-Aspire-TC-1760:~$ assword
Command 'assword' not found, but can be installed with:
apt install assword
Please ask your administrator.
userd@userd-Aspire-TC-1760:~$
 
To change your user Password do this...
1717753615691.png


Open the Terminal and type passwd...as shown above hit Enter... (passwd) is not a spelling mistake.

Type your current password...as shown above hit Enter.

Type your new password hit Enter and re-type it and hit Enter.

Password updated successfully...done.
1717753972533.gif
 
OP,

Don't take notice of what computer shops say...they know nothing about Linux.
1717802955328.gif


When you install Linux Mint...you're asked to create a User Name and a User Password as shown here from the Mint site...
1717801723545.png


The Password you create is for installing Software...Updates...setting up Timeshift and logging in...so remember it...better still write it down.
If you type the wrong Password...you'll get this...
1717802426109.png


To avoid confusion your Password is also called...User Password...Root Password but it's the same thing. It's easy to change the password you know but if you forget it...you can still create a new one but that's another story. Hope this helps.
1717803278943.gif
 
1. Click on menu....type in Software Manager.....click on that....give it a full minute to load
In there are approx 50,000 apps
They all install from there...NOT from the 'net...definitely not from the microsoft store...(all apps in the microsoft store are .exe files and will NOT run on Linux
if there were any apps you had on windows that you still need....have a look at : https://alternativeto.net/
There are thousands and thousands of apps there.....type in what you are looking for and the site will show alternatives that will run in Linux....you need to read it carefully because there are so many

Adblock plus and Privacy Badger are good. Download them from the browser.....do you use Firefox ?....if not tell us which one, please.

You do not need an antivirus.

Antivirus is useless
A virus or rootkit can't install itself in Linux unless you let it. In order to install itself on your computer, a virus or rootkit needs your password. And that it doesn't have.

Turn on the firewall. This is a must.

Click on ctrl + alt + T ....that will open the Terminal (or you can find it from the menu....just type in terminal and then click on it

When you have Terminal open, copy and paste the code below in and hit enter.....then put in your password and hit enter again

Code:
sudo ufw enable


Thats it.
I would actually recommend using an AV scanner on Linux. I use clamav myself. It does miss a lot, but catches some things, mostly false positives. You might be surprised by just what can be done in Linux. Those setuid to root programs can be buggy which can create serious security issues.

A firewall is certainly sound advice. I would suggest nftables, but limit access to it to root alone. The netfilters part of the Linux kernel has still been having some problems. Malware can get onto your system a number of different ways. You might visit a malicious website which might cause you to download something. Since you're already logged into the system it won't need your password.

Signed,

Matthew Campbell
 
If your Linux system is using shadow passwords then your password will be stored in /etc/shadow rather than /etc/passwd. Having physical access to the computer hardware is perhaps the greatest security vulnerability available. If you can connect your hard drive to another computer and mount it you can access these files without needing the root password for the Linux system. So if you boot your computer with the installation CD and ask for a command shell you can mount your hard drive, in the same computer, and change your passwords for root and other users at will. Just use a text editor to modify the /etc/shadow file as needed to let yourself back in.

Signed,

Matthew Campbell
 
Welcome @wm460 ,
I have been using LinuxMint for close to 10 years. Have not used any anti-virus programs whatever. Also, I have not ever had even a hint of a virus or malware.
That said, I do not visit weird or oddball websites. I do all the updates that are offered on a daily basis. One of the nice things is that I can keep working on whatever I am doing while the updates take place, so updating the system does not interfere with my productivity at all.
That's just my experience for what it's worth.
Old Geezer,
Tango Charlie
 
Last edited:
Big problems, I have been changing all the passwords on my phone and writing them in a notebook including the root password etc for my computer.
I left it on the coffee table and some horrible black mutt decided to shred it, we salvaged some but couldn't find the root p/word.
Is there any way to change it?
 
which.. root/admin or user?
 

Members online


Top