• Important: We recently upgraded our forum software - please let us know if you run into any issues.

Get the error "The 'grub-efi-amd64-signed' package failed to install into /target/" in Mint 19 [Solved]

Tzalim

New Member
Hey, nice to meet yaw! I'm new but not to Linux.

Ok, I got the error "The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB bootloader, the installed system will not boot." Well, here goes... I love Linux Mint, tried others always came back to Mint. Mint 18.3, grub installed fine. I want to install Mint 19.1 but can't because of the above error. It installs fine up until I get to grub2. I've been researching how to go about this but it seems as though there could be several reasons why. I'm just installing Linux Mint and nothing else. I'm extremely agitated to why Mint 18 installs fine but Mint 19 doesn't. I've tried near about everything that I know how to. I've tried looking at Youtube videos, reading forum posts on different sites, did pretty much everything that they said but I still can't install Mint 19. I'm kinda intermediate in Linux. Knows just enough to get into trouble, lol. This whole grub2 thing just through me for a spin. My laptop only has one drive, the checksum is fine, I'm using 64-bit, tried installing with and without internet and even installed and ran 'boot-repair' 3 or 4 times. I ran it before and after the error shows up and in different ways of doing that. Nothing works. In case you want to know, I've got Secure Boot disabled. I took a few commands from this link https://www.linux.org/threads/grub-install-failed.18663 and put into the terminal: cd /sys/firmware/efi and sudo fdisk -l | grep -i "disklabel".

Found out that I am using EFI.
Code:
sudo fdisk -l | grep -i "disklabel"
Disklable type: gpt
Disklable type: dos
Here's my latest paste from boot-repair where it failed at grub2: paste.ubuntu.com/p/HZCgBRBWdp/
I don't know if that's even relevant or not.

Thanks!
 


Condobloke

Well-Known Member
G'day Tzalim, and Welcome to Linux.org
Are we to assume you are using a bootable usb/thumb drive ?
You can boot the thumb drive successfully ?....and LM 19.1 runs ok from the thumb drive itself ?
When you click on the "Install" icon on the desktop and LM 19.1 installs.......where are you choosing to install mint ....?......what choices are you shown ?.....are you taking the thumb drive out of the usb port upon completion ?.....or are you not getting that far before the error presents itself ?
...
 

Tzalim

New Member
Hello Condo,


Yes, I'm using a USB drive. Yes, I can boot successfully to my USB drive and installation for Mint 19 goes good until I get to the grub2 boot-loader error. I don't get your question when you said 'where are you choosing to install mint', I took up the whole hard drive. I didn't install alongside anything. When I installed 'boot-repair' on live USB after grub2 failed, the program told me you can try this again but this time open gParted and take off all the partitions and then add a new partition with 100MB to 250MB and flag it with the boot flag. Didn't work but the installer said before I installed to live USB the boot-repair the options to install alongside of Linux Mint 18.3 but I did boot-repair and so I didn't have anything to install alongside of. So, to get to your question, it just had 1 option to install Mint 19.1. It never did complete, it always stopped/error on grub2. So the installer crashed in grub2.
 

Condobloke

Well-Known Member
Does THIS have any joy for you ?

....or THIS
 

Tzalim

New Member
Hello,

That first link http://linuxbsdos.com/ didn't work for me. I thought that too, that it would find the files it needed if it went online but nope.
The second link https://www.learningpenguin.net/amp/ I thought would but I had to the 3rd step first and the 2nd step next and the main partition. Did all that and it got a little bit further and had a fatal error... The error was "Executing 'grub-install /dev/sda' failed". This is a fatal error.

I went into my boot menu to see the 'secure boot,' was disabled like I thought and it was.
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
G'day @Tzalim , and Welcome to Linux.org :p

(Yes, Brian and I are both Aussies)

Mate, your output for

Code:
sudo fdisk -l | grep -i "disklabel"
has me interested, because of the dual references to gpt AND dos.

Is this two drives, involved?

Why I ask, I'll let you know a little of my config.

It's a Dell Inspiron deployed last July, has a 256 GB SSD, and a 2 TB HDD. I also have a 4 TB WD My Book, powered, USB 3.0 always hooked in, and on that I have about 35 LInux.

Both the internal drives were GPT to start with, and I have UEFI. Because of my work here, I help a lot of people with older computers (BIOS-MBR) (and MBR is also called MSDOS, somewhat wrongly), so I converted the 2 TB internal to old-style, and I am currently wrting from my Lubuntu there.

So my output for

Code:
sudo fdisk -l | grep -i "disklabel"
is as follows

Code:
[email protected]:/home/chris# fdisk -l | grep -i "disklabel"
Disklabel type: dos
Disklabel type: gpt
Disklabel type: gpt
... which lists the internal 2 TB, and then the other 2.

I wonder then, whether you are trying to install under the wrong setup?

Wizard
 

Tzalim

New Member
Hello wizard, nice to meet you! I don't know to much about the bios. Just know how boot up options and how to disable secure boot. No, only one hard drive. I thought it was weird too about the disk label but like I said, don't know to much about bios. I forgot to say my my laptop is an hp pavilion. It is about 2 yrs old. But going back to your question, should it be gpt and then dos? I don't know. It was originally a windows 10 user and I got tired of all the bigger updates like the community update and the anniversary update etc, I had a few things disabled but every time I installed one of those updates it re-enabled the ones I had disabled. So, I found Linux Mint and never looked back. I installed other distros but always came back to to Mint cause it worked out of the box, well until this problem. But like I said in my first post, 18.3 installed fine... No hiccups but 19.1 is giving me problems.
 
Last edited:

Tzalim

New Member
Since I don't know how XenForo does its edits, I'm going to try making a new reply...

As I was researching my error I just noticed that while Mint 18 supports MDM display manager 19 doesn't, it has LightDM display manager. I don't know if this is gonna work but let's see if I upgrade Mint 18.3 to 19.1 if it will work. I'll come back to tell you if it did or not. Since idk if grub2 has anything to do with the display manager.

Well that didn't work... Even tried legacy didn't work either.
 
Last edited:

Tzalim

New Member
I got mint 19 installed and working... By doing:
Code:
sudo mkdir -p /mnt/boot/efi
sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys; do sudo mount -B $i /mnt$i; done
sudo chroot /mnt
sudo apt-get update
sudo apt-get install ubuntu-system-adjustments
apt install --reinstall grub-efi-amd64-signed
sudo os-prober
sudo update-grub
exit
Thx for all the help, I really appreciate it!
 

wizardfromoz

Super Moderator
Staff member
Gold Supporter
Well the Aussies like it, Legend :D

I haven't used the mkdir -p (--parents) option before, useful.

Some of the pundits say that with

/dev /dev/pts /proc /sys

... we should umount them on the way out (after exiting chroot) but I have no solid opinion either way, haven't experienced any dramas without doing so.

Now would be a good time to familiarise yourself with Timeshift, it's on your LM19 if you have not used it before, see my Thread at

https://www.linux.org/threads/timeshift-similar-solutions-safeguard-recover-your-linux.15241/

Enjoy your Linux :cool:

Wiz
 

Members online

No members online now.

Top