Fix disk and volume manager configurations for a cloned server


New Member
Nov 6, 2021
Reaction score
I have cloned a physical server that has Enterprise Linux version as the operating system with Clonezilla to a VMware virtual machine and the cloning completed successfully. However, I noticed two interesting messages during the cloning process.
  • The first one was on the physical server and it said something like "pv uses old naming format".
  • The second one on the destination virtual machine after the completing the cloning said "clonezilla couldn't run the command update initramfs because it was not found".
I thought everything finished smoothly until I rebooted the virtual machine. When the machine starts I get this error and it doesn't reboot.
boot error.jpeg

I'm not new to Linux but I'm not an expert either. So, from this message I figured out that the problem is GRUB can't find VG where the system is located. So, I started to search but i didn't find any helpful information and also tried many fixes but they all failed. Then I used a live cd to enter the hard drive to see if i can fix it manually which I believe it is the first step to the right solution. Now I will explain the scenario that is happening. on the physical server (the source) the hard drive is partitioned as follows:

        /dev/cciss/c0d0p1     (for boot)
        /dev/cciss/c0d0p2     (linux lvm)

The PV is already created and linked to c0d0p2. Under the PV there is a VG called VolGroup00 which contains 4 LVs (LogVol00 etc...). I will focus only on the first LV which contains the system. This LV mounted to the root directory "/" in the `fstab` file as follows:

/dev/VolGroup00/LogVol00          /

# I remembered the first message on the server from clonezilla that the PVs use old naming.

Grub conf file system also uses this file as root for kernel command. So, I figured out that the problem is related to the hard disk configuration because the new virtual machine has different specifications. So, I tried to change the grub configuration file and `fstab` file by using rescue mode through a live cd on the virtual machine but it didn't work and i think the system still needs more things to be configured. However I noticed on the live cd when I run `pvs` or `vgs` or `lvs` the commands print the old information that I can get from the source server but when I change the root(`chroot /mnt/sysimage`) the commands don't print anything. and I ran `lsblk` and this what I get:

lsblk - rescue.jpeg

I'm sorry for taking so long to explain the problem but I should be precise. So, I have a couple of questions:

1. Is this problem related to the `update-initramfs -u` command? If yes, should I run it on the live CD or after `chroot /mnt/sysimage` And what should I do if the command can't be found on the system.

2. If the live cd was able to `mount` the LV to `/mnt/sysimage`, how can I mount `LogVol00` to the root directory in `/dev/sda2` if that is the problem?

3. When I run `pvs` in the live cd shell it prints the PVs but when I change the root to `/mnt/sysimage` the command doesn't show them. What should I do to fix that?

Staff online