Finlux FIN32BASEBK screen suddenly can't be found


New Member
Apr 6, 2020
Reaction score
My computer suddenly thinks that my screen is a Vestel Eleltronik Sanayi ve Ticaret, but it isn't. It is a Finlux.

The result is that the main screen picture is sort of too big for the actual screen, so that icons are not along the borders, but slightly outside the borders, and I can't see them. Link to screnshot of bottom of screen
What I tried: it happened around when I updated to Uma. So I have now tried to update to Una, and going back to Ulyana and Ulyssa. I tried all the resolution playing around, including fractions. Currenlty on Linuc Mint Cinnamon Ulyana (that worked excellent before), and if I have the energy I will update to Una again tomorrow.

EDIT: OK, It seems Finlux is now owned by Vestel, so it is maybe not so wrong. Then it is even more confusing. I had a virus, for the first time in thirty years of owning computers, and I couldn't see the commands for restore, and had to just install everything again. Thankfully I was planning to do it anywaym but there was some back-up I had not done properly. And I still have the same problem.

Theory: It seems my TV-screen was set on automatic update. I didn't know there was somethin to be updated. Could it be that it is the update of the screen that has made it like this? What shall I do?

Mac mini from 2009 without a screen, coupled with a Finlux TV screen FIN32BASEBK
Last edited:

@Toove hello again :)

My apologies, your Thread and thus the first Post was held in Limbo for nearly 36 hours, and just came across my desk for Approval (which was not really needed), perhaps stimulated by your editing something.

It must have been a software glitch and I cannot account for it. Regrets.

Not my area of expertise, but maybe one of our good folks can help this lady?


Chris Turner
Oh, that's OK:) I already asked a similar question, and nobody knew the answer, but then I thought that I knew the answer, which turned out to be wrong. :p
It has been solved. Very easily: Advanced settings with the remote on the screen itself, go a bit back and forth, and voilà! Suddenly it was fine.

Members online