Fedora 36 kernel 5.18.5 failed to detect RTL 8188 eu wifi adapter while previous kernels working.

rupeshforu3

New Member
Joined
Feb 28, 2022
Messages
28
Reaction score
1
Credits
377
Hi I am Rupesh from India and I have a pc with Intel i3 10th gen processor and asus prime h 510 me motherboard including coconut wa04 wifi adapter which has RTL 8188 chip. I have installed Fedora 36 at the time it was released. Upto yesterday I have been able to browse internet and after updating my system failed to browse internet.

Upto now I have updated my system upto 5 times and the last kernel version installed was 5.17.13-300.fc36.x86_64 and the new kernel version installed is 5.18..5-200.fc36.x86_64.

Upto kernel versions 5.17 I am able to browse internet and install latest packages but at present while using kernel version 5.18 I am unable to browse internet. I have issued the command dmesg to see any errors and the output is

Code:
 [[email protected] ~]$ dmesg --level=err
[    0.128505] x86/cpu: SGX disabled by BIOS.
[    5.349119] r8188eu 1-9:1.0: _rtw_init_xmit_priv failed
[[email protected] ~]$

I have found upto 17 packages starting with word iwl which stands for intel wireless internet. What is the need of such packages and can I delete them.

As my system has 3 kernels I am able to browse internet while using previous kernels and not in latest new kernel.

Please try to suggest how to browse internet while using latest new kernel.

Regards,
Rupesh.
 


Brickwizard

Well-Known Member
Joined
Apr 28, 2021
Messages
2,836
Reaction score
1,845
Credits
21,165
OP
R

rupeshforu3

New Member
Joined
Feb 28, 2022
Messages
28
Reaction score
1
Credits
377
You need to enable the software guard extension in the UEFI.
May I know how to do so I have enabled secure boot and I have seen messages related to secure boot and it's showing as secure boot has been enabled.

When I select the latest new kernel it's showing some error message and I can't see properly because with in few seconds it's being disappeared and the os is booting. Previously while using previous older kernels I have not seen such. Here these messages are shown after I select latest kernel in grub2 menu.
 

dos2unix

Well-Known Member
Joined
May 3, 2019
Messages
1,472
Reaction score
1,074
Credits
9,160
May I know how to do so I have enabled secure boot and I have seen messages related to secure boot and it's showing as secure boot has been enabled.

Usually you press the [Delete] or [ESC] key during boot up. Sometimes it's [F2] it just depends on the manufacturer.
Usually you will have a series of tabs. One will likely say BOOT, and another might say SECURITY.
There is probably a checkbox or something you can disable under secure boot. It's usually similar for the
Software Guard either under boot or Security. Sometimes it's simply under advanced settings.
 

KGIII

Super Moderator
Staff member
Gold Supporter
Joined
Jul 23, 2020
Messages
6,713
Reaction score
5,862
Credits
54,055
$100 Digital Ocean Credit
Get a free VM to test out Linux!

Linux.org Hosting Donations
Consider making a donation

Members online


Top